I n t r o d u c t i o n

전천후 HTML사전은 초보자를 위한 HTML4.0 태그 안내서입니다. 사전이라고 부르기에는 모든 HTML요소에 대한 설명이 간략하지만, 곁에 두고 다양한 태그들과 친숙해질 수 있으리라 기대합니다.
보다 숙련된 HTML 사용자가 되려면, 더 자세한 설명과 풍부한 예제를 제공하는 참고서가 필요합니다.

이 전천후태그사전만으로도 HTML을 쉽게 배우고 활용할 수 있도록 업데이트 노력을 계속하겠습니다.

이 글은 w3master@sanyaro.com이 작성하였고, bestsouth@korea.com이 편집과 입력 작업을 하였습니다.


HTML 4.0 Full

HTML4.0 Full |
HTML 4.0 Full | .
<A> <ACORONYM> <ADDRESS> <APPLET> <AREA> <B> <BASE> <BASEFONT> <BIG> <BLOCKQUOTE> <BODY> <BR> <BDO> <CAPTION> <CENTER> <CITE> <CODE> <COL> <COLGROUP> <DD> <DEL> <DFN> <DIR> <DIV> <DL> <DT> <EM> <FIELDSET> <FONT> <FORM> <FRAME> <FRAMESET> <H1~6> <HEAD> <HR> <HTML> <I> <IFRAME> <IMG> <INPUT> <INS> <ISINDEX> <KBD> <LABEL> <LEGEND> <LI> <LINK> <MAP> <MENU> <META> <NOFRAMES> <OBJECT> <OL> <OPTION> <P> <PARAM> <PRE> <Q> <S> <SAMP> <SCRIPT> <SELECT> <SMALL> <SPAN> <STRIKE> <STRONG> <SUB> <SUP> <TABLE> <TBODY> <TD> <TEXTAREA> <TFOOT> <TH> <THEAD> <TITLE> <TR> <TT> <U> <UL> <VAR>


Explorer Only

.

아래의 HTML요소들은 모두 인터넷 익스플로러에서만 지원되는 것들이므로 HTML문서에 실제로 사용하면, 넷스케이프 사용자는 만든이의 의도와 달리 엉뚱한 문서를 접할 수도 있다. 따라서 아래의 요소를 꼭 사용한다면, 넷스케이프와의 호환성을 신중히 고려하여야만 한다.


Netscape Only

.

아래의 HTML요소들은 모두 넷스케이프 커뮤니케이터에서만 지원되는 것들이므로 HTML문서에 실제로 사용하면, 익스플로러 사용자는 만든이의 의도와 달리 엉뚱한 문서를 접할 수도 있다. 따라서 아래의 요소를 꼭 사용한다면, 익스플로러와의 호환성을 신중히 고려하여야만 한다.


CROSS-BROWSER HTML4.0

. .

¾Æ·¡ÀÇ °¢ ¿ä¼ÒElementsµéÀº ³Ý½ºÄÉÀÌÇÁ¿Í ÀÍ½ºÇÃ·Î·¯¿¡¼ °øÅëÀ¸·Î »ç¿ëÇÒ ¼ö ÀÖ´Â HTML4.0ÀÌ´Ù.

<A>

HREF
NAME
TARGET

<ADDRESS>

<APPLET>
ALIGN
ALT
CODE
CODEBASE
HEIGHT
HSPACE
NAME
SRC
WIDTH

<AREA>

ALT
COORDS
HREF
NAME
SHAPE
TARGET

<B>

<BASE>

HREF
TARGET

<BASEFONT>

COLOR
SIZE

<BIG>

<BLOCKQUOTE>

<BODY>

ALINK
BACKGROUND
BGCOLOR
LINK
TEXT
VLINK

<BR>

CLEAR

<CAPTION>

ALIGN
VALIGN

<CENTER>

<CITE>

<CODE>

<COMMENT>

<DD>

<DIR>

<DIV>

ALIGN

<DL>

COMPACT

<DT>

<EM>

<EMBED>

ALIGN
ALT
BORDER
HSPACE
NAME
PALETTE
PLUGINSPACE V
SPACE

<FONT>

COLOR
FACE

<FORM>

ACTION
ENCTYPE
METHOD
NAME
TARGET

<FRAME>

BODERCOLOR
FRAMEBODER
FRAMSPACING
MARGINHEIGHT
MARGINWIDTH
NORESIZE
SCROLLING
SRC

<FRAMESET>

 BORDER
BORDERCOLOR
COLS
FRAMESPACING
ROWS

<H1~6>

<HEAD>

<HR>

ALIGN
COLOR
NOSHADE
SIZE
WIDTH

<HTML>

<I>

<IMG>

ALIGN
ALT
BODER
HEIGHT
HSPACE
ISMAP
LOWSRC
NAME
SRC
USEMAP
VSPACE
WIDTH

<INPUT>

ALIGN
CHECKED
MAXLENGTH
NAME
SIZE
TYPE
VALUE

<KBD>

<LI>

TYPE

<LINK>

HREF
REL
TYPENAME

<LISTING>

<MAP>

NAME

<MENU>

<META>

CONTENT
HTTP-EQUIV
NAME

<OL>

START
TYPE

<OPTION>

NAME
SELECTED
TYPE
VALUE

<P>

ALIGN

<PARAM>

NAME
VALUE

<PLAINTEXT>
<PRE>

WIDTH

<S>

<SAMP>

<SELECT>

ALIGN
MULTIPLE
NAME
SIZE
TYPE

<SMALL>
<STRIKE>

<STRONG>

<STYLE>

DISABLE
MEDIA
TYPE

<SUB>

<SUP>

<TABLE>

ALIGN
BACKGROUND
BGCOLOR
BODER
BODERCOLOR
CELLPADDING
CELLSPACING
FRAME
HEIGHT
RULES
VALIGN
WIDTH

<TD>

ALIGN
BACKGROUND
BGCOLOR
BODERCOLOR
COLSPAN
HEIGHT
VALIGN
WIDTH

<TEXTAREA>

ALIGN
COLS
NAME
WRAP

<TH>

ALIGN
BACKGROUND
BGCOLOR
BODERCOLOR
COLSPAN
HEIGHT
NOWRAP
ROWSPAN
VALIGN
WIDTH

<TITLE>
<TR>

ALIGN
BGCOLOR
BODERCOLOR
VALIGN

<TT>

<U>

<UL>

TYPE

<VAR>

<XMP>


ÃÑ¸ñ·Ï

. .

HTML 4.0 Full

 .

<A>

HREF
NAME
TARGET new

<ACORONYM> Explorer4.0 Only

<ADDRESS>

<APPLET>

ALIGN
ALT
ARCHIVE . ...Netscape Only
CODE
CODEBASE
HEIGHT
HSPACE
NAME
SRC
WIDTH

<AREA>

ALT
COORDS
HREF
NAME
SHAPE
TARGET

<B>

<BASE>

HREF
TARGET

<BASEFONT> new

COLOR new
FACE ...Explorer Only
SIZE ....new

<BIG>

<BLOCKQUOTE>

<BODY>

ALINK
BACKGROUND
BGCOLOR
BGPROPERTIES .Explorer Only
BOTTOMMARGIN Explorer4.0 Only
LEFTMARGIN ......Explorer Only
LINK
RIGHTMARGIN ....Explorer4.0 Only
SCROLL .............Explorer4.0 Only
TEXT
TOPMARGIN .......Explorer4.0 Only

<BR>

CLEAR

<BUTTON> Explorer4.0 Only

ACCESSKEY
DATAFLD
DATAFORMATAS
DATASRC
DISABLED
TYPE

<CAPTION>

ALIGN
VALIGN new

<CENTER>

<CITE>

<CODE>

<COL> Explorer Only

ALIGN ..new
VALIGN new

<COLGROUP> Explorer Only

ALIGN ...new
SPAN ...new
VALIGN new
WIDTH .new

<DD>

<DEL> Explorer4.0 Only

CITE
DATETIME

<DFN> Explorer Only

<DIR>

<DIV>

ALIGN
DATAFLD ............Explorer4.0 Only
DATAFORMATAS Explorer4.0 Only
DATASRC ...........Explorer4.0 Only
COMPACT

<DL>

<DT>

<EM>

<FIELDSET> Explorer4.0 Only

<FONT>

COLOR
FACE
POINT-SIZE Netscape4.0 Only
SIZE
WEIGHT ......Netscape4.0 Only

<FORM>

ACTION
ENCTYPE
METHOD
NAME
TARGET

<FRAME> new

BORDERCOLOR
DATAFLD ............Explorer4.0 Only
DATASRC ...........Explorer4.0 Only
FRAMEBORDER
FRAMESPACING
MARGINHEIGHT
MARGINWIDTH
NORESIZE
SCROLLING
SRC

<FRAMESET> new

BORDER
BORDERCOLOR
COLS
FRAMEBORDER
FRAMESPACING
ROWS

<H1~6>

ALIGN

<HEAD>

<HR>

ALIGN
COLOR
NOSHADE
SIZE
WIDTH

<HTML>

<I>

<IFRAME> Explorer4.0 Only

ALIGN
BORDER
BORDERCOLOR
DATAFLD DATASRC
FRAMEBORDER
HEIGHT
HSPACE
NAME
SCROLLING
SRC
VSPACE
WIDTH

<IMG>

ALIGN
ALT
BORDER
CONTROLS ..Explorer Only
DATAFLD ......Explorer Only
DATASRC .....Explorer Only
DYNSRC .......Explorer Only
HEIGHT
HSPACE
ISMAP
LOOP ...........Explorer Only
LOOPDELAY .Explorer Only
LOWSRC
NAME
SRC
START ..........Explorer Only
USEMAP
VRML ............Explorer Only
VSPACE
WIDTH

<INPUT>

ACCESSKEY ........Explorer4.0 Only
ALIGN
CHECKED
DATAFLD .............Explorer4.0 Only
DATAFORMATAS .Explorer4.0 Only
DATASRC ............Explorer4.0 Only
DISABLED ............Explorer4.0 Only
MAXLENGTH
NAME
READONLY ..........Explorer4.0 Only
SIZE
SRC
TABINDEX ............Explorer4.0 Only
TYPE
VALUE

<INS> Explorer4.0 Only

CITE
DATETIME

<ISINDEX>

ACTION
PROMPT

<KBD>

<LABEL> Explorer4.0 Only

<LEGEND> Explorer4.0 Only

ALIGN

<LI>

<LINK>

DISABLED Explorer Only
HREF

<MAP>

NAME

<MENU>

<META>

CONTENT
HTTP-EQUIV
NAME

<NOFRAMES>

<OBJECT> Explorer4.0 Only

<OL>

 START
TYPE

<OPTION>

NAME
SELECTED
TYPE
VALUE

<P>

ALIGN

<PARAM>

DATAFLD Explorer4.0 Only

 <PRE>

WIDTH

<Q> Explorer4.0 Only

CITE

<S>

<SAMP>

<SCRIPT>

<SELECT>

ACCESSKEY .Explorer4.0 Only
ALIGN
DATAFLD ......Explorer4.0 Only
SIZE
TABINDEX ....Explorer4.0 Only
TYPE ......... .new

<SMALL>

<SPAN>

DATAFLD .............Explorer4.0 Only
DATAFORMATAS .Explorer4.0 Only
DATASRC ............Explorer4.0 Only
DIR ......................Explorer Only

<STRIKE>

<STRONG>

<STYLE>

DISABLED .new
MEDIA .......new
TYPE ..... ..new

<SUB>

<SUP>

<TABLE>

ALIGN
BACKGROUND
BGCOLOR
BORDER
BORDERCOLOR
BORDERCOLORDARK ..Explorer Only
BORDERCOLORLIGHT .Explorer Only
CELLPADDING
CELLSPACING
COLS ..........................Explorer Only
DATAFLD .....................Explorer4.0 Only
DATAPAGESIZE ...........Explorer4.0 Only
DATASRC ....................Explorer4.0 Only
FRAME
HEIGHT
RULES
VALIGN
WIDTH

<TBODY> Explorer Only

ALIGN
BGCOLOR
VALIGN

<TD>

ALIGN
BACKGROUND
BGCOLOR
BORDERCOLOR
BORDERCOLORDARK ..Explorer4.0 Only
BORDERCOLORLIGHT .Explorer4.0 Only
COLSPAN
HEIGHT
NOWRAP
ROWSPAN
VALIGN
WIDTH

<TEXTAREA>

CCESSKEY .Explorer4.0 Only
ALIGN
COLS
DATAFLD ....Explorer4.0 Only
DATASRC ...Explorer4.0 Only
DISABLED ...Explorer4.0 Only
NAME
READONLY .Explorer4.0 Only
ROWS
TABINDEX ...Explorer4.0 Only
WRAP

<TFOOT> Explorer Only

ALIGN ........new
BGCOLOR .new
VALIGN ......new

<TH>

ALIGN .........................3.2
BACKGROUND ............IEx 3.0
BGCOLOR ...................IEx 3.0
BORDERCOLOR ..........IEx 3.0
BORDERCOLORDARK ..IEx 3.0
BORDERCOLORLIGHT .IEx 3.0
COLSPAN ....................3.2
HEIGHT ........................3.2
NOWRAP .....................3.2
ROWSPAN ...................3.2
VALIGN ........................3.2
WIDTH .........................3.2

<THEAD> Explorer Only

ALIGN
BGCOLOR
VALIGN

<TITLE>
<TR>

ALIGN
BACKGROUND ............Netscape Only
BGCOLOR
BORDERCOLOR
BORDERCOLORDARK ..Explorer Only
BORDERCOLORLIGHT .Explorer Only
VALIGN

<TT>

<U>

<UL>

TYPE

<VAR>

Explorer Only

 .

<BGSOUND>

BALANCE
LOOP
SRC
VOLUME

<MARQUEE>

ALIGN
BEHAVIOR
BGCOLOR
DATAFLD
DATAFORMATAS
DATASRC
DIRECTION
HEIGHT
SCROLLDELAY
TRUESPEED
VSPACE
WIDTH

Netscape Only

 .

<BLINK>

<ILAYER> Netscape4.0 Only

ABOVE
BACKGROUND
BELOW
BGCOLOR
LEFT
NAME
SRC
TOP
VISIBILITY
WIDTH
Z-INDEX

<KEYGEN>

CHALLENGE
NAME

<LAYER> Netscape4.0 Only

ABOVE
BACKGROUND
BELOW
BGCOLOR
SRC
TOP
VISIBILITY
WIDTH
Z-INDEX

<MULTICOL>

COLS
GUTTER
ALIGN
BORDER
CLASSID
CODE
CODEBASE
HEIGHT
HSPACE
NAME

<SPACER>

ALIGN
HEIGHT
SIZE
TYPE
WIDTH

HTML4.0¿¡ Æ÷ÇÔµÇÁö ¾ÊÁö¸¸
....IE¿Í NS°¡ »ç¿ëÇÏ´Â ¿ä¼Òµé

 . .

<COMMENT>

<XMP>

<PLAINTEXT>

<LISTING>

<EMBED>

ALIGN
ALT
BORDER
HIDDEN
HSPACE
NAME
PALETTE
PLUGINSPACE
VSPACE

HTML4.0¿¡ Æ÷ÇÔµÇÁö¸¸
....IE¿Í NS°¡ »ç¿ëÇÏÁö ¾Ê´Â ¿ä¼Òµé


ÀüÃµÈÄ HTML 4.0 ÅÂ±×»çÀü

ÀüÃµÈÄ HTML 4.0 ÅÂ±×»çÀü | .
ÃÑ¸ñ·Ï |
HTML4.0 Full |
CROSS-BROWSER HTML4.0 |
Netscape Only |
Explorer Only |


<A>

<A> HREF, NAME, TARGET

쪽넘기 요소Anchor element는 HTML의 핵심이며, <A>로 그 기능을 설정한다. <A> 요소에 부가적으로 사용되는 것들은 다음과 같은데, 기본적으로 다른 문서나 한 문서에서 다른 곳으로 이동할 때에 사용한다.

HREF, NAME

쪽넘기Anchor는 다음과 같은 형식으로 사용한다.

<A HREF="http://soback.kornet21.net/~ykwoo3">Woolee's HTML+CSS</A>

위는 특정 주소의 문서로 옮겨갈 때의 경우이고 동일한 디렉토리의 다른 문서의 특정 부분으로 옮겨갈 때에는 아래와 같이 표시한다.

<A href="same.html#넘기">넘기</A>

이 경우에는 same.html의 내용중 '넘기'라는 낱말이 있는 곳으로 이동하는데, 이 때 same.html의 '넘기'는 다음과 같이 표시되어 있어야 한다.

<A NAME="넘기">넘기</A>

또, 동일문서내에서 다른 위치로 옮겨갈 때에는

<A HREF="#건너뛰기">건너뛰기</A>로 건너 뛸 위치를 지정하고,

건너 뛸 목표는

<A NAME="건너뛰기">건너뛰기</A>로 표시한다.

TARGET

이것은 <frame>요소Element와 함께 사용한다.

<A HREF="new.html" TARGET="window_name">덧창</A>

위에서

window_name

은 사용자가 임의로 정하는 이름이고, 이는 해당 프레임의 이름이다.

<frame src="etop.html" scrolling="NO" noresize marginheight="0" marginwidth="0" border="0" name="top">

따라서 위의 예에서 new.html 문서는 사용자가 이름을 정한 프레임 안으로 호출된다.


<ACRONYM>

<ACRONYM>

이 요소는 그 안에 묶여 있는 내용의 속성을 알려주기 위해 만들어졌다. 이러한 필요는 다양한 종류의 브라우저를 전제로 할 때, 모든 브라우저가 해당 기능을 전부 지원하지 않을 것이 예상되기 때문이다.

TITLE

쪽넘기Anchor는 다음과 같은 형식으로 사용한다.

<ACRONYM TITLE="HyperText Markup Language">HTML</ACRONYM>

위의 경우는 마우스의 커서가 이 요소안의 내용위로 가면,
'HyperText Markup Language'라는 풍선도움말 informational ToolTip이 나타난다.

LANG = "언어"

이 속성은 이 요소안의 글이 어떤 종류의 말인가를 지정할 때에 사용한다. 물론 ISO standard language 로 표준화된 형식이어야 한다.

LANGUAGE = "Scripting language"

vbscript, vbs, javascript or jscript등의 스크립에 사용되는 프로그램 언어를 지정한다.

CLASS = "Style Sheet의 class명칭"

이것은 스타일 시트의 CLASS를 지정할 때에 사용하는 속성이다.


<ADDRESS>

<ADDRESS>

이것은 주소를 표시할 때 사용하는데, 글꼴은 이탤릭체로 나타난다. 영어를 전제로 만들어진 요소로 한글에서는 별반 다른 효과를 기대할 수는 없다.

<ADDRESS>
대한민국 <BR>
경기도 양평군 양평읍 대흥1리<BR>
000-00
</ADDRESS>

위처럼 하면 다음과 같이 나타난다.

대한민국
경기도 양평군 양평읍 대흥1리
000-00


<APPLET>

<APPLET> ALIGN, ALT, CODE, CODEBASE, HEIGHT, HSPACE, NAME, SRC, WIDTH

이것은 자바 애플릿pre-compiled HotJava applets을 HTML에 삽입할 때 사용한다. 자바 애플릿을 만드는 방법에 대해서는

http://java.sun.com/

http://www.microsoft.com/java/

위의 두 사이트에서 정보를 얻을 수 있다.

이것의 간단한 보기는 다음과 같다.

<APPLET CODE="java.class" WIDTH=200 HEIGHT=100></APPLET>

위는 해당 HTML과 같은 디렉토리에 있는 java.class를 가로 200px, 세로 100px로 실행하는 경우이다.

좀더 복잡한 보기를 들면 다음과 같은데,

<APPLET CODEBASE="http://www.any.where/applets/ animate" CODE="animate.class" width=400 height=75 align=center>
</APPLET>

이것은 http://www.any.where/applets/ animate의 주소에 있는 animate.class를 실행하는 경우이다.

부가적으로 사용되는 속성을 살펴보면 다음과 같다.

ALIGN=위치(left, right, top, texttop, middle, absmiddle, baseline, bottom, absbottom)

이것은 <IMG> 요소Element의 위치를 지정하는 방법과 동일하다.

ALT=주석

applet이 실행되지 않을 경우에 대비해 해당 위치에 일반 글Text로 설명을 다는 데에 사용한다.

CODE=파일applet File

실행될 파일의 이름을 지정한다.

CODEBASE=URL

applet이 있는 위치(주소)를 지정한다. 해당 HTML문서와 같은 디렉토리에 있는 경우에는 필요하지 않다.

HEIGHT=pixels WIDTH=pixels

applet이 실행될 때의 크기를 지정한다.

HSPACE=pixels VSPACE=pixels

이것은 applet의 위와 아래(VSPACE), 그리고 좌우(HSPACE)에 공백을 지정할 때에 사용한다. <IMG>의 VSPACE, HSPACE와 같다.

NAME=applet의 이름

같은 문서내에서 applet을 구분하고, 서로 관련지을 때에 사용한다.

SRC=URL

applet과 관련된 주소를 지정할 때에 사용한다.


<AREA>

<AREA>=<MAP>
ALT
COORDS
HREF
NAME
SHAPE
TARGET


<B>

<B>

ÀÌ°ÍÀº Æ¯Á¤ ±ÛÀ» ±½°í ÁøÇÏ°Ô Ç¥½ÃÇÒ ¶§¿¡ »ç¿ëÇÑ´Ù.

´ÙÀ½Àº <B>±½Àº ±ÛÀÌ´Ù.</B>

´ÙÀ½Àº ±½Àº ±ÛÀÌ´Ù.


<BASE>

<BASE> HREF, TARGET

이것은 특정 홈페이지의 기본(시작)이 되는 주소를 지정할 때에 사용하는데, <HEAD>부분에 위치해야만 한다. 이는 웹호스팅 서비스를 받을 때, 인덱스 페이지(index.html)에 (호스팅 받는 도메인과는 다른)해당 서비스 업체가 제공하는 고유 주소를 넣도록 하는 경우에 쓰인다. 하지만 그 경우에도 필요하지 않은 경우가 많다. 유영한 쓰임새가 있는 요소는 아니다.

HREF

<BASE HREF="http://www.user.com/">

이렇게 지정하면, 상대적인 주소relative URLs를 문서내에서 자유롭게 사용할 수 있다.

TARGET

<BASE TARGET="default_target">


<BASEFONT>

<BASEFONT> SIZE

ÀÌ°ÍÀº ¹®¼ÀÇ ±Û²ÃÅ©±âFont Size¸¦ Á¤ÇÒ ¶§¿¡ »ç¿ëÇÏ´Âµ¥, <HEAD> ºÎºÐ¿¡ À§Ä¡ÇÒ ÇÊ¿ä´Â ¾ø´Ù. ÃÊ±â°ªDefault ValueÀº 3ÀÌ°í, 1¿¡¼ 7±îÁö °¡´ÉÇÏ´Ù.

SIZE

<BASEFONT SIZE=5>


<BDO>

<BDO>

ÀÌ ¿ä¼Ò´Â ÇöÀç ¾î¶² ºê¶ó¿ìÀú¿¡¼µµ »ç¿ëµÇ°í ÀÖÁö ¾Ê´Â HTML4.0ÀÇ ¼Ó¼ºÀÌ´Ù.


<BGSOUND>

<BGSOUND>

.WAV나 .AU 형식format 또는 MIDI( .MID 형식)의 음악을 HTML에서 배경음악background sound으로 연주되도록 할 때에 사용한다. 그런데, 익스플로러는 현재 넷스케이프의 <EMBED>를 완전히 지원하고 있으므로 굳이 넷스케이가 지원하지 않는 <BGSOUND>를 사용할 이유는없다.


<BIG>

<BIG>

ÀÌ°ÍÀº ¹®¼ÀÇ Æ¯Á¤ºÎºÐÀ» ´Ù¸¥ ºÎºÐº¸´Ù Å©°Ô ³ªÅ¸³¾ ¶§¿¡ »ç¿ëÇÑ´Ù.

´ÙÀ½Àº <BIG>Å©°Ô</BIG> º¸ÀÏ °ÍÀÌ´Ù.

´ÙÀ½Àº Å©°Ô º¸ÀÏ °ÍÀÌ´Ù.


<BLINK>

<BLINK>

±ÛÀÚ³ª ¹®ÀåÀ» ±ôºýÀÌ°Ô ÇÑ´Ù.


<Blockquote>

<Blockquote>

이 요소는 월래 인용문을 표시할 때 사용하도록 고안된 것이다. 문서 작성자가 소스를 보면서도 쉽게 자신이 작업한 내용을 쉽게 파악하도록 하기 위해서다. 하지만 인용문이 아니더라도 문서의 특정 부분을 들여쓰기 할 때에 주로 사용한다.

술 취한 시인이 말했다.
<BLOCKQUOTE>
"나는 술 마시는 것이 부끄러워 또 술을 마신다고 쓴 메모가 술을 마시고 나니 보인다. 술이 깨면 알아볼 수 없다."
</BLOCKQUOTE>
그는 그저 술꾼일 뿐이다.

라고 하면, 다음과 같이 나타난다.

술 취한 시인이 말했다.

"나는 술 마시는 것이 부끄러워 또 술을 마신다고 쓴 메모가 술을 마시고 나니 보인다. 술이 깨면 알아볼 수 없다."
그는 그저 술꾼일 뿐이다.


<BODY>

<BODY> ALINK,BACKGROUND, BGCOLOR, LINK, TEXT,VLINK

이것은 HTML문서의 본문에 해당한다.

이것의 간단한 보기는 다음과 같다.

<BODY>
이 안에 모든 문서내용이 들어간다.
</BODY>

BACKGROUND

문서의 바탕그림을 지정한다.

<BODY BACKGROUND="image.gif">

BGCOLOR

바탕색을 지정한다.

<BODY BGCOLOR="#ffffff">

TEXT

글꼴의 색깔을 지정한다.

<BODY TEXT="#000000">

LINK, VLINK=visited link, ALINK=acive link

<BODY LINK="blue" VLINK="red" ALINK="yellow'>

위처럼 하면, Link된 글은 파란색이고, 그것을 선택하면 노란색으로 바뀌며, 이미 방문했던 Link는 붉은 색으로 나타난다.

주의 : ALINK는 NS에서만 가능하다.

참고로 BGPROPERTIES=FIXED를 소개한다.

이는 IE에서만 가능한데,

<BODY BAKGROUND="image.git" BGPROPERTIES=FIXED>

위처럼 하면, 문서를 아래로 읽어가도 배경그림은 그대로 멈추어 있는 효과를 얻을 수 있다.


<BR>

<BR> CLEAR

이것은 줄바꾸기를 할 때 사용한다.

바람이 분다.<BR>구름이 몰려 온다.<BR>비가 내린다.<BR>

라고 하면, 다음과 같이 나타난다.

바람이 분다.
구름이 몰려 온다.
비가 내린다.

CLEAR=left

왼쪽에 그림Image가 있다면 그 그림의 높이만큼 줄바꾸기를 한다.

CLEAR=right

그림이 오른쪽에 있는 경우 그 그림의 높이만큼 줄바꾸기를 한다.

CLEAR=all

양쪽에 그림이 있을 때, 그 그림의 높이만큼 줄바꾸기를 한다.


<BUTTON>

<BUTTON> new

<BUTTON>

HTML문서에 단추BUTTON를 만든다.

<BUTTON name="reset" type="reset">단 추</BUTTON>

주의: <SELECT>, <A>또는 <INPUT>요소는 <BUTTON>안에 포함될 수 없다. 그리고 이 요소는 보통 HTML의 <form>을 이용하여 외부에서 CGI등을 불러들일 때 사용된다.


<CAPTION>

<CAPTION> ALIGN, VALIGN

<TABLE>¿¡ Á¦¸ñÀ» ´Þ ¶§¿¡ »ç¿ëÇÑ´Ù.

À§Ä¡´Â

<TABLE>

<CAPTION>...</CAPTION>

<TR>

... ...

</TABLE>

ÀÌ´Ù.


<CENTER>

<CENTER>

±×¸²ÀÌ³ª ¹®ÀåÀ» ¹®¼ Áß¾Ó¿¡ À§Ä¡ÇÏ°Ô ÇÑ´Ù.


<CITE>

<CITE>

인용Citation할 때에 사용한다.

속담에 <CITE>아니 땐 굴뚝에 연기나랴</CITE>라는 말이 있다.

라고 하면

속담에 아니 땐 굴뚝에 연기나랴 라는 말이 있다.

위처럼 이태릭체로 나타난다.


<CODE>

<CODE>

이것은 특정 내용(수학의 수식 등)이 한 줄에 다 나타나도록 한다. 이것은 미리 형태를 정해놓고 그대로 나타나도록 하는 <PRE>와는 구분된다.

덧셈 : <CODE>1 + 2 + 3 + 4 + 5 - 1 - 2 - 3 - 4 - 5 = 0</CODE>

라고 하면

덧셈 : 1 + 2 + 3 + 4 + 5 - 1 - 2 - 3 - 4 - 5 = 0

수식은 줄을 나누지 않고 한 줄에 다 표시된다.


<COL>

<COL> ALIGN, VALIGN, WIDTH, SPAN

이 요소는 <TABLE>의 각 칸column의 속성을 다양하게 그리고 일괄적으로 지정한다.

ALIGN = "center, justify, left, right"

이 속성은 칸안의 글의 좌우위치를 지정한다.

VALIGN = "baseline, bottom, middle, top"

이 속성은 칸안의 글의 상하위치를 지정한다.

WIDTH = "숫자"

칸의 길이를 지정한다.

SPAN = "숫자"

ALIGN, VALIGN, WIDTH에서 지정된 사항이 몇개의 칸에 적용될 것인가를 결정한다.


<COLGROUP>

<COLGROUP>

이것은 <COL>과 유사한 기능인데, <COL>이 각 칸에 대해 개별적으로 속성을 지정하는 특성이 있는 반면 이것은 모든 칸에 대해 같은 속성을 지정하는 데에 편리하다.


<COMMENT>

<COMMENT>

ÀÌ°ÍÀº ¹®¼»ó¿¡ ³ªÅ¸³ªÁö ¾Ê´Â ¼û°ÜÁø ¸»À» Ç¥½ÃÇÒ ¶§ ¾²¸ç,
<!-- -->°ú °°Àº ±â´ÉÀ» ÇÑ´Ù.


<DD>

<DD> COMPACT

<DL>안에서 <DT>와 함께 사용한다.

<DL>
<DT>제1조<DD>남자는 여자를 사랑한다.
<DT>제2조<DD>여자는 남자를 사랑한다.
</DL>

위처럼 하면 다음과 같이 나타난다.

제1조
남자는 여자를 사랑한다.
제2조
여자는 남자를 사랑한다.

COMPACT

<DL COMPACT>
<DT>선택과 권리<DD>여자는 남자를 사랑한다.
<DT>의무<DD>남자는 여자를 사랑한다.
</DL>

위처럼 하면 다음과 같이 나타난다.

선택과 권리
여자는 남자를 사랑한다.
의무
남자는 여자를 사랑한다.


<DEL>

<DEL> new

<DEL>

ÀÌ ¿ä¼Ò¾ÈÀÇ ¹®ÀåÀº <DEL>´ÙÀ½°ú °°ÀÌ ³ªÅ¸³ª´Ù.</DEL>

ÀÌ ¿ä¼Ò¾ÈÀÇ ¹®ÀåÀº ´ÙÀ½°ú °°ÀÌ ³ªÅ¸³ª´Ù.


<DFN>

<DFN>

ÀÌ ¿ä¼Ò¿¡ ¹ÀÎ ³»¿ëÀº <DFN>ÀÌÅÅ¸¯Ã¼·Î</DFN> ³ªÅ¸³´Ù.

ÀÌ ¿ä¼Ò¿¡ ¹ÀÎ ³»¿ëÀº ÀÌÅÅ¸¯Ã¼·Î ³ªÅ¸³´Ù.


<DIR>

<DIR>

±â´É»ó ÀÌ°Íº¸´Ù´Â <UL>À» »ó¿ëÇÏ´Â °ÍÀÌ ÁÁ´Ù.

<DIR>
<LI>°¡
<LI>³ª
<LI>´Ù
<LI>¶ó
</DIR>

  • °¡
  • ³ª
  • ´Ù
  • ¶ó


<DIV>

<DIV> ALIGN

이것은 묶음요소Block Element인데 Style Sheet의 사용에서 중요한 기능을 한다.

HTML로 인터넷 문서를 만드는 사람들은 <DIV>NS와 IE의 서로 상이한 HTML의 지원과 CSS의 수용 차이를 발견하고 잠시 혼란에 빠진다. 이 두 브라우저에 동시에 적용되는 홈페이지를 구축하자면, 아주 단순하고 볼품없는 문서형식을 유지할 수 밖에 없고, 과도하게 그림을 사용할 수 밖에 없는데 </DIV>이것이 우리가 처한 브라우저와 관련한 현실이다.

위처럼 하면 다음과 같이 나타난다.

HTML로 인터넷 문서를 만드는 사람들은

NS와 IE의 서로 상이한 HTML의 지원과 CSS의 수용 차이를 발견하고 잠시 혼란에 빠진다. 이 두 브라우저에 동시에 적용되는 홈페이지를 구축하자면, 아주 단순하고 볼품없는 문서형식을 유지할 수 밖에 없고, 과도하게 그림을 사용할 수 밖에 없는데
이것이 우리가 처한 브라우저와 관련한 현실이다.

ALIGN = center, left, right

위치를 지정한다.


<DL>

<DL> COMPACT

<DT>안에서 <DD>와 함께 사용한다.

<DL>
<DT>제1조<DD>남자는 여자를 사랑한다.
<DT>제2조<DD>여자는 남자를 사랑한다.
</DL>

위처럼 하면 다음과 같이 나타난다.

제1조
남자는 여자를 사랑한다.
제2조
여자는 남자를 사랑한다.

COMPACT

<DL COMPACT>
<DT>선택과 권리<DD>여자는 남자를 사랑한다.
<DT>의무<DD>남자는 여자를 사랑한다.
</DL>

위처럼 하면 다음과 같이 나타난다.

선택과 권리
여자는 남자를 사랑한다.
의무
남자는 여자를 사랑한다.


<DT>

<DT> COMPACT

<DL>안에서 <DD>와 함께 사용한다.

<DL>
<DT>제1조<DD>남자는 여자를 사랑한다.
<DT>제2조<DD>여자는 남자를 사랑한다.
</DL>

위처럼 하면 다음과 같이 나타난다.

제1조
남자는 여자를 사랑한다.
제2조
여자는 남자를 사랑한다.

COMPACT

<DL COMPACT>
<DT>선택과 권리<DD>여자는 남자를 사랑한다.
<DT>의무<DD>남자는 여자를 사랑한다.
</DL>

위처럼 하면 다음과 같이 나타난다.

선택과 권리
여자는 남자를 사랑한다.
의무
남자는 여자를 사랑한다.


<EM>

<EM>

이것은 문서의 일부를 강조할 때 사용하는데 이태릭체로 나타난다.

<EM>사랑은</EM> 신비롭지 않다.

는 다음과 같이 나타난다.

사랑은 신비롭지 않다.


<EMBED>

<EMBED> ALIGN, ALT,BORDER, HSPACE, NAME, PALETTE, PLUGINSPACE, VSPAC0E

이것은 html문서에 외부화일을 연결할 때에 사용한다.

<EMBED SRC="song.mid" WIDTH="100" HEIGHT="50">

위의 보기는 song.mid가 연주되도록 하는데, 브라우저상에 제어판이 그림으로 나타난다. 물론, 브라우저에 midi음악을 연주할 프로그램이 plug-in 되어 있음을 전제로 한다.

PALETTE = foreground, background

사용자의 컴퓨터가 256 색으로 설정되어 있을 경우, 색상이 그릇되게 나타나는 palette flash라는 현상이 나타날 수 있다. 이것을 피하기 위해 foreground나 background palette를 사용한다. 그런데, 이것은 Windows platform에서만 가능하다.

PLUGINSPACE = "주소"

이것은 사용자가 해당 파일을 실행할 plug-in이 없을 경우, 그것을 얻을 수 있는 주소를 설정하여 설치할 수 있도록 돕는 데에 사용한다.


<FIELDSET>

<FIELDSET> new

<FIELDSET>

이 요소는 <LEGEND>와 함께 사용되면서 상자모양framed container을 구성한다. <LEGEND>요소안의 글은 상자 테두리에 걸쳐 나타난다.

<FIELDSET><LEGEND align=left>윗 테두리 왼쪽에 걸친다.<LEGEND></FIELDSET>

<LEGEND>는
Align="left, bottom, center, left, right, top"의 속성을 가지고 있다.


<FONT>

<FONT> COLOR, FACE, SIZE

글꼴종류와 색, 크기를 지정한다.

<FONT SIZE=4 COLOR="#FF0000">크기가 4인 붉은 색의 글</FONT>

의 경우

크기가 4인 붉은 색의 글

로 나타난다.

FACE

이것은 글꼴의 종류를 정한다. 주의할 것은 글꼴을 선택할 때에 반드시 사용자의 시스템에 해당 글꼴이 있는가를 고려하여야만 한다. 따라서,

FACE="샘물체, 굴림체"

위처럼 하면, 샘물체가 사용자의 시스템에 없을 경우 굴림체로 글꼴이 정해진다.


<FORM>

<FORM> ACTION, ENCTYPE, METHOD, NAME, TARGET

문서에 데이터(CGI등)를 불러들일 때에 사용한다. 한 문서안에 여러개의 form을 사용할 수는 있지만, form안에 또다른 form을 넣을 수는 없다.

<FORM ACTION="주소" METHOD="GET|POST" ENCTYPE="MIME type">
. . .
</FORM>

ACTION

이것은 실행될 데이터가 위치한 곳을 지정한다.

METHOD = GET 또는 POST

GET은 데이터를 읽어들일 때에 사용한다. POST는 데이터를 바꿀(등록할) 때에 사용한다.

ENCTYPE

이것은 media type을 지정한다. MIME type이 기본설정이다.

TARGET

이것은 form이 실행될 창을 설정한다.


<FRAME>

<FRAME> new

<FRAME> RAMEBODER, FRAMSPACING, MARGINHEIGHT, MARGINWIDTH, NORESIZE, SCROLLING, SRC

이것은 <FRAMESET>안에 한 frame을 설정할 때에 사용한다.

SRC = "주소"

frame으로 사용할 문서가 위치한 주소를 지정한다.

MRGINWIDTH = "값"

좌우의 여백을 지정한다.

MRGINHEIGHT = "값"

위, 아래의 여백을 지정한다.

SCROLLING = "yes, no, auto"

이것은 frame안의 문서를 두루마리식으로 볼 수 있는가의 여부를 정한다. no는 사용자의 설정을 고려하지 않으므로 위험하다.

NORESIZE

이것은 frame창의 크기를 조정하지 못하도록 한다.

FRAMEBORDER = "yes, no, 0"

이것은 frame 창의 조절막대 부분을 나타내는 여백의 유무를 정한다.

그런데, 이 여백없는 frame창은 IE와 NS가 지원하는 방식이 틀리다. NS에서는 BORDER="0"이라고 설정하면 되지만, IE는 FRAMEBORDER와 FRAMESPACING을 함께 0으로 하여야 한다. 따라서 다음과 같이 하여야 두 브라우저를 동시에 만족하는 여백없는 frame창을 만들 수 있다.

<FRAMESET FRAMEBORDER="0" FRAMESPACING="0" BORDER="0" COLS="150,*">
<FRAME SRC="frame.htm" NAME="frame">
...


<FRAMESET>

<FRAMESET> new

<FRAMESET> BORDER, BORDERCOLOR, COLS, FRAMESPACING, ROWS

이것은 frame 설정의 기본 단위이다.

ROWS = 세로로 나누기

<FRAMESET ROWS="20%, 100, *">

위의 보기는 화면을 세로축으로 전체 화면을 세개로 나눈 것인데, 그 높이가 각각 전체창의 20%, 나머지에서 100px, 그리고 남은 원래창으로 구성된다.

<FRAMESET ROWS="25%, 75%">

위의 보기는 전체 창을 세로축으로 두개로 나눈 것이다. 이것은 다음과 같이 표시하여도 동일한 효과가 나타난다.

<FRAMESET ROWS="*,3*">

COLS = 가로로 나누기

이것은 ROW와 동일한 방법으로 가로축으로 창을 나눈다.

BORDER = 길이(px...등)

창의 경계의 두께를 설정한다.

BORDERCOLOR = 색

경계의 색을 지정한다.

FRAMESPACING = 길이

나뉘어진 창 사이의 간격을 설정한다.


<H1~6>

<H1~6>

±ÛÀÚÀÇ Å©±â¸¦ 6´Ü°è·Î ³ª´©¾î ÁÙÀ» ¾ÕµÚ·Î ³ª´©¸é¼ Ç¥½ÃÇÑ´Ù.<H1>ÀÌ °¡Àå Å« ±ÛÀÌ°í, <H6>ÀÌ °¡Àå ÀÛÀº ±ÛÀÌ´Ù.


<HEAD>

<HEAD>

HTML¹®¼ÀÇ Á¤º¸¸¦ ¼³Á¤ÇÑ´Ù.

<HEAD>
<TITLE>HTML INFO</TITLE>
</HEAD>

ÀÌ ¾È¿¡ µé¾î°¡´Â °ÍµéÀº ´ÙÀ½°ú °°´Ù.

<BASE>

<BASEFONT>

<LINK>

<META>

<STYLE>

<TITLE>


<HR>

<HR> ALIGN, NOSHADE, SIZE, WIDTH

HTML문서에 가로줄을 그을 때 사용한다.

SIZE = 길이

두께를 지정한다.

WIDTH = 길이(또는 %)

가로의 길이를 지정한다.

ALIGN = left, right, center

가로줄의 위치를 결정한다.

NOSHADE

입체적인 모양 대신 단순히 선으로 나타낼 때 사용한다.


<HTML>

<HTML>

ÀÌ°ÍÀº ±×°ÍÀÌ HTML¹®¼ÀÓÀ» ³ªÅ¸³»´Â ±âº» ´ÜÀ§ÀÌ´Ù.

<HTML>

<HEAD>
<TITLE></TITLE>
</HEAD>

<BODY>

</BODY>

</HTML>


<I>

<I>

ÀÌ°ÍÀº ±ÛÀÚ¸¦ ±â¿ï¿© ¾µ ¶§(ÀÌÅÅ¸¯Ã¼)¿¡ »ç¿ëÇÑ´Ù.


<IFRAME>

<IFRAME> new

<IFRAME> BORDER, BORDERCOLOR, FRAMEBORDER, NAME, SCROLLING

<FRAME>과 유사한 기능을 가지는 요소인데, 다른 점은 브라우저에 나타나는 HTML문서 위의 자유로운 위치에 새로운 창으로 생성된다. floating frame인 것이다.

<IFRAME NAME="float" width="40" height="100" SRC="sam.htm">
익스플로러만 가능하다.</IFRAME>

위에서 처럼 사용하면, 가로 40, 세로 100의 새로운 창(sam.htm의 내용)이 열리며, 익스플로러가 아닌 다른 브라우저로 검색할 경우에는 '익스플로러만 가능하다.'라는 문장이 나타난다.

BORDER = "테두리의 굵기"

floating frame의 테두리의 굵기를 정한다. 주의할 것은 FRAMEBORDER와 함께 정의되어야 한다는 것이다.

BORDERCOLOR = "테두리의 색깔"

FRAMEBORDER가 정해진 상태에서 테두리의 색깔을 지정한다.

FRAMEBORDER = "테두리의 유무"

테두리를 설정할 경우는 "yes" (또는 "1"), 테두리를 없앨 경우는 "no" (또는 "0")로 한다.

NAME = "Frame의 이름"

고유의 이름을 정한다.

SCROLLING = "스크롤 바의 유무"

스크롤 바는 프레임의 길이와 문서의 분량에 따라 자동으로 만들어지지만, 필요에 따라 없앨 수도 있다. SCROLLING="no"로 하면 막대를 강제로 없앨 수 있고, SCROLLING="auto"라고 하면, 문서의 길이에 따라 자동으로 막대가 생긴다.


<ILAYER>

<ILAYER>

<LAYER>¸¦ Çà°£¿¡ »ðÀÔÇÏ¿©in-line 'layers' »ç¿ëÇÒ ¼ö ÀÖµµ·Ï ÇÑ ¿ä¼ÒÀÌ´Ù.

¼Ó¼ºÀº <LAYER>¿Í µ¿ÀÏÇÏ´Ù.


<IMG>

<IMG> ALIGN, ALT, BODER, HEIGHT, HSPACE, ISMAP, LOWSRC, NAME, SRC, USEMAP, VSPACE, WIDTH

이것은 그림을 HTML문서에 연결할 때에 사용한다. 외부파일을 HTML에 불러들이는 형식이므로 과도한 사용은 HTML의 검색을 더디게 한다.

ALIGN =left, right, top, texttop,middle,absmiddle, baseline, bottom, absbottom

한 줄Line에서 그림의 위치와 글자에 대한 상대적 높낮이를 결정한다.

ALT = 설명

그림에 대한 풍선도움말ToolTip을 지정한다.

ISMAP

다른 곳에서 이미지맵<MAP>을 불러들일 때 사용한다.

<A HREF="http://machine/htbin/imagemap/sample">
<IMG SRC="sample.gif" ISMAP></A>

위처럼 사용할 수 있는데, 주의할 것은 HTTP server에 이미지맵을 조정할 수 있는 cgi-bin software가 설치되어 있어야 한다는 것이다.

SRC = 주소

그림이 위치한 주소를 지정한다.

WIDTH = 값, HEIGHT = 값

그림의 가로, 세로의 길이를 지정한다. 이 때, 그림이 가지는 고유의 값을 지정할 수도 있고, 축소 또는 확대하여 나타낼 수도 있다. 길이를 지정하는 것이 그림이 떠오르는 시간을 줄일 수 있다.

BORDER = 값

그림의 테두리를 설정한다.

VSPACE = (세로)값, HSPACE = (가로)값

그림과 글자간의 가로와 세로의 간격을 지정한다.

LOWSRC

이것은 다음과 같이 사용하는데,

<IMG SRC="high.gif" LOWSRC="low.gif">

HTML에 접속하면, 브라우저는 먼저 LOWSRC에 지정한 그림을 나타나게 하고,모든 문서가 다 나타났을 때, 그 그림 위에 SRC에서 지정한 그림이 나타나도록 한다. 이 때, 두 그림의 길이를 지정하지 않았다면, LOWSRC의 원래 크기에 해당하는 크기에 맞추어 SRC에서 지정한 그림이 드러나도록 한다.

NAME

HTML문서상에서의 그림의 이름을 지정한다.


<INPUT>

<INPUT> ALIGN, CHECKED, MAXLENGTH, NAME, SIZE, TYPE, VALUE

<FORM>형식에 필요한 사항인데, 사용자가 직접 글을 써넣거나 데이터를 스크립트의 도움을 받아 실행시킬 수 양식을 만든다.

ALIGN

위치를 지정한다.

CHECKED

표시된 사각형checkbox 또는 원radio botton을 보여준다.

MAXLENGTH

한 공간안에 들어갈 수 있는 최대문자를 지정한다.

NAME

이름을 지정한다.

SIZE

아래의 보기처럼 크기를 지정한다.

INPUT TYPE="text" SIZE="24"

SRC

IMG에서처럼 주소를 지정한다.

TYPE

글text 등, 해당 형식을 정한다.

BUTTON

단추. 이것은 각종 스크립트를 실행하는 장치로 이용된다.

VALUE

이것은 단추의 이름을 정할 때 사용하며, 단추에 표시된다.


<INS>

<INS> new

<INS>

ÀÌ ¿ä¼Ò´Â <DEL>°ú À¯»çÇÑ ±â´ÉÀ» ÇÏ´Âµ¥,
<INS>¹ØÁÙÀÌ ±×¾îÁø´Ù.</INS>

¹ØÁÙÀÌ ±×¾îÁø´Ù.


<ISINDEX>

<ISINDEX>

이것은 HTML 사용자user agent에게 해당 문서가 색인문서index document임을 알려주며, keyword search를 가능하게 해준다.

이것을 사용하기 위해서는 자신의 서버Server가 이 요소를 지원하는 search engine을 가지고 있어야만 한다.

PROMPT

<ISINDEX PROMPT="임의의 문장(예를들면 '찾아보기')">

위에서 '임의의 문장'은 input box앞에 놓이게 된다. 사용자는 input box에 원하는 말을 넣고, 엔터키를 치면 원하는 결과를 얻게 된다.

<ISINDEX ACTION="search">

위처럼 하면

This is a searchable index. Enter search keywords: input box

와 같이 브라우저에 나타나는데, 이것은 cgi script "websearch"를 실행한다. 그런데 위에서 보기를 든 "search"는 그 script이 host machine에 있어야만 가능하다.

익스플로러는 4.0판에서부터 이 기능을 제외하였다.


<KBD>

<KBD>

±ÛÀÚ¸¦ mono spaced font·Î ³ªÅ¸³¾ ¶§¿¡ »ç¿ëÇÑ´Ù.


<KEYGEN>

<KEYGEN>

<FORM>¿¡¼ ¿¼èKey¸¦ ÄÚµåÈÇÏ¿© »ç¿ëÀÚÀÇ PC¿¡ ÀúÀåÇÏ´Â ±â´ÉÀ» ÇÑ´Ù.


<LABEL>

<LABEL> new

<LABEL>

Radio buttonÀ» ¸¸µé¸ç, »ç¿ëÀÚ°¡ Æ¯Á¤ Ç×¸ñÀ» ¼±ÅÃÇÏµµ·Ï ÇØÁØ´Ù.

<LABEL FOR="big">big : <INRUT TYPE ="radio" NAME="size" VALUE="big" ID="big"></LABEL><BR>
<LABEL FOR="small">small : <INPUT TYPE="radio" NAME="size" VALUE="small" ID="small"></LABEL>


<LAYER>

주의 : 이 요소를 사용할 경우 익스플로러 브라우저에서는 보기 흉한 모습으로 나타난다.

<LAYER> NAME,LEFT,TOP,SRC,Z-INDEX,ABOVE, BELOW, WIDTH, CLIP, VISIBILITY, BGCOLOR, BACKGROUND

HTML문서 안의 글이나 그림을 겹쳐놓음으로써 다양한 효과를 기대할 수 있는 요소이다. 두 개 이상의 대상을 고정시키거나 이동시키면서 사용하는 데, JavaScript과 함께 사용하면 역동적인 특수효과visual effects를 HTML문서에 부여할 수 있다.

그런데, 여기서 알아두어야 할 것은 넷스케이프와 익스플로러 4.0판에서부터 Style Sheet(CSS)를 지원하고 있으며, Style Sheet(CSS)를 사용하면 <LAYER>기능을 사용하는 것보다 자유롭게 비쥬얼한 HTML문서를 만들 수 있다는 것이다.

NAME

layer의 고유한 속성에 부여하는 이름이다.

LEFT

정확한 x축 좌표를 설정한다. 초기값 "0"은 브라우저의 왼편 끝을 의미한다.

TOP

정확한 y축 좌표를 설정한다. 초기값 "0"은 브라우저 창의 맨 위를 의미한다.

SRC

<HEAD>와 <BODY>가 없는외부 파일external layer source files로 layer을 구성하여 불러옴으로써 한 번에 여러 문서 동일한 효과를 가져올 수 있다.

Z-INDEX

ABOVE와 BELOW속성을 확장하는 기능을 한다. 즉, 각 layer에 각각 "1", "2", "3"...등으로 Z-INDEX에 번호를 넣으면, 각각의 layer는 순서대로 겹쳐진다.

ABOVE, BELOW

layer에서 BELOW로 지정된 것은 아래에 깔리고, ABOVE로 지정된 것은 그 위에 겹쳐진다.

<LAYER NAME="Red">
어쩌구 저쩌구
</LAYER>
<LAYER NAME="Green" ABOVE="Red">
어쩌구 저쩌구
</LAYER>

WIDTH

layer의 길이를 지정한다.

CLIP

<LAYER CLIP="10,10,50,20">

위의 예는 x축 10px에서 x축 50px로, y축 10px에서 y축 10px로 이동한다는 것을 나타낸 것이다.

<LAYER CLIP="50,20">

위는 x, y축 0, 0에서 10, 20으로 이동함을 보여준다.

VISIBILITY = "show, hide"

해당 layer가 보일 것인지 말 것인지를 지정한다.

BGCOLOR

layer의 바탕색을 지정한다.

BACKGROUND

layer에 그림을 불러들인다.


<LEGEND>

<LEGEND> new

<FIELDSET>


<LI>

<OL>


<LINK>

<LINK> HREF, REL, TYPE

이것은 문서와 외부의 대상을 연결한다.

<LINK REL="stylesheet" TYPE="text/css" HREF="http://www.user.com/formal.css"
TITLE="formal">

위의 예는 스타일 시트 formal.css를 문서에 불러들여 사용할 때에 사용한다.

Dynamic Font를 불러들여 사용할 수도 있는데, 이 때 NS는 다음과 같이 한다.

<LINK REL="fontdef" SRC="http://site/path/fontdef.pfr">

자세한 것은 http://home.netscape.com/comprod/products/
communicator/fonts/index.html 를 방문한다.

DISABLED

이것은 IE에서만 가능한데, 해당 LINK가 기능하지 못하도록 한다.


<LISTING>

<LISTING>

<PRE>³ª <XMP>¿Í À¯»çÇÑ ±â´ÉÀ» ÇÑ´Ù.

»çÀÌºñ´Â <LISTING>ºñ½ÁÇÏÁö¸¸ ¾Æ´Ï¶ó´Â</LISTING> ¶æÀÌ´Ù.

´Â

»çÀÌºñ´Â

ºñ½ÁÇÏÁö¸¸ ¾Æ´Ï¶ó´Â ¶æÀÌ´Ù.

·Î Ç¥½ÃµÈ´Ù.


<MAP>

<MAP> NAME

그림을 분할하여 각 부분이 다른 문서와 연결되도록 한다.

<IMG SRC="map.gif" USEMAP="maps.html#map1">

위의 보기는 map1이라는 이름으로 해당 그림이 maps.html에 연결됨을 보여준다. 그림의 분할은 <MAP>과 <AREA>를 사용한다.

<MAP NAME="map">
<AREA [SHAPE="shape"] COORDS="x,y,..." [HREF="reference"] [NOHREF]>
</MAP>

NAME

<IMG USEMAP=...>과 일치한다.(<AREA>에서 지정할 수도 있다.)

SHAPE = CIRCLE, RECT, POLYNAME

범위지정을 어떤 모양으로 하는가를 결정한다.

COORDS

범위를 지정한다.

SHAPE="RECT"(사각)일 경우는

COORDS="left-x,top-y,right-x,bottom-y"로 정해지며,

SHAPE="CIRCLE"(원)은

COORDS="centre-x, centre-y, radius"

SHAPE="POLY"(불규칙)는

COORDS="x1,y1,x2,y2,x3,y3... "로 정해진다.


<MARQUEE>

<MARQUEE> ALIGN, BEHAVIOR, BGCOLOR, DIRECTION, HEIGHT, HSPACE, LOOP, SCROLLAMOUNT, SCROLLDELAY

HTML문서의 일부 글text을 좌에서 우로 또는 그 반대로 움직이게 하는 효과를 줄 때에 사용한다.

<MARQUEE>이 문장은 오른쪽에서 왼쪽으로 반복적으로 흘러갈 것이다.</MARQUEE>

ALIGN = "left, right, top, middle, bottom"

흘러가는scrolling 글자들의 줄 위치를 지정한다.

BEHAVIOR = "scroll, slide, alternate"

흘러가는scrolling 글자들의 모양새를 정한다. SCROLL은 자연스럽게 흘러가고(글자가 화면밖으로 줄줄이 사라진다.) SLIDE는 맨 앞의 글자가 화면 끝에 닿는 순간 문장 전체가 사라지고 다시 반대편에서 흘러온다.ALTERNATE는 화면 안에서 좌우로 오락 가락한다.

BGCOLOR = "바탕색"

흐르는 글자들의 바탕색을 지정한다.

<MARQUEE BGCOLOR="#ffffff">하얀 색의 바탕위를 흐르는 글자들</MARQUEE>

DIRECTION = "left, right"

글자 흐름의 방향을 정한다.

HEIGHT = "숫자, %"

marquee의 높이를 정한다.

HSPACE = "숫자"

글자의 흐름이 시작되는 위치를 설정한다.(마이너스 숫자도 가능하다.)

LOOP = "숫자, -1, nfinite"

숫자만큼 또는 무제한으로 글자를 흐르게 한다. -1과 nfinite는 무제한으로 흐르도록 한다.

SCROLLAMOUNT = "숫자"

흐르는 글자의 속도를 조절한다. 숫자가 크면 속도는 빨라진다.

SCROLLDELAY = "숫자"

흐르는 글자들이 잠시 멈추며 흐르는 효과를 나타낸다. 숫자가 크면 멈춤의 횟수가 커진다.

VSPACE = "숫자"

상하의 여백을 지정한다.

WIDTH = "숫자, %"

길이를 지정한다.

주의 : NOTE

흐르는 글자들을 <FONT>로 특별한 글꼴을 만드려면 아래와 같이 <MARQUEE> 태그 바깥에 <FONT>태그를 위치시키는 태그대칭으로 해야만 한다.

<FONT FACE = "궁서"><MARQUEE>궁서글꼴이다.</MARQUEE>
</FONT>


<MENU>

<MENU>

<UL>°ú °°Àº ±â´ÉÀ» ÇÏ´Âµ¥, ¿ª½Ã<LI>¿Í ÇÔ²² »ç¿ëÇÑ´Ù.

<MENU>
<LI>³²ÀÚ
<LI>¿©ÀÚ
<LI>»ç¶û
</MENU>

´Â
  • ³²ÀÚ
  • ¿©ÀÚ
  • »ç¶û
    •      À¸·Î ³ªÅ¸³´Ù.


<META>

<META> CONTENT, HTTP-EQUIV, NAME

<HEAD>에 위치하는데, 문서의 다양한 정보를 server와 client에 제공한다.

<META HTTP-EQUIVE="CONTENT-TYPE" CONTENT="TEXT/HTML; CHARSET=EUC-KR">

위는 해당 문서가 한글 전용으로 나타남을 뜻한다.

CHARSET=ISO-8859-1은 영어권 전용을 의미한다.

IE의 경우는 이것이 정해지면 다른 언어는 깨져 보인다.


<MULTICOL>

<MULTICOL> COLS, GUTTER

보통 신문에서 보는 단편집formatted in multiple columns을 가능하게 해준다.

COLS = "숫자"

화면을 세로 방향으로 몇 개 설정할 것인가를 결정한다.

GUTTER = "숫자"

세로로 분할된 각 칸 사이의 간격white space을 조절한다.

WIDTH = "숫자"

전체(각 칸이 아닌)의 길이를 지정한다.

<MULTICOL COLS="3" GUTTER="25">
현재와 같은 설정은, 세로로 3개의 칸으로 나뉘고 칸 사이의 여백은 25px가 된다 </MULTICOL>


<NOFRAMES>

<NOFRAMES>

이 요소는 프레임이 불가능한 브라우저를 이용하는 사용자에게 해당 HTML문서가 프레임을 사용하는 문서임을 알려주는 기능을 한다.

<NOFRAMES>이 문서는 프레임을 사용하고 있다.</NOFRAMES>

라고 하면, 프레임이 불가능한 브라우저를 이용하는 사용자는

이 문서는 프레임을 사용하고 있다.

는 메시지를 읽을 수 있는 것이다.


<NOSCRIPT>

<NOSCRIPT>

ÀÌ ¿ä¼Ò´Â ¾î¶² ºê¶ó¿ìÀúµµ »ç¿ëÇÏÁö ¾Ê´Â HTML40¿ä¼ÒÀÌ´Ù.


<OBJECT>

<OBJECT> new

<OBJECT>

ActiveX control이나 다른 media를 직접 HTML에 삽입하는 역할을 한다. 이것은 특정내용을 <IMG>에서와 같이 그림형식으로 문서에 나타나도록 한다.

<OBJECT
CLASSID="clsid:99B42120-6EC7-11CF-A6C7-00AA00A47DD2"
ID=lbl1
WIDTH=40
HEIGHT=250
>
<PARAM NAME="angle" VALUE="90">
<PARAM NAME="alignment" VALUE="2">
<PARAM NAME="BackStyle" VALUE="0">
<PARAM NAME="caption" VALUE="Hello there">
<PARAM NAME="FontName" VALUE="Arial">
<PARAM NAME="FontSize" VALUE="30">
<PARAM NAME="FontBold" VALUE="1">
<PARAM NAME="frcolor" VALUE="8388608">
</OBJECT>

위의 예를 익스플로러로 실행하면, 우리가 보통 HTML로 할 수 없는 기능을 구현할 수 있지만 자유로운 사용은 ActiveX OLE control를 이해할 때에 가능하다.

ActiveX control pad

http://www.microsoft.com/workshop/author/cpad/


<OL>

<OL> START, TYPE

순서가 있는 목록Ordered List이다. 즉, 각 항의 앞에 숫자가 붙는 것이다.<LI>와 함께 사용한다.

<OL>
<LI>아침
<LI>점심
<LI>저녁
</OL>

위의 보기는 다음과 같이 나타난다.

  1. 아침
  2. 점심
  3. 저녁

TYPE=A

A, B, C...가 앞에 붙는다.

TYPE=a

a, b, c...가 앞에 붙는다.

TYPE=I

I, II, III...가 앞에 붙는다.

TYPE=i

i, ii, iii...가 앞에 붙는다.

TYPE=1

1, 2, 3 ...가 앞에 붙는데, 미리 지정된Default 형식이다.

START

위의 보기를 같이 바꾸면,

<OL START="5">
<LI>아침
<LI>점심
<LI>저녁
</OL>

  1. 아침
  2. 점심
  3. 저녁

위처럼 나타난다.


<OPTION>

<OPTION> NAME, SELECTED, VALUE

<SELECT>¾È¿¡¼ ¾²ÀÎ´Ù.

SELECTED

ÃÊ±â¼³Á¤ÀÌ´Ù.

VALUE

»ç¿ëÀÚ°¡ ¼±ÅÃÇÏ´Â ÃÊ±â¼³Á¤DefaultÀÌ´Ù.

NAME

ÀÌ¸§À» ÁöÁ¤ÇÑ´Ù.


<P>

<P> ALIGN

문단을 나눈다.

아내가 돌아온다. <P>저녁을 먹는다.</P> 아내가 돌아온 것이다.

는

아내가 돌아온다.

저녁을 먹는다.

아내가 돌아온 것이다.

위처럼 나타난다.


<PARAM>

<PARAM> NAME, VALUE

'pre-compiled HotJava applets'과 관련된 것으로, 이에 대해서는

http://java.sun.com/

나

Java SDK의 http://www.microsoft.com/java/

을 방문하면 자세한 정보를 얻을 수 있다.

<APPLET CODE="Applet.class" WIDTH=200 HEIGHT=150></APPLET>

위의 예는 Java Applet을 불러들여 HTML에서 실행하는 것을 보여준다.

<APPLET CODEBASE="http://java.sun.com/JDK-prebeta1/applets/ NervousText" CODE="NervousText.class" width=400 height=75 align=center>
<PARAM NAME="text" VALUE="This is the Applet Viewer.">
<BLOCKQUOTE>
<HR>
움직이는 글자의 예이다.
<HR>
</BLOCKQUOTE>
</APPLET>

<PARAM>은 위에서 처럼 사용된다.


<PLAINTEXT>

<PLAINTEXT>

ÀÌ°ÍÀº <PRE>, <XMP>, <LISTING>µî°ú À¯»çÇÑ ±â´ÉÀ» ÇÑ´Ù.


<PRE>

<PRE> WIDTH

<PRE WIDTH="100">
작성되대로 나타난다.
</PRE>

위처럼 사용하는데, 다음과 같이 저자가 쓴대로 나타난다.

        작성된대로 나타난다.

WIDTH

가로의 길이를 지정한다.


<Q>

<Q> new

<Q>

ÃÖ¼ÒÇÑ ÇÑ±Û HTML¹®¼¿¡ »ç¿ëÇÒ °æ¿ì º°´Ù¸¥ ±â´ÉÀ» º¸¿©ÁÖÁö ¾Ê´Â´Ù.


<S>

<S> = <STRIKE>

±ÛÀÚ Áß¾Ó¿¡ <STRIKE>°¡·Î·Î ÁÙÀÌ ³ªÅ¸³´Ù.</STRIKE>

±ÛÀÚ Áß¾Ó¿¡ °¡·Î·Î ÁÙÀÌ ³ªÅ¸³´Ù.


<SAMP>

<SAMP>

±ÛÀÚ¸¦ mono spaced font·Î ³ªÅ¸³½´Ù.


<SCRIPT>

<SCRIPT>

HTML문서에 스크립을 삽입하는 기능을 담당하는 요소이다. 가장 대표적으로 사용되는 스크립은 Javascript인데, 익스플로러4.0과 넷스케이프4.0에서는 javaScript1.2를 지원하고 있다.

<SCRIPT LANGUAGE="JavaScript">
. . .
</SCRIPT>


<SELECT>

<SELECT> ALIGN, MULTIPLE, NAME, SIZE

사용자가 여러 문항중에서 하나를 고를 수 있도록 해준다. 문항 설정은 <OPTION>으로 한다.

MULTIPLE

이것은 사용자가 다수의 항을 동시에 선택하도록 해준다.

NAME

이름을 지정한다.

SIZE

길이를 지정한다.

ALIGN = 위치

위치를 지정한다.

보기

<SELECT NAME="골라잡기">
<OPTION>자동차
<OPTION>비행기
<OPTION>배
<OPTION>자전거
<OPTION>오토바이
<OPTION>맨발1
<OPTION SELECTED>무엇을 타고 가나?
<SELECT>

위에서 SELECTED는 초기설정이다.


<SMALL>

<SMALL>

±ÛÀÚ¸¦ ´Ù¸¥ ±ÛÀÚ¿¡ ºñÇØ »ó´ëÀûÀ¸·Î <SMALL>ÀÛ°Ô</SMALL> ³ªÅ¸³½´Ù.

±ÛÀÚ¸¦ ´Ù¸¥ ±ÛÀÚ¿¡ ºñÇØ »ó´ëÀûÀ¸·Î ÀÛ°Ô ³ªÅ¸³½´Ù.


<SPACER>

<SPACER> TYPE, SIZE, WIDTH, HEIGHT, ALIGN

HTML문서의 가로, 세로 또는 일정 부분에 임의로 여백을 지정할 때에 사용한다.

TYPE = "horizontal, vertical, block"

글자 사이에 가로horizontal로, 세로horizontal로 또는 일정 구간block에 여백white space을 지정할 것을 정한다.

SIZE="숫자"

<SPACER TYPE="horizontal">이나 <SPACER TYPE="vertical">로 TYPE을 정했을 때 그 여백의 길이를 지정한다.

WIDTH = "숫자"

<SPACER TYPE="block">으로 지정할 때에 사용하여 그 길이를 지정한다.

HEIGHT = "숫자"

<SPACER TYPE="block">으로 지정할 때에 사용하여 그 여백 구간의 높이를 지정한다.

ALIGN = "여백의 위치"

<SPACER TYPE="block">을 사용할 때에 <IMG>요소에서 가능한 모든 ALIGN속성을 사용하여 여백의 위치를 지정한다.


<SPAN>

<SPAN>

이것은 순전히 <SPAN CLASS="some">Style Sheet를 사용하기 위해 고안해낸 것으로 이 요소는 그 자체로는 어떠한 표현 기능도 가지고 있지 않다.

위의 경우, 스타일 시트에서 'some'으로 지정된 CLASS가 어떤 것이냐에 따라 태그안의 문장이 변화할 것이다.


<STRIKE>

<STRIKE> = <S>


<STRONG>

<STRONG>

±ÛÀÚ¸¦ ±½°í ÁøÇÏ°Ô ³ªÅ¸³½´Ù.

±ÛÀÚ¸¦ ±½°í ÁøÇÏ°Ô ³ªÅ¸³½´Ù.


<STYLE>

<STYLE>

ÀÌ°ÍÀº Style Sheet¸¦ HTML¹®¼¿¡ ³¢¿ö³ÖÀ»Cascading ¶§ ½Ã¿ëÇÏ´Â µ¥, º¸Åë <HEAD> </HEAD>»çÀÌ¿¡ À§Ä¡ÇÑ´Ù.


<SUB>

<SUB>

´Ù¸¥ ±ÛÀÚ¿Í ºñ±³ÇÏ¿© »ó´ëÀûÀ¸·Î ÀÛ°Ô ³ªÅ¸³½´Ù.


<SUP>

<SUP>

´Ù¸¥ ±ÛÀÚ¿Í ºñ±³ÇÏ¿© »ó´ëÀûÀ¸·Î Å©°Ô ³ªÅ¸³½´Ù.


<TABLE>

<TABLE> ALIGN, BACKGROUND, BGCOLOR, BODER, BODERCOLOR, CELLPADDING, CELLSPACING, HEIGHT, VALIGN, WIDTH

표table는 다음과 같이 구성된다.

<TABLE>
<TR>
<TD>
</TD>
<TD>
</TD>
</TR>
<TR>
<TD>
</TD>
<TD>
</TD>
</TR>
</TABLE>

위의 보기는 세로로 두 줄, 가로로 두 칸의 표를 나타낸다.

BORDER = 값

테두리의 굵기를 정한다. 0으로 정하면, 테두리가 없는 표가 된다.

CELLPADDING = 값

이것은 항cell과 내용 사이의 여백을 지정한다. 초기값은 1이다.

CELLSPACING = 값

이것은 각 항cell사이의 공간을 설정한다. 초기값은 2이다.

<TABLE BORDER="0" CELLSPACING="0" CELLPADDING="0">

위처럼 하면, 테두리가 없으며, 모든 여백이 없는 표를 만들게 된다.

WIDTH = 값, 또는 %

가로 길이를 지정한다.

HEIGHT = 값 또는 %

세로 길이를 정한다.

ALIGN = left, right

표의 위치를 정한다.

VALIGN = top, bottom, center

표안의 글의 세로위치를 정한다.

BGCOLOR = 색

바탕색을 정한다.

BORDERCOLOR = 색

테두리의 색을 정한다.

BACKGROUND = 그림image의 주소URL

바탕에 그림을 불러들인다.


<TBODY>

<TBODY> ALIGN, BGCOLOR, VALIGN

표table는 다음과 같이 구성된다.

<TABLE>의 구성요소, 즉 문자의 상하좌우 위치와 각 칸의 바탕색깔을 일괄적으로 지정할 때에 사용한다. 특히 <TBODY></TBODY>를 사용하면, <TABLE>의 일부 칸의 문자와 바탕색만을 조정할 수도 있다. 이 때 주의할 점은 각 태그의 좌우대칭을 정확하게 지켜야 한다는 것이다. 그렇지 않으면, 표의 모양이 의도와 달리 이상해질 수도 있다.

ALIGN = "center, left, right"

좌우 위치

BGCOLOR = "색"

색의 지정 (예: #000000, red)

VALIGN = "baseline, bottom, middle, top"

상하 위치

<TABLE WIDTH="70%" height="70" BORDER=1>

<TBODY ALIGN="right" BGCOLOR="#c0c0c0" VALIGN="bottom">

<TR>
...........<TD>
.....................<B>1행1칸</B>
...........</TD>
...........<TD>
......................<B>1행1칸</B>
...........</TD>
</TR>
<TR>
...........<TD>
......................<B>2행1칸</B>
...........</TD>
...........<TD>
.......................2행2칸
...........</TD>
</TR>
</TABLE>

위의 예는 2줄2칸의 표를 보여주는데, <tbody>에서 설정된 대로 각 칸의 문자는 오른쪽 맨 아래쪽에, 각 칸의 바탕색은 회색으로 지정된다.


<TD>

<TD> ALIGN, BACKGROUND, BGCOLOR, BODERCOLOR, COLSPAN, HEIGHT, VALIGN, WIDTH

이것은 표table의 칸을 만든다. <TD>의 갯수만큼 가로로 칸이 생긴다.

ALIGN = "left, center, right "

글의 가로 위치를 지정한다.

VALIGN = top, middle, bottom, baseline

글의 세로 위치를 지정한다.

WIDTH = 값, 또는 %

칸의 가로 길이를 정한다.

HEIGHT = 값

칸의 세로 길이를 정한다.

NOWRAP

<TH>와 <TD>에서 내용의 가로 길이가 항cell의 크기에 제한 받지 않도록 한다.

COLSPAN = 값

<TH>와 <TD>에서 항cell과 내용 사이의 가로 폭을 정한다. 초기값은 1이다.

ROWSPAN = 값

<TH>와 <TD>에서 항cell과 내용 사이의 세로 폭을 정한다. 초기값은 1이다.

BGCOLOR = 색

바탕색을 정한다.

BORDERCOLOR = 색

테두리 색을 정한다.

BACKGROUND = 그림image의 주소URL

바탕에 그림을 불러들인다.


<TEXTAREA>

<TEXTAREA> ALIGN, COLS, NAME, WRAP

사용자가 직접 글을 써넣을 수 있는 공간을 설정한다.

ROWS

세로 길이를 설정한다.

COLS

가로 길이를 설정한다.

WRAP

<TEXTAREA WRAP=OFF>

초기값으로 가로 길이를 제한하지 않는다.

<TEXTAREA WRAP=VIRTUAL>

가로 길이만 제한한다.

<TEXTAREA WRAP=PHYSICAL>

가로, 세로 길이를 제한한다.


<TFOOT>

<TFOOT> ALIGN, BGCOLOR, VALIGN

<TABLE>에서 꼬리말 부분footer section을 정의할 때에 사용한다.

ALIGN = "center, left,, right"

<TFOOT> 부분section의 전체 표table에 대한 상대적인 좌우 위치를 결정한다.

BGCOLOR = "바탕색"

<TFOOT> 부분section의 색깔을 지정한다.

VALIGN = "baseline, bottom, middle, top"

<TFOOT> 부분section의 전체 표table에 대한 상대적인 상하 위치를 결정한다.


<TH>

<TH> ALIGN, BACKGROUND, BGCOLOR, BODERCOLOR, COLSPAN, HEIGHT, NOWRAP, ROWSPAN, VALIGN, WIDTH

이것은 표의 제목항table header이다.

ALIGN = left, center, right

글자의 가로 위치를 지정한다.

VALIGN = top, middle, bottom, baseline

글자의 세로위치를 정한다.

WIDTH = 값, 또는 %

<TH>의 가로 길이를 설정한다.

HEIGHT = 값, 또는 %

<TH>의 세로 길이를 설정한다.

참고

NS는 <TABLE>에서 HEIGHT=%만을 지원한다.

NOWRAP

<TH>나 <TD>에서 사용하는데, 내용의 가로 길이가 항cell의 크기에 제한 받지 않도록 한다.

COLSPAN = 값

<TH>나 <TD>에서 항cell과 내용 사이의 가로 폭을 정한다. 초기값은 1이다.

ROWSPAN = 값

<TH>나 <TD>에서 세로 폭을 정한다. 초기값은 1이다.

BGCOLOR = 색

바탕색을 지정한다.

BORDERCOLOR = 색

테두리색을 지정한다.

BACKGROUND = 그림image의 주소URL

<TH>, <TABLE>, <TD>등의 바탕에 그림을 불러들인다.


<THEAD>

<THEAD> ALIGN, BGCOLOR, VALIGN

<TABLE>의 머리부분head section을 정의한다.

ALIGN = center, left, right

<THEAD> 부분section의 전체 표table에 대한 상대적인 좌우 위치를 결정한다.

BGCOLOR = "바탕색"

<THEAD> 부분section의 색깔을 지정한다.

VALIGN = "baseline, bottom, middle, top,"

<THEAD> 부분section의 전체 표table에 대한 상대적인 상하 위치를 결정한다.


<TITLE>

<TITLE>

<HEAD>
<TITLE>HTML INFO</TITLE>
</HEAD>

¹®¼ÀÇ Á¦¸ñÀ» Á¤ÇÑ´Ù.


<TR>

<TR> ALIGN, BGCOLOR, BODERCOLOR, VALIGN

<TABLE>에서 줄row을 설정할 때에 사용한다. 즉,

ALIGN = left, center, right

이것은 표table안의 글자의 가로 위치를 지정한다.

VALIGN = top, middle, bottom, baseline

이것은 한 줄에서 세로 위치를 정한다. .

BGCOLOR = 색

이것은 표table 내부의 바탕색을 지정한다.

BORDERCOLOR = 테두리 색

표의 테두리 색을 지정한다.


<TT>

<TT>

ÀÌ°ÍÀº Å¸ÀÌÇÁÃ¼·Î ³ªÅ¸³¾ ¶§ »ç¿ëÇÏ´Âµ¥, ÇÑ±ÛÀÇ °æ¿ì¿¡´Â ¾à°£ ÀÛ°Ô ³ªÅ¸³ª´Â Á¤µµÀÌ´Ù.


<U>

<U>

¹ØÁÙÀ» ±ß´Â´Ù.

ÀÌ°ÍÀº <U>¹ØÁÙÀÌ´Ù.</U>

ÀÌ°ÍÀº ¹ØÁÙÀÌ´Ù.


<UL>

<UL> TYPE

¼ø¼¾ø´Â ¸ñ·ÏÀºUnordered List ´ÙÀ½°ú °°ÀÌ <LI>¿Í ÇÔ²² »ç¿ëÇÑ´Ù.

<UL TYPE=disc>
<LI>Ã¹Â°
<LI>µÑÂ°
<LI>¼ÂÂ°
</UL>

  • Ã¹Â°
  • µÑÂ°
  • ¼ÂÂ°

TYPE(ÃÊ±â°ªÀº discÀÌ´Ù.)

TYPE=disc
TYPE=circle
TYPE=square


<VAR>

<VAR>

´ÙÀ½Àº <VAR>ÀÌÅÂ¸¯Ã¼·Î</VAR> ³ªÅ¸³´Ù.

´ÙÀ½Àº ÀÌÅÂ¸¯Ã¼·Î ³ªÅ¸³´Ù.


<XMP>

<XMP>

ÀÌ°ÍÀº <XMP>Áö±ÝÃ³·³</XMP> ³ªÅ¸³´Ù.

ÀÌ°ÍÀº

Áö±ÝÃ³·³ ³ªÅ¸³´Ù.