I n t r o d u c t i o n

자바 스크립트 사전은 Java Script에서 사용하는 객체와 속성 및 메소드를 목록별로 찾아 볼 수 있도록 구성한 전자 사전입니다.

왼쪽 메뉴에서 목록을 클릭하면 해당 목록이 나타납니다.

또는 [검색] 기능을 사용하면 찾고 싶은 목록을 쉽게 찾아서 볼 수 있습니다.


Anchor 객체

3 [image] 2

<a> 태그에 사용되는 하이퍼링크나 책갈피 정보를 제공합니다. 넷스케이프에서는 배열을 사용하고 익스플로러에서는 document.all 객체를 통해 접근할 수 있습니다.

속 성

name
<a> 태그의 NAME 속성 값을 가지고 옵니다.

text
<a> 태그 내부에 들어가는 문자 정보를 가지고 옵니다.

x
<a> 태그 좌측 상단의 x 좌표 값을 가지고 옵니다.

y
<a> 태그 좌측 상단의 y 좌표 값을 가지고 옵니다.

length
<a> 태그의 배열의 크기를 가지고 옵니다.

메 소 드

없음

이벤트 핸들러

없음


Document 객체

3 [image] 2

브라우저에서 보여주는 문서에 관련된 정보에 접근할 때에도 사용되고 자바스크립트를 이용하여 브라우저에 출력을 할 때에도 사용됩니다.
( 1. HTML문서라는 것은 <HEAD>와 <BODY>태그에 포함되어 있을 것을 가리킵니다.
2. document 객체의 anchors, forms, links 배열을 이용하여 문서에 들어 있는 표식, 입력 양식, 링크 정보에 접근할 수 있습니다. )

속 성

alinkColor
<BODY> 태그의 ALINK 속성입니다

anchors
문서에 있는 모든 표식(anchor) 객체들을 배열로 모아놓은 변수입다

bgColor
<BODY> 태그의 BGCOLOR 속성입니다.

cookie
cookie

domain
현제 문서가 포함된 서버의 도메인의 이름입니다.

fgColor
<BODY> 택의 TEXT 속성 입니다.

forms
문서에 있는 모든 입력양식정보를 배열로 모아놓은 변수입니다.

lastModified
문서가 가장 최근에 바뀐 날짜입니다.

linkColor
<BODY> 태그의 LINK 속성입니다.

links
문서에 있는 모든 링크객체들을 배열로 모아놓은 변수입니다.

referrer
현재 문서를 불러들인 문서의 URL입니다.

title
<TITLE> 태그로 지정된 문서의 이름입니다.

URL
현재 문서의 URL 주소입니다.

vlinkColor
<BODY> 태그의 VLINK 속성입니다.

applets
문서에 있는 모든 애플릿 객체들을 배열로 모아놓은 변수입니다.

embeds
문서에 있는 모든 플러그인 객체들을 배열로 모아놓은 변수입니다.

images
문서에 있는 모든 이미지 객체들을 배열로 모아놓은 변수입니다.

URL
문서의 URL 주소입니다.

메 소 드

open()
출력을 위해 문서를 엽니다.

close()
출력을 위해 열어둔 문서 닫습니다.

write()
문서에 문자열을 출력합니다.

writeln()
문서에 문자열 출력(줄바꾸기 포함)합니다.

getSelection()
현재 선택된 문자열을 반환합니다. 넷스케이프에서 동작

captureEvents()
특정 이벤트 타입 잡아내도록 세팅합니다. 넷스케이프에서 동작

handleEvent()
특정 이벤트 핸들러를 호출합니다. 넷스케이프에서 동작

releaseEvents()
특정 이벤트 타입 잡아내는 것을 풀어줍니다. 넷스케이프에서 동작

routeEvent()
잡은 이벤트 타입을 다른 객체에 전달합니다. 넷스케이프에서 동작

이벤트 핸들러

onclick
문서에서 마우스를 클릭했을 때 사용합니다.

ondblclick
문서에서 마우스를 더블클릭했을 때 사용합니다.

onkeydown
문서에서 키를 입력했을 때 사용합니다.

onkeypress
키보드에서 키를 눌렀을 때 사용합니다.

onkeyup
키보드에서 키를 눌렀다 놓았을 때 사용합니다.

onmousedown
마우스 버튼을 눌렀을 때 사용합니다.

onmousesetup
마우스 버튼을 눌렀다 놓았을 때 사용합니다.


Event 객체

4 [image] 4

자바스크립트에서 발생하는 이벤트에 관한 정보입니다.
( 넷스케이프 커뮤니케이터와 인터넷 익스플로러의 이벤트 객체가 조금씩 다릅니다. )

사 용 법

event.속성

속 성

- 넷스케이프 커뮤니케이터의 event 객체 -

data
DragDrop 이벤트 발생시 Drop된 객체의 URL 주소 포함합니다.

height
윈도우나 프레임의 높이입니다.

layerX
레이어를 기준으로 한 커서의 x좌표 또는 resize 이벤트 발생시 객체의 너비입니다.

layerY
레이어를 기준으로 한 커서의 y좌표 또는 resize 이벤트 발생시 객체의 높이입니다.

modifiers
마우스나 키 이벤트 발생시 Alt, Control, Shift, Meta 키의 상태. ALT_MASK, CONTROL_MASK, SHIFT_MASK, META_MASK를 이용하여 체크할 수 있습니다.

pageX
페이지를 기준으로 한 커서의 x 좌표입니다.

pageY
페이지를 기준으로 한 커서의 y 좌표입니다.

screenX
전체화면을 기준으로 한 커서의 x 좌표입니다.

screenY
전체화면을 기준으로 한 커서의 y 좌표입니다.

target
이벤트가 대상으로 하고 있는 객체입니다.

type
이벤트 타입을 보여주는 문자열입니다.

which
클릭한 마우스 버튼 위치(1:왼쪽, 2:가운데, 3:오른쪽), 누른 키의 ASCII 값입니다.

width
윈도우나 프레임의 너비입니다.

x
layerX와 동일합니다.

y
layerY와 동일합니다.

- 인터넷 익스플로러의 event 객체 -

altKey
Alt 키의 상태입니다.

altLeft
왼쪽 Alt 키의 상태입니다.

button
클릭한 버튼의 위치(1:왼쪽, 2:오른쪽, 3:왼쪽+오른쪽, 4:가운데, 5:왼쪽+가운데, 6:오른쪽+가운데 7:3개 모두)입니다.

cancelBubble
현재 이벤트가 이벤트 핸들러 계층 트리를 올라갈 것인지의 여부

clientX
윈도우 실제 데이터 영역을 기준으로 한 마우스의 x좌표입니다.

clientY
윈도우 실제 데이터 영역을 기준으로 한 마우스의 y좌표입니다.

ctrlKey
Ctrl 키의 상태입니다.

ctrlLeft
왼쪽 Ctrl 키의 상태입니다.

dateFld
oncellchange 이벤트에 영향 받는 데이터 필드입니다.

dataTransfer
Drapdrop시 사용할 클립보드 포맷에 접근하는데 사용합니다.

fromElement
onmouseover/onmouseout 이벤트 발생시 미우스 객체입니다.

keyCode
키 이벤트 발생한 키의 유니코드입니다.

offsetX
이벤트 발생 객체를 기준으로 한 마우스 x 좌표입니다.

offsetY
이벤트 발생 객체를 기준으로 한 마우스 y 좌표입니다.

propertyName
이벤트를 발생한 객체에서 바뀐 특성 이름입니다.

qualifier
데이터 소스 객체에서 제공된 데이터 멤버의 이름입니다.

reason
데이터 소스 객체의 데이터 전송의 결과입니다.

recordset
디폴트 레코드셋에 대한 레퍼런스입니다.

repeat
onkeydown 이벤트가 반복되는 횟수입니다.

returnValue
이벤트로부터 리턴되는 값입니다.

saveType
oncontentfire 이벤트 발생시 클립보드 타입입니다.

screenX
전체 화면을 기준으로 한 마우스의 x 좌표입니다.

screenY
전체 화면을 기준으로 한 마우스의 y 좌표입니다.

shfitKey
shift 키의 상태입니다.

shiftLeft
왼쪽 shift 키의 상태입니다.

srcElement
이벤트를 발생한 객체입니다.

srcFilter
onfilterchange 이벤트 발생시킨 filter 객체입니다.

srcUrn
이벤트를 발생시킨 behavior의 URN 입니다.

toElement
마우스 포인터를 가리키고 있는 객체입니다.

type
이벤트 객체의 이벤트 이름입니다.

x
현 객체를 기준으로 한 마우스의 x 좌표입니다.

y
현 객체를 기준으로 한 마우스의 y 좌표입니다.

메 소 드

없음

이벤트 핸들러

없음


FileUpload 객체

4 [image] 3

파일 업로드 입력 양식을 위한 객체입니다.
( 자바스크립트에서는 파일 업로드 입력 양식을 참조할 수만 있고 수정할 수는 없습니다. )

사 용 법

fileUploadName.속성

속 성

form
파일 업로드 입력 양식을 포함하고 있는 폼 객체입니다

name
<INPUT> 태그의 NAME 속성입니다.

type
파일 업로드 입력 양식의 타입(TYPE 속성)입니다.

value
파일 업로드 양식의 필드에 들어 있는 값. 읽기 전용입니다.

메 소 드

blur()
파일 업로드 양식의 포커스를 다른 곳으로 옮깁니다.

focus()
파일 업로드 입력 양식으로 포커스를 가져옵니다.

handleEvent()
특정 이벤트 핸들러 호출합니다. 넷스케이프에서 동작

select()
파일 업로드 입력 양식의 입력된 데이터 선택합니다.

이벤트 핸들러

onblur
파일 업로드 입력 양식이 포커스를 잃었을 때 발생하는 이벤트 핸들러입니다.

onchange
파일 업로드 입력 양식의 값이 바뀌었을 때 발생하는 이벤트 핸들러입니다. 넷스케이프에서 동작

onfocus
파일 업로드 입력 양식이 포커스를 얻었을 때 발생하는 이벤트 핸들러입니다.


Form 객체

3 [image] 2

<form> 태그의 입력 양식 정보를 제어합니다.
( 1. Form 안에 포함된 입력 양식들은 elements 특성으로 접근할 수 있습니다.
2. 또한 각 입력 양식의 이름으로도 접근 할 수도 있습니다. )

사 용 법

formName.속성

formName.메소드

form[배열 번호].속성

form[배열 번호].메소드

속 성

action
<FORM> 태그의 ACTION 속성 정보를 가지고 옵니다.

elements
Form 안에 포함되어 있는 각 입력 양식 정보를 가지고 옵니다.

encoding
<FORM> 태그의 ENCTYPE 속성 정보를 가지고 옵니다.

length
Form 안에 포함되어 있는 입력 양식의 수를 표시합니다. 넷스케이프에서 동작

name
<FORM> 태그의 NAME 속성 정보를 설정합니다.

method
<FORM> 태그의 METHOD 속성 정보를 설정합니다.

target
<FORM> 태그의 TARGET 속성 정보를 설정합니다.

메 소 드

submit()
Form에 입력된 데이터를 서버로 보냅니다.

reset()
Form에 입력된 데이터를 처음 상태로 되돌립니다.

handleEvent()
특정 이벤트 핸들러 호출합니다. 넷스케이프에서 동작

이벤트 핸들러

onsubmit
Submit 버튼을 눌렀을 때 발생하는 이벤트 핸들러입니다.

onreset
Reset 버튼을 눌렀을 때 발생하는 이벤트 핸들러입니다.


Frame 객체

3 [image] 2

한 윈도우 안에 여러 개의 문서를 보여주기 위해 나눈 것, 각 프레임은 자신만의 URL 주소를 가지며 독립적으로 동작하게 됩니다.
( 1. 프레임은 <FRAMESET>태그를 통해 형식을 지정하게 됩니다.
2. 각 프레임에 들어갈 내용은 <FRAME> 태그를 통해 지정하게 됩니다.
3. self와 window 특성은 현재 프레임을 가리키는데 사용됩니다.
4. top과 parent 특성은 현재 프레임을 포함하고 있는 프레임이나 윈도우를 지정하는데 사용됩니다. )

사 용 법

[windowReference.]frameName.속성

[windowReference.]frames[배열번호].속성

window.속성

self.속성

parent.속성

속 성

frames
프레임 안에 포함된 모든 프레임에 관한 정보를 배열로 제공합니다.

name
<FRAME>태그의 NAME 속성입니다.

length
프레임 안에 포함된 프레임의 개수입니다.

parent
현재 프레임을 포함하고 있는 윈도우나 프레임입니다.

self
자기 자신 프레임을 가리키는 것입니다.

window
자기 자신 프레임을 가리키는 것입니다.

메 소 드

clearTimeout()
setTimeout으로 지정한 것을 취소합니다.

setTimeout()
지정된 시간 후에 실행시킬 명령을 지정합니다.

이벤트 핸들러

onFocus
프레임이 focus를 받았을 때 발생하는 이벤트 핸들러 입니다.

onBlur
프레임이 focus를 잃었을 때 발생하는 이벤트 핸들러입니다.


Function 객체

4 [image] 3

함수를 만드는데 사용하는 객체입니다.
( 일반적으로 정의하는 함수와 동일합니다. )

사 용 법

functionTarget = new Function ([arg1, arg2, ... argn], functionBody)

functionTarget : 함수 이름

arg1, ... : 함수의 매개변수

functionBody : 함수의 본체

속 성

arguments
함수의 매개변수 입니다.

arguments.callee
현 Function 객체의 내용을 반환합니다. 넷스케이프에서 동작

arguments.caller
현 Function 객체를 호출하는 함수의 이름을 반환합니다. 넷스케이프에서 동작

arguments.length
매개변수의 개수입니다.

arity
매개변수의 개수(함수 외부에서 사용)입니다. 넷스케이프에서 동작

caller
현 Function 객체를 호출하는 함수 참조입니다. 익스플로러에서 동작

constructor
생성자 함수 객체입니다.

length
매개변수의 개수입니다. 넷스케이프에서 동작

prototype
Function 객체의 특성을 추가하기 위한 것입니다.

메 소 드

apply()
메소드를 호출하는 객체 내에서 한 객체의 메소드에 적용합니다. 넷스케이프에서 동작

call()
메소드를 호출하는 객체 내에서 한 객체의 메소드 실행합니다. 넷스케이프에서 동작

toSource()
Function 객체의 소스코드 반환합니다. 넷스케이프에서 동작

toString()
Function 객체를 문자열로 만들어 반환합니다.

valueOf()
Function 객체 값을 현재 가진 데이터 타입으로 반환합니다.

이벤트 핸들러

없음


Hidden 객체

3 [image] 2

숨겨진 입력 양식을 위한 객체입니다.
(1. hidden 객체는 입력 양식이기 때문에 반드시 <FORM> 태그 안에서 정의되어야 합니다.
2. hidden 객체의 값은 사용자에 의해 수정될 수 없고, 프로그램에 의해만 수정될 수 있습니다. )

사 용 법

hiddenName.속성

formName.elements[배열번호].속성

속 성

form
숨겨진 입력 양식이 포함된 폼 객체입니다.

name
<INPUT> 태그의 NAME 속성입니다.

value
hidden 객체의 현재 값입니다.

type
입력 양식의 종류("hidden") 입니다.

메 소 드

없음

이벤트 핸들러

없음


History 객체

3 [image] 2

사용자가 윈도우 안에서 방문하였던 URL 주소들을 저장해 놓은 곳입니다.
( history 객체에 포함된 URL 주소는 넷스케이프 Go 메뉴에서 볼 수 있습니다. )

사 용 법

history.속성

history.메소드(매개변수)

속 성

length
history 객체에 저장되어 있는 URL 주소의 수입니다.

current
히스토리 리스트 중 현재 보고 있는 곳의 URL 주소입니다.

next
히스토리 리스트 중 현재 보다 뒤에 있는 곳의 URL 주소입니다.

previous
히스토리 리스트 중 현재보다 앞에 있는 곳의 URL 주소입니다.

메 소 드

back()
history 객체에 저장된 URL 주소 리스트 중에서 뒤로 이동합니다.

forward()
history 객체에 저장된 URL 주소 리스트 중에서 앞으로 이동합니다.

go()
history 객체에 저장된 URL 주소 리스트 사이에서 상대적인 이동합니다.

이벤트 핸들러

없음


Image 객체

4 [image] 3

문서에 포함되어 있는 이미지를 위한 객체입니다.
( 1. 문서에 나타난 이미지의 크기와 위치는 자바스크립트에서 수정할 수 없습니다.
2. 대신 이미지 파일이 존재하는 위치를 가리키는 src와 lowsrc는 수정할 수 없습니다. )

사 용 법

imageName.속성

document.images[배열번호].속성

formName.elements[배열번호].속성

속 성

border
<IMG> 태그의 BORDER 속성입니다.

complete
이미지가 모두 전송되었는지를 알려주는 변수(완료시 true)입니다.

height
<IMG> 태그의 HEIGHT 속성입니다.

hspace
<IMG> 태그의 HSPACE 속성입니다.

lowsrc
<IMG> 태그의 LOWSRC 속성입니다.

name
<IMG> 태그의 NAME 속성입니다.

src
<IMG> 태그의 SRC 속성입니다.

vspace
<IMG> 태그의 VSPACE 속성입니다.

width
<IMG> 태그의 WIDTH 속성입니다.

메 소 드

handelEvent()
특정 이벤트 핸들러 호출합니다.

이벤트 핸들러

onabort
사용자가 이미지 전송을 중지시켰을 때 발생하는 이벤트 핸들러입니다.

onerror
이미지 전송중 에러가 생겼을 때 발생하는 이벤트 핸들러입니다.

onload
이미지가 브라우저에 나타났을 때 발생하는 이벤트 핸들러입니다.

onkeydown
이미지상에서 키를 눌렀을 때 실행되는 이벤트 핸들러입니다. 넷스케이프에서 동작

onkeypress
이미지상에서 키를 눌렀을 때 실행되는 이벤트 핸들러입니다. 넷스케이프에서 동작

onkeyup
이미지상에서 키를 눌렀을 때 실행되는 이벤트 핸들러입니다. 넷스케이프에서 동작


Layer 객체

4

레이어를 위한 객체입니다.

사 용 법

document.layers[배열번호].속성

속 성

name
레이어의 이름입니다.

left
레이어의 좌측 위치입니다.

top
레이어의 상단 위치입니다.

pageX
레이어의 좌측 위치(항상 문서 기준)입니다.

pageY
레이어의 상단 위치(항상 문서 기준)입니다.

width
레이어의 가로 길이입니다.

height
레이어의 세로 길이입니다.

clip.top
클리핑 영역(상단 위치)입니다.

clip.left
클리핑 영역(좌측 위치)입니다.

clip.right
클리핑 영역(우측 위치)입니다.

clip.bottom
클리핑 영역(하단 위치)입니다.

bgColor
레이어의 배경색입니다.

background
레이어의 배경 이미지입니다.

zindex
레이어의 현재 순서입니다.

visibility
레이어가 보이는지의 여부입니다.

siblingAbove
현재 레이어의 아래에 있는 레이어(동일한 상위 레이어)입니다.

siblingBelow
현재 레이어의 위에 있는 레이어(동일한 상위 레이어)입니다.

above
현재 레이어의 아래에 있는 레이어입니다.

below
현재 레이어의 위에 있는 레이어입니다.

parentLayer
현재 레이어가 포함되어 있는 상위 레이어입니다.

src
레이어의 내용이 포함된 HTML 문서의 위치입니다.

메 소 드

moveBy()
레이어 위치의 상대적인 이동입니다.

moveTo()
레이어 위치의 절대적인 이동(상위 레이어나 문서 기준)입니다.

moveToAbsolute()
레이어 위치의 상대적인 이동(전체 페이지 기준)입니다.

resizeBy()
레이어의 크기 바꿉니다.

resizeTo()
레이어의 크기 바꿉니다.

moveAbove()
매개변수가 가리키는 레이어 위로 올리기입니다.

moveBelow()
매개변수가 가리키는 레이어 밑으로 내리기입니다.

load()
매개변수가 가리키는 HTML 문서를 레이어 내로 읽기입니다.

이벤트 핸들러

없음


Applet 객체

4 [image] 3

문서에 삽입되어 있는 자바 애플릿 정보를 가지고 옵니다.

사 용 법

appletName.속성

document.applets[배열번호].속성

속 성

name
<Applet> 태그의 NAME 속성 정보를 가지고 옵니다.

메 소 드

자바 애플릿에서 public 선언한 모든 메소드를 사용할 수 있습니다.

이벤트 핸들러

없음


Link 객체

4 [image] 3

하이퍼텍스트 링크를 위한 객체입니다.
( 1. 마우스로 클릭하게 되면 href에 지정된 주소에 있는 문서를 읽어오게 됩니다.
2. target 속성을 지정하게 되면 다른 윈도우나 프레임에서 문서를 보여주게 됩니다.
3. document.links에서 NAME 속성 값을 통한 참조 배열로 접근할 수 없습니다. )

사 용 법

document.links[index].propertyName

속 성

hash
URL 주소의 anchor 이름입니다.

host
URL 주소에서 "hostname:port" 부분입니다.

hostname
URL 주소의 호스트와 도메인 네임(또는 IP 어드레스)입니다.

href
전체 URL 주소입니다.

pathname
URL 주소의 절대 디렉토리 부분입니다.

port
URL 조소 중에서 서버가 사용하는 포트 번호입니다.

protocol
URL 주소 중에서 프로토콜 종류입니다.

search
URL 주소 중에서 검색 부분(? 뒤에 나오는 것)입니다.

target
<A> 태그의 TARGET 속성입니다.

text
<A> 태그 내에 있는 문자열입니다. 넷스케이프에서 동작

메 소 드

handleEvent
특정 이벤트 핸들러 호출합니다. 넷스케이프에서 동작

이벤트 핸들러

onclick
마우스로 링크를 클릭했을 때 발생하는 이벤트 핸들러입니다.

ondblclick
마우스로 링크를 더블클릭했을 때 발생하는 이벤트 핸들러입니다.<AREA> 태그에 대해서만 사용 가능합니다.

onkeydown
포커스를 가진 링크 위에서 키를 눌렀을 때 발생되는 이벤트 핸들러입니다.

onkeyup
포커스를 가진 링크 위에서 키를 눌렀을 때 발생되는 이벤트 핸들러입니다.

onmousedown
마우스로 링크 위에서 클릭했을 때 발생되는 이벤트 핸들러입니다.

onmouseover
마우스로 링크 위를 지나갔을 때 발생되는 이벤트 핸들러입니다. <AREA> 태그에 대해서만 사용 가능합니다.

onmouseout
마우스가 링크 밖으로 나갔을 때 발생되는 이벤트 핸들러입니다. <AREA> 태그에 대해서만 사용 가능합니다.

onmouseup
마우스가 링크 위에서 버튼을 올렸을 때 발생되는 이벤트 핸들러입니다.


Location 객체

3 [image] 2

현재 브라우저에서 보고 있는 문서의 URL 주소에 관한 정보를 가지고 있는 객체입니다.
( 현재 브라우저에서 보여주고 있는 문서의 URL 주소 정보를 포함하고 있습니다. )

사 용 법

[windowReference.]location[.속성]

속 성

hash
URL 주소의 anchor 이름입니다.

host
URL 주소에서 "hostname:port" 부분입니다.

hostname
URL 주소의 호스트와 도메인 네임(또는 IP 어드레스)입니다.

href
전체 URL 주소입니다.

pathname
URL 주소의 절대 디렉토리 부분입니다.

port
URL 주소 중에서 서버가 사용하는 포트 번호입니다.

protocol
URL 주소 중에서 서버가 사용하는 프로토콜입니다.

search
URL 주소 중에서 검색부분(? 뒤에 나오는 것)입니다.

메 소 드

reload()
현재 브라우저에 있는 문서를 다시 한번 읽어들입니다.

replace()
현재 문서를 지정된 URL 주소의 문서로 바꿔쳐줍니다.

이벤트 핸들러

없음


Math 객체

3 [image] 2

수학 계산을 위해 자바스크립트에서 제공하고 있는 내장 객체입니다.
( 1. Math 객체는 어느 객체로부터도 상속되지 않은 독립 객체입니다.
2. Math 객체는 정적(static) 객체이므로 다음과 같이 곧바로 사용하게 됩니다.
Math.PI, Math.E, Math.sin(0.5)....... )

사 용 법

Math.속성

Math.메소드(매개변수)

속 성

E
오일러 상수 (약 2.718)입니다.

LN2
2의 자연로그 (약 0.693)입니다.

LN10
10의 자연로그 ( 약 2.302)입니다.

LOG2E
밑이 2인 e의 로그 (약 1.442)입니다.

LOG10E
밑이 10인 e의 로그 (약 0.434)입니다.

PI
원주율 (약 3.14159)입니다.

SQRT1_2
1/2의 제곱근 (약 0.707)입니다.

SQRT2
2의 제곱근 (약 1.414)입니다.

메 소 드

abs()
절대값을 반환합니다.

acos()
Arc cosine 값을 반환합니다.

asin()
Arc sine 값을 반환합니다.

atan()
Arc tangent 값을 반환합니다.

atan2()
Arc Tangent 값을 반환합니다.

ceil()
지정된 숫자보다 같거나 작지 않은 정수를 반환합니다.

cos()
Cosine 값을 반환합니다.

exp()
오일러 상수 e가 밑인 지수 값을 반환합니다.

floor()
지정된 숫자보다 같거나 크지 않은 정수를 반환합니다.

log()
로그 값(e가 밑)을 반환합니다.

max()
입력된 두 숫자 중 큰 값을 반환합니다.

min()
입력된 두 숫자 중 작은 값을 반환합니다.

pow()
지수 값을 반환합니다.( base의 exponent승 값 )

random()
0과 1사이의 값 중에서 임의로 골라 반환합니다.
( 유닉스 시스템에서만 사용 가능합니다. )

round()
숫자를 반올림하여 반환합니다.

sin()
Sine 값을 반환합니다.

sqrt()
 제곱근 값을 반환합니다.

tan()
Tangent 값을 반환합니다.

이벤트 핸들러

없음


mimeType 객체

3

브라우저에서 지원하는 MIME 타입을 살펴보기 위한 객체입니다.
( 현재 브라우저에서 사용할 수 있는 MIME 타입을 체크하기 위해 사용된됩니다. )

사 용 법

avigator.mimeType[배열번호].속성

속 성

type
MIME 타입의 이름입니다.

description
MIME 타입의 설명입니다.

enabledPlugin
MIME 타입을 다루는 플러그인 객체를 확인합니다.

suffixes
MIME 타입에 해당하는 확장자들 입니다.

메 소 드

없음

이벤트 핸들러

없음


Navigator 객체

3 [image] 2

브라우저에 관한 일반 정보를 제공하는 객체입니다.
( 1. 주로 현재 사용하고 있는 일반 정보를 구하는데 사용합니다.
2. 버전을 체크하여 현재 사용할 수 있는 기능을 제한시킬 수 있습니다. )

사 용 법

navigator.속성

속 성

appCodeName
브라우저의 코드 이름입니다.

appName
브라우저의 이름입니다.

appVersion
브라우저의 버전 정보입니다.

userAgent
브라우저의 user-agent 헤더 정보입니다.

mimeType
브라우저의 MIME 타입 정보입니다.

plugins
브라우저에서 지원하는 플러그인 정보입니다.

language
현재 브라우저가 사용하는 언어입니다.

platform
브라우저가 설치된 시스템 종류입니다.

preference
인증받은 스크립트가 preference 값을 설정하거나 가져오는데 사용하는 특성입니다.

appMinorVersion
브라우저 Minor 버전(버전 5.0에서 0)을 보여줍니다. 익스플로러에서 동작

browserLanguage
브라우저가 어떤 언어판인지 보여줍니다. 익스플로러에서 동작

cookieEnabled
브라우저에서 쿠키를 사용할 수 있는지의 여부를 보여줍니다. 익스플로러에서 동작

cpuClass
브라우저가 사용하고 있는 컴퓨터의 CPU 타입을 보여줍니다. 익스플로러에서 동작

systemLanguage
브라우저가 사용되는 운영체계의 사용 언어를 보여줍니다. 이스플로러에서 동작

userLanguage
사용자에 의해 사용되는 언어를 보여줍니다. 익스플로러에서 동작

userProfile
사용자 프로파일 정보를 보여줍니다. 익스플로러에서 동작

메 소 드

javaEnabled()
자바를 사용할 수 있는지를 체크합니다.

이벤트 핸들러

없음


Number 객체

4 [image] 4

문자로 된 숫자 단어를 실제 숫자로 바꾸어주는 객체입니다.

사 용 법

Number(num_string)

속 성

constructor
Number 객체의 생성자 함수를 참조합니다.

MAX_VALUE
자바스크립트에서 표현할 수 있는 가장 큰 수입니다.

MIN_VALUE
자바스크립트에서 표현할 수 있는 가장 작은 수입니다.

NaN
Not a Number

NEGATIVE_INFINITY
음의 무한대

POSITIVE_INFINTY
양의 무한대

prototype
Number 객체로 할당된 변수들이 공유할 수 있는 특성을 만드는데 사용합니다.

메 소 드

toSource()
Number 객체의 소스코드 반환합니다. 넷스케이프에서 동작

toStirng()
Number 객체를 문자열로 만들어 반환합니다.

valueOf()
현재 가지고 있는 값을 원래 타입으로 반환합니다.

* 인터넷 익스플로러에서는 지원하지 않음 (JavaScript 1.3에서 추가)

이벤트 핸들러

없음


Option 객체

4 [image] 3

리스트 박스에 있는 옵션 메뉴를 위한 객체입니다.
( 넷스케이프 3.0부터 옵션 메뉴의 추가/삭제가 가능해졌습니다. )

사 용 법

[옵션 메뉴 추가]

optionName=newOption([optionText,optionValue, defaultSelected, selected])

selectName.options[배열번호]=optionName

[옵션 메뉴 삭제]

selectName.options[배열번호]=null

속 성

defaultSelected
옵션 메뉴의 초기 선택 상태입니다.

index
옵션 메뉴의 인덱스입니다.

prototype
옵션에 특성을 추가하기 위한 것 입니다.

selected
옵션의 현재 선택 상태를 보여주는 변수입니다.

text
옵션 메뉴에 보이는 제목입니다.

value
옵션 메뉴의 값입니다.

메 소 드

없음

이벤트 핸들러

없음


Password 객체

3 [image] 2

비밀번호 입력 양식을 위한 객체입니다.
( 비밀번호 입력 양식은 <FORM> 태그 안에서 정의됩니다. )

사 용 법

passwordName.속성

passwordName.메소드(매개변수)

formName.elements[배열번호].속성

formName.elements[배열번호].메소드(매개변수)

속 성

defaultValue
<INPUT> 태그의 VALUE 속성입니다.

name
<INPUT> 태그의 NAME 속성입니다.

value
비밀번호 입력 양식에 입력된 값입니다.

type
<INPUT> 태그의 TYPE 속성("password")입니다.

메 소 드

focus()
비밀번호 입력 양식 안에 커서가 들어가게 합니다.

blur()
비밀번호 입력 양식 안에 있는 커서를 밖으로 나가게 합니다.

select()
비밀번호 입력 양식에 입력된 값을 선택합니다.

이벤트 핸들러

onblur
암호 입력이 포커스를 잃었을 때 발생하는 이벤트 핸들러입니다.

onfocus
암호 입력이 포커스를 얻었을 때 발생하는 이벤트 핸들러입니다.


Plugin 객체

4 [image] 3

플러그인을 위한 객체입니다.
( <EMBED> 태그를 통해 설정한 플러그인에 관한 정보에 접근하는데 사용됩니다. )

사 용 법

document.embeds[배열번호]

document.embeds.length

속 성

없음

메 소 드

없음

이벤트 핸들러

없음


Radio 객체

3 [image] 2

웹페이지에 포함되어 있는 자바 애플릿에 접근하기 위한 객체입니다.
( 1. 라디오 객체는 <FORM> 태그 안에 정의되어야 합니다.
2. 라디오 객체 안에 있는 모든 라디오 버튼들은 name 특성이 동일합니다. )

사 용 법

radioName[배열번호1].속성

radioName[배열번호1].메소드(매개변수)

formName.elements[index2].속성

formName.elements[index2].메소드(매개변수)

속 성

checked
 라디오 버튼의 선택 여부를 알려줍니다.

defaultChecked
<INPUT> 태그의 CHECKED 속성입니다.

form
라디오 버튼이 포함되어 있는 폼 객체입니다.

name
<INPUT> 태그의 NAME 속성입니다.

value
<INPUT> 태그의 VALUE 속성입니다.

type
<INPUT> 태그의 TYPE 속성("radio")입니다.

메 소 드

blur()
라디오 버튼의 포커스를 다른 객체로 옮깁니다.

click()
라디오 버튼을 클릭합니다.

focus()
라디오 버튼에 포커스를 가져옵니다.

handleEvent()
특정 이벤트 핸들러 호출합니다. 넷스케이프에서 동작

이벤트 핸들러

onblur
라디오 버튼이 포커스를 잃었을 때 발생되는 이벤트 핸들러입니다.

onclick
라디오 버튼이 클릭되었을 때 발생되는 이벤트 핸들러입니다.

onfocus
라디오 버튼이 포커스를 얻었을 때 발생되는 이벤트 핸들러입니다.


Area 객체

4 [image] 3

이미지 맵에서 그림의 영역을 정의할 경우 사용되는 <area> 태그를 정의해줍니다. 이 영역에 설정한 하이퍼링크 정보를 가지고 옵니다.

사 용 법

태그 이름.속성

document.links[배열 번호].속성

속 성

herf
URL 정보를 가지고 옵니다.

host
URL 주소의 호스트 이름과 포트 번호를 가지고 옵니다.

protocol
URL 주소의 프로토콜 종류를 가지고 옵니다.

hostname
URL 주소의 호스트 이름을 가지고 옵니다.

pathname
URL 주소의 디렉토리 위치 정보를 가지고 옵니다.

port
URL 주소의 포트 번호 정보를 가지고 옵니다.

hash
URL 주소의 표식 정보를 가지고 옵니다.

search
URL 주소에서 검색엔진을 호출할 때 사용하는 형식 정보를 가지고 옵니다.

target
TARGET 속성 정보를 가지고 옵니다.

메 소 드

없음

이벤트 핸들러

onClick
마우스로 클릭했을 경우 이벤트를 발생합니다.

onDblClick
마우스로 더블클릭했을 경우 이벤트를 발생합니다.

onKeyDown
영역 위에서 키를 눌렀을 때 이벤트를 발생합니다.

onKeyUp
영역 위에서 키를 누르고 놓았을 경우에 이벤트를 발생합니다.

onMouseDown
영역 위에서 클릭했을 때 이벤트를 발생합니다.

onMouseOver
영역 위에 마우스 포인터를 위치할 경우에 이벤트를 발생합니다.

onMouseOut
영역 위에 마우스 포인터가 벗어날 때 이벤트를 발생합니다.

onMouseUp
영역 위에 마우스 단추를 올렸을 때 이벤트를 발생합니다.


Reset 객체

3 [image] 2

리셋 버튼을 위한 객체입니다.
( 1. 리셋 객체는 <FORM> 태그 안에서 정의되어야 합니다.
2. onClick을 이용하여 리셋 상태를 취소시킬 수 없습니다.
3. 리셋은 일단 실행되면 어떤 경우에도 취소시킬 수 없습니다. )

사 용 법

resetName.속성

resetName.메소드(매개변수)

formName.elements[배열번호].속성

formName.elements[배열번호].메소드(매개변수)

속 성

name
 <INPUT> 태그의 NAME 속성입니다.

value
<INPUT> 태그의 VALUE 속성입니다.

type
<INPUT> 태그의 TYPE 속성("rest")입니다.

메 소 드

blur()
리셋 버튼에서 포커스를 없애줍니다.

click()
리셋 버튼을 클릭합니다.

focus()
리셋 버튼에 포커스가 오도록 만듭니다.

handleEvent()
특정 이벤트 핸들러를 호출합니다. 넷스케이프에서 동작

이벤트 핸들러

onblur
리셋 버튼이 포커스를 잃었을 때 이벤트를 발생합니다.

onclick
리셋 버튼이 클릭되었을 때 이벤트를 발생합니다.

onfocus
리셋 버튼이 포커스를 얻었을 때 이벤트를 발생합니다.


Screen 객체

4 [image] 4

현재 웹페이지를 보고 있는 컴퓨터의 화면 해상도나 색상에 관한 정보입니다.
( screen 객체는 JavaScript 1.2/JScript 3.0 이상부터 지원되기 시작하였습니다. )

사 용 법

screen.속성

속 성

availHeight
원도우의 태스크 바와 같은 인터페이스를 제외한 화면의 높이입니다.

availWidth
윈도우의 태스크 바와 같은 인터페이스를 제외한 화면의 너비입니다.

colorDepth
사용 가능한 색상 수 입니다.

height
화면의 높이(픽셀 단위)입니다.

width
화면의 너비(픽셀 단위)입니다.

pixelDepth
한 픽셀당 비트 수 입니다. 넷스케이프에서 동작

메 소 드

없음

이벤트 핸들러

없음


Select 객체

3 [image] 2

리스트 박스를 위한 객체입니다.
( 넷스케이프 3.0부터는 리스트 박스에 옵션 메뉴를 추가하거나 삭제할 수 있습니다. )

사 용 법

selectName.속성

selectName.메소드(매개변수)

formName.elements[배열번호].속성

formName.elements[배열번호].메소드(매개변수)

속 성

form
리스트 박스가 포함되어 있는 폼 객체입니다.

length
리스트 박스에 포함된 옵션 메뉴의 개수입니다.

name
<INPUT> 태그의 NAME 속성입니다.

options
옵션 메뉴입니다.

selectedindex
현재 선택된 옵션 메뉴의 인덱스입니다.

type
TYPE에 입력된 값("select")입니다.

메 소 드

focus()
리스트 박스에 focus가 되도록 합니다.

blur()
리스트 박스로부터 focus를 없애줍니다.

handleEvent()
특정 이벤트 핸들러 호출합니다. 넷스케이프에서 동작

이벤트 핸들러

onfocus
리스트 박스가 focus를 받았을 때 발생하는 이벤트 핸들러입니다.

onblur
리스트 박스가 focus를 잃었을 때 발생하는 이벤트 핸들러입니다.

onchange
리스트 박스에서 선택을 바꾸었을 때 발생하는 이벤트 핸들러입니다.


String 객체

3 [image] 2

문자열을 처리하기 위한 객체입니다.
( String 객체는 어느 객체로부터도 상속되지 않은 독립 객체입니다.)

사 용 법

문자열.속성

문자열.메소드(매개변수)

속 성

length
문자열의 길이입니다.

메 소 드

anchor()
하이퍼텍스트 링크로 사용되는 표식을 지정합니다.

big()
문자열의 크기를 크게 합니다.. <BIG> 태그와 동일한 결과입니다.

blink()
문자열을 깜박이게 합니다.. <BLINK> 태그와 동일한 결과입니다.

bold()
문자열을 볼드체로 보여줍니다. <B> 태그와 동일한 결과입니다.

charAt()
지정된 인덱스에 있는 문자를 반환합니다.

charCodeAt()
문자열의 유니코드 값 알아냅니다.

concat()
두 문자열을 하나로 붙입니다.

fixed()
문자열을 고정된 크기의 폰트로 보여줍니다. <TT> 태그와 동일한 결과입니다.

formCharCode()
유니코드 값에 해당하는 문자 알아냅니다.

fontcolor()
문자열이 지정된 색으로 보이도록 만듭니다.<FONT COLOR=color> 태그와 동일한 결과입니다.

fontsize()
문자열이 지정된 크기로 보이도록 만듭니다.<FONT SIZE=size> 태그와 동일한 결과입니다.

indexOf()
검색한 문자열이 처음으로 나타나는 위치를 반환합니다.

italics()
문자열을 이탤릭체로 보여줍니다. <I> 태그와 동일한 결과입니다.

lastindexOf()
검색한 문자열이 처음으로 나타나는 위치를 반환합니다.(뒤에서부터 검색)

link()
하이퍼텍스트링크를 만듭니다.

match()
문자열에서 정규식 검색하여 성공 여부를 반환합니다.

replace()
정규식에 의한 문자열 치환합니다.

search()
문자열에 정규식 검색하여 위치 파악합니다.

slice()
문자열의 일부를 추출합니다.

small()
문자열을 작은 크기로 나타나게 합니다. <SMALL>태그와 동일한 결과입니다.

split()
문자열을 분리시킵니다.

strike()
문자열 중간에 줄을 그립니다. <STRIKE> 태그와 동일한 결과입니다.

sub()
문자열을 아래첨자로 만듭니다. <SUB> 태그와 동일한 결과입니다.

substring()
문자열 객체의 일부를 반환합니다.

sup()
문자열이 위첨자로 나타나도록 만듭니다. <SUP>와 동일한 결과입니다.

toLowerCase()
문자열을 소문자로 변환합니다.

toSource()
String 객체의 소스 코드를 반환합니다. 넷스케이프에서 동작

toUpperCase()
문자열을 대문자로 변환합니다.

toString()
String 객체를 문자열로 만들어 반환합니다.

valueOf()
String 객체 값을 현재 데이터 타입으로 반환합니다.

이벤트 핸들러

없음


Submit 객체

3 [image] 2

Submit 버튼을 위한 객체입니다.
(1. Submit 버튼을 입력 양식에 입력된 값들을 서버로 보내게 됩니다.
2. onclick 이벤트 핸들러는 submit을 취소시키지 못합니다.
3. 대신 onSubmit 이벤트 핸들러를 이용하면 됩니다. )

사 용 법

submitName.속성

submitName.메소드(매개변수)

formName.elements[배열번호].속성

formName.elements[배열번호].메소드(매개변수)

속 성

form
데이터 보내기 버튼 입력 양식이 포함된 속성입니다.

name
<INPUT> 태그의 NAME 속성입니다.

value
<INPUT> 태그의 VALUE 속성입니다.

type
입력 양식의 종류("submit")입니다.

메 소 드

blur()
데이터 보내기 버튼의 포커스를 다른 곳으로 보냅니다.

click()
Submit 버튼을 클릭시킵니다.

focus()
데이터 보내기 버튼에 포커스 가져옵니다.

handleEvent()
특정 이벤트 핸들러 호출합니다. 넷스케이프에서 동작

이벤트 핸들러

onblur
데이터 보내기 버튼이 포커스를 잃었을 때 발생하는 이벤트 핸들러 입니다.

onclick
마우스로 버튼을 클릭했을 때 발생하는 이벤트 핸들러입니다.

onfocus
데이터 보내기 버튼이 포커스를 얻었을 때 발생하는 이벤트 핸들러입니다.


Text 객체

3 [image] 2

텍스트 입력 양식을 위한 객체입니다.
( 1. 텍스트 입력 양식은 <FORM> 태그의 VALUE 속성입니다.
2. text 객체의 value 특성을 수정함으러써 입력된 값을 즉석에서 바꿀 수 있습니다. )

사 용 법

textName.속성

textName.메소드(매개변수)

formName.elements[배열].속성

formName.elements[배열].메소드(매개변수)

속 성

defaultValue
<INPUT> 태그의 VALUE 속성입니다.

name
<INPUT> 태그의 NAME 속성입니다.

value
텍스트 입력 양식에 입력된 값입니다.

type
입력 양식의 종류("text")입니다.

메 소 드

focus()
텍스트 입력 양식 안에 커서가 들어가게 합니다.

blur()
텍스트 입력 양식 안에 있는 커서를 밖으로 나가게 합니다.

select()
텍스트 입력 양식에 입력된 값을 선택합니다.

handleEvent()
특정 이벤트 핸들러를 호출합니다. 넷스케이프에서 동작

이벤트 핸들러

onFocus
텍스트 입력 양식이 focus를 받았을 때 발생하는 이벤트 핸들러입니다.

inBlur
텍스트 입력 양식이 focus를 잃었을 때 발생하는 이벤트 핸들러입니다.

onChange
텍스트 입력 양식에 입력된 값이 바뀌었을 때 발생하는 이벤트 핸들러입니다.

onSelect
텍스트 입력 양식에 입력된 값을 선택했을 때 발생하는 이벤트 핸들러입니다.


Textarea 객체

3 [image] 2

텍스트 영역을 위한 객체입니다.
( 1. 텍스트 영역에 입력된 값은 value 특성을 통해 알아낼 수 있습니다.
2. 텍스트 영역에서 줄바꿈하는 문자는 운영체계마다 달라집니다.
유닉스 : \n, 윈도우즈 : \r\n, 매킨토시 : \n )

사 용 법

textareaName.속성

textareaName.메소드(매개변수)

formName.elements[배열번호].속성

formName.elements[배열번호].메소드(매개변수)

속 성

form
텍스트 영역이 포함되어 있는 폼 객체입니다.

defaultValue
<INPUT> 태그의 VALUE 속성입니다.

name
<INPUT> 태그의 NAME 속성입니다.

value
텍스트 입력 양식에 입력된 값입니다.

type
입력 양식의 종류("textarea")입니다.

메 소 드

focus()
텍스트 영역 안에 커서가 들어가게 합니다.

blur()
텍스트 영역 안에 있는 커서를 밖으로 나가게 합니다.

select()
텍스트 영역에 입력된 값을 선택하는 메소드

handleEvent()
특정 이벤트 핸들러 호출합니다. 넷스케이프에서 동작

이벤트 핸들러

onfocus
텍스트 영역에 커서가 들어갔을 때 발생하는 이벤트 핸들러입니다.

onblur
텍스트 영역에서 커서가 나갔을 때 발생하는 이벤트 핸들러입니다.

onchange
텍스트 영역에 입력된 값이 바뀌었을 때 발생하는 이벤트 핸들러입니다.

onselect
텍스트 영역에 입력된 값을 선택했을 때 발생하는 이벤트 핸들러입니다.

onkeydown
입력 필드에서 키를 눌렀을 때 발생하는 이벤트 핸들러입니다.

onkeypress
입력 필드에서 키를 눌렀을 때 발생하는 이벤트 핸들러입니다.

onkeyup
입력 필드에서 키를 놓았을 때 발생하는 이벤트 핸들러입니다


Wondow 객체

3 [image] 2

브라우저 윈도우에 관한 정보에 접근하기 위한 객체입니다.
( window 객체는 브라우저 내장 객체의 가장 최상위에 있습니다. )

사 용 법

window.속성

window.메소드(매개변수)

self.속성

self.메소드(매개변수)

top.속성

top.메소드(매개변수)

parent.속성

parent.메소드(매개변수)

windowVar.속성

windowVar.메소드(매개변수)

속성

메소드(매개변수)

속 성

closed
윈도우가 닫혔는지의 여부입니다.

defaultStatus
브라우저의 상태선에 항상 나타나는 정보입니다.

document
윈도우에서 보여주는 문서 정보입니다.

frames
윈도우에 포함되어 있는 프레임들입니다.

history
현 윈도우의 history 객체입니다.

innerHeight
윈도우에서 내용이 나타나는 영역의 높이입니다. 넷스케이프에서 동작

innerWidth
윈도우에서 내용이 나타나는 영역의 너비입니다. 넷스케이프에서 동작

length
윈도우에 포함된 프레임의 수입니다.

location
윈도우에서 보여주는 문서의 URL 주소입니다.

locationbar
윈도우의 Locationbar를 보여줄지의 여부를 지정합니다. 넷스케이프에서 동작

menubar
윈도우의 메뉴를 보여줄지의 여부를 지정합니다. 넷스케이프에서 동작

name
윈도우의 이름입니다.

opener
open() 메소드로 윈도우를 연 문서가 있는 윈도우입니다.

outerHeight
윈도우 바깥 테두리의 높이입니다. 넷스케이프에서 동작

outerWidth
윈도우 바깥 테두리의 너비입니다. 넷스케이프에서 동작

pageXOffset
윈도우에 현재 나타나는 페이지의 x 위치입니다. 넷스케이프에서 동작

pageYOffset
윈도우에 현재 나타나는 페이지의 y 위치입니다. 넷스케이프에서 동작

parent
이 윈도우를 포함하고 있는 윈도우나 프레임입니다.

personalbar
윈도우의 Personalbar를 보여줄지의 여부를 지정합니다.

scrollbars
윈도우의 스크롤 바를 보여줄지의 여부를 지정합니다.

self
자기 자신입니다.

status
브라우저의 상태선에서 보여줄 정보입니다.

statusbar
윈도우의 상태선을 보여줄지의 여부를 지정합니다. 넷스케이프에서 동작

toolbar
윈도우의 툴바를 보여줄지의 여부를 지정합니다. 넷스케이프에서 동작

top
최상단 윈도우입니다.

tags
HTML 문서에 사용된 모든 태그들입니다. 넷스케이프에서 동작

classes
HTML 문서에 정의된 모든 스타일시트 클래스들입니다. 넷스케이프에서 동작

window
자기 자신입니다.

메 소 드

alert()
메시지와 OK버튼만을 가진 다이얼로그 박스를 보여줍니다.

back()
앞 페이지로 이동합니다. 넷스케이프에서 동작

blur()
특정 객체의 포커스 없애줍니다.

captureEvents()
특정 이벤트 타입 잡아내도록 세팅합니다. 넷스케이프에서 동작

clearInterval()
setInterval 해제합니다.

clearTimeout()
setTimeout 해제합니다.

close()
윈도우를 닫습니다.

confirm()
메시지와 OK/Cancel 버튼을 포함한 다이얼로그 박스를 만듭니다.

disableExternalCapture()
enableExternalCapture 해제합니다. 넷스케이프에서 동작

enableExternalCapture()
각 프레임 내의 서로 다른 문서에서 이벤트 잡아낼 수 있게 허용합니다. 넷스케이프에서 동작

find()
윈도우 안에 포함된 텍스트 검색합니다. 넷스케이프에서 동작

focus()
특정 객체에 포커스가 가도록 만듭니다.

forward()
뒤 페이지로 이동합니다. 넷스케이프에서 동작

handleEvent()
특정 이벤트 호출합니다. 넷스케이프에서 동작

home()
홈페이지로 이동합니다. 넷스케이프에서 동작

moveBy()
윈도우로 상대 이동합니다.

moveTo()
윈도우로 절대 이동합니다.

open()
새로운 브라우저 윈도우를 엽니다.

print()
윈도우에 포함된 내용을 출력합니다.

prompt()
메시지와 입력 필드를 가진 다이얼로그 박스를 보여줍니다.

releaseEvents()
특정 이벤트 타입 잡아내는 것을 풀어줍니다. 넷스케이프에서 동작

resizeBy()
윈도우의 상대적 크기로 바꿉니다.

resizeTo()
윈도우의 절대적 크기로 바꿉니다.

setInterval()
주기적으로 명령 실행합니다.

setTimeout()
지정된 시간이 지난 후에 지정된 명령을 실행시키도록 합니다.

routeEvent()
잡은 이벤트 타입을 다른 객체에 전달합니다. 넷스케이프에서 동작

scroll()
윈도우를 특정 위치까지 스크롤시킵니다.

scrollBy()
윈도우에 보여지는 부분을 상대적으로 스크롤합니다.

scrollTo()
윈도우에 보여지는 부분을 절대적으로 스크롤합니다.

setInterval()
지정된 주기 동안 기다린 후 지정된 명령 실행합니다.

setTimeout()
지정된 시간동안 기다린 후 지정된 명령 실행합니다.

stop()
문서 전송 중지시킵니다. 넷스케이프에서 동작

이벤트 핸들러

onLoad
윈도우에 문서가 나타날 때 발생하는 이벤트 핸들러입니다.

onUnload
윈도우에서 문서가 없어질 때 발생하는 이벤트 핸들러입니다.

onError
브라우저가 문서를 읽던 중 에러가 발생했을 때 발생하는 이벤트 핸들러입니다.

onBlur
브라우저가 focus를 잃었을 때 하는 이벤트 핸들러입니다.

onFocus
브라우저가 focus를 얻었을 때하는 이벤트 핸들러입니다.


Argument 객체

5 [image] 4

함수가 실행할 때 함수의 매개변수 정보를 제공합니다.

사 용 법

argumentName.속성

속 성

value
매개변수의 값 정보를 가지고 옵니다.

caller
함수를 실행하는 함수의 매개변수 정보를 가지고 옵니다.

callee
함수가 실행하는 함수의 매개변수 정보를 가지고 옵니다.

메 소 드

없음

이벤트 핸들러

없음


Array 객체

3 [image] 3

배열을 만들어 객체입니다.

사 용 법

배열 객체 이름 = new Array()

배열 객체 이름= new Array(배열 번호)

배열 객체 이름 = new Array(element0, elememt1, ..., element)

속 성

length
배열의 크기 정보를 설정합니다.

prototype
Array 객체에 새로운 속성을 설정해줍니다.

constructor
Array 객체를 만드는데 사용된 생성자 함수를 설정합니다.

index
검색한 문자열에서 처음으로 일치하는 부분이 시작하는 문자 위치를 설정합니다. 익스플로러 5.0 이상에서 지원합니다.

input
정규식 검색에 사용한 문자열을 반환합니다. 익스플로러 5.0 이상에서 지원합니다.

메 소 드

concat(array1, ...)
여러 개의 배열을 하나로 만들어 줍니다.

join([str])
배열의 값을 하나의 문자열로 만들어 줍니다.

pop()
배열의 마지막 요소를 삭제한 후 반환합니다. 넷스케이프에서 동작

push(elem1, ...)
배열에 새로운 요소를 추가한 후 반환합니다. 넷스케이프에서 동작

reverse()
배열을 역순으로 만들어 줍니다.

shift()
배열의 첫 번째요소를 삭제한 후 반환합니다. 넷스케이프에서 동작

slice(begin [, end])
배열의 일부를 추출합니다.

sort(function)
배열을 정렬합니다.

splice(idx, n, e1, ...)
배열의 일부를 수정합니다. 넷스케이프에서 동작

toSource()
Array 객체의 소스 코드를 반환합니다. 넷스케이프에서 동작

toString()
Array 객체를 문자열로 만들어 줍니다.

unshift(e1, e2, ... en)
배열 앞에 요소를 추가한 후 반환합니다. 넷스케이프에서 동작

valueOf()
배열의 값을 현재 가진 데이터 타입으로 반환합니다.

이벤트 핸들러

없음


Boolean 객체

3 [image] 3

boolean 형식의 값을 가지는 객체를 만들어 줍니다.매개변수에는 true나 false 값을 설정합니다.

사 용 법

객체 이름 = new Boolean(true or false)

속 성

prototype
Boolean 객체에 새로운 속성을 추가해줍니다.

constructor
Boolean 객체를 만드는데 사용된 생성자 함수를 설정합니다.

메 소 드

toSource()
Boolean 객체의 소스 코드 반환합니다. 넷스케이프에서 동작합니다.

toString()
Boolean 객체를 문자열로 반환합니다.

valueOf()
현재 값을 boolean 타입으로 반환합니다.

이벤트 핸들러

없음


Button 객체

3 [image] 2

버튼 입력 양식 정보를 제어해주는 객체입니다.

사 용 법

buttonName.속성

buttonName.메소드

formName.elements[배열 번호].속성

formName.elements[배열 번호].메소드

속 성

form
버튼 입력 양식을 포함하고 있는 폼 객체 정보를 가지고 옵니다.

name
버튼 입력 양식의 NAME 속성 정보를 가지고 옵니다.

value
버튼 입력 양식의 VALUE 속성 정보를 가지고 옵니다.

type
버튼 입력 양식의 TYPE 속성 정보를 가지고 옵니다.

메 소 드

blur()
버튼에서 포커스를 다른 요소에 이동시킵니다.

click()
버튼을 클릭해줍니다.

focus()
버튼에 포커스를 가지고 옵니다.

이벤트 핸들러

onblur
버튼에 포커스가 이동될 때 이벤트를 발생합니다.

onclick
마우스로 버튼을 클릭했을 때 이벤트를 발생합니다.

ocfocus
버튼에 포커스가 생성될 때 이벤트를 발생합니다.


Checkbox 객체

3 [image] 2

체크 박스 입력 양식 정보를 제어하는 객체입니다.

사 용 법

checkboxName.속성

checkboxName.메소드

formName.elements[배열 번호].속성

formName.elements[배열 번호].메소드

속 성

form
체크 박스 입력 양식을 포함하는 폼 객체 정보를 가지고 옵니다.

checked
체크 박스를 선택해줍니다.

defaultChecked
<INPUT> 태그에 CHECKED 속성이 설정되어있는 지 확인합니다.

name
체크 박스 입력 양식의 NAME 속성 정보를 제어합니다.

value
체크 박스 입력 양식의 VALUE 속성 정보를 제어합니다.

type
체크 박스 입력 양식의 TYPE 속성 정보를 제어합니다.

메 소 드

blur()
체크 박스에서 포커스를 다른 요소로 이동해줍니다.

click()
체크 박스를 체크해줍니다.

focus()
체크 박스에 포커스를 생성해줍니다.

이벤트 핸들러

onblur
체크 박스에 포커스가 이동되었을 때 이벤트를 발생합니다.

onclick
마우스로 체크 박스를 클릭했을 때 이벤트를 발생합니다.

onfocus
체크 박스에 포커스가 생성되었을 때 이벤트를 발생합니다.


Date 객체

3 [image] 2

날짜와 시간 정보를 생성해줍니다.

사 용 법

객체 이름= new Date()

객체 이름= new Date("monthday,yearhours:minutes:seconds")

객체 이름= new Date("monthday,yearhours:minutes:seconds")

객체 이름= new Date(year, month, day[, hours, minutes, seconds, milliseconds])

속 성

prototype
Data 객체에 새로운 속성을 추가해줍니다.

메 소 드

getYear()
1970년 이후의 연도 정보를 알려줍니다.

getFullYear()
연도 정보를 열려줍니다.

getMonth()
월(月) 정보를 알려줍니다. 1월부터 순서대로 0,1,...순으로 표시됩니다.

getDate()
일(日) 정보를 알려줍니다.

getDay()
요일 정보를 알려 줍니다. 일, 월....요일을 순서대로 0,1,2... 순으로 표시됩니다.

getHour()
시간 정보를알아줍니다.

getMinutes()
분 정보를 알아줍니다.

getSeconds()
초 정보를 알아줍니다.

getTime()
1970년 1월 1일 이후 시간을 1000분의 1초로 표시해줍니다.

getMiliseconds()
1/100초 단위로 표시해줍니다.

getUTCDate()
유니버설 타임의 일 정보를 알려줍니다.

getUTCDay()
유니버설 타임 형식의 요일 정보를 알려줍니다.

getUTCFullYear()
유니버설 타임 형식의 연도 정보를 알려줍니다.

getUTCHours()
유니버설 타임 형식의 시간 정보를 알려줍니다.

getUTCMiliseconds()
유니버설 타임 형식의 1/100초 단위로 표시해줍니다.

getUTCMinutes()
유니버설 타임 형식의 분 정보를 알려줍니다.

getUTCMonth()
유니버설 타임 형식의 월 정보를 알려줍니다.

getUTCSeconds()
유니버설 타임 형식의 초 정보를 알려줍니다.

getTimezoneOffset()
현재 시간의 Timezone offset을 분단위로 설정합니다.

setYear(연도)
특정 연도를 설정합니다.

setFullYear(연도,[월,일])
특정 연도를 설정합니다.

setMonth(월,[일])
특정 월 정보를 설정합니다.

setDate(일)
특정 일(日) 정보를 설정합니다.

setDay(요일)
특정 요일 정보를 설정합니다.

setHours(시,[분,초,1/100초])
특정 시간 정보를 설정합니다.

setMinutes(분,[초,1/100초])
특정 분 정보를 설정합니다.

setSeconds(초,[1/100초])
특정 초 정보를 설정합니다.

setTime(초)
1970년 1월 1일 이후 시간을 1000분의 1초로 단위로 설정합니다.

setMiliseconds(초)
1/100초 단위로 설정합니다.

setUTCDate(일)
유니버설 타임 형식으로 일 정보를 설정합니다.

setUTCFullYear(년도,[월,일])
유니버설 타임 형식의 연도를 설정합니다.

setUTCHours(시,[분,초,1/100초])
유니버설 타임 형식의 시간 정보를 설정합니다.

setUTCMiliseconds(1/100초)
유니버설 타임 형식을 1/100초로 설정합니다.

setUTCMinutes(분,[초,1/100초])
유니버설 타임 형식을 분으로 설정합니다.

setUTCMonth(월,[일])
유니버설 타임 형식의 월 정보를 설정합니다.

setUTCSeconds(초,[1/100초])
유니버설 타임 형식의초 정보를 설정합니다.

parse(날짜 문자열)
1970년 1월 1일 00:00:00 이후에 경과한 시간을 1000분의 1초 단위로 설정합니다.

UTC(년, 월, 일 [,시] [,분] [,초])
GMT 형식으로 1970년 1월 1일 00:00:00 이후에 경과한 시간을 1000분의 1초 단위로 설정합니다.

toGMTString()
GMT(Greenwich Mean Time) 형식으로 날짜 정보를 설정합니다.

toLocaleString()
날짜를 문자열로 변환 합니다.

toString()
날짜를 문자열로 변환 합니다.

toUTCString()
유니버설 타임 형식으로 시간 정보를 설정합니다.

toSource()
Date 객체를 소스코드로 설정합니다.

valueOf()
Date 객체 값을 현재 가진 데이터 형식으로 설정합니다.

이벤트 핸들러

없음


abs ¸Þ¼Òµå

3 [image] 2

¸Å°³º¯¼ö¿¡ ÀÖ´Â °ªÀ» Àý´ë°ªÀ¸·Î °è»êÇÕ´Ï´Ù.

Çü ½Ä

Math.abs(¼ýÀÚ)

°´ Ã¼

Math


big ¸Þ¼Òµå

3 [image] 2

¹®ÀÚ¿ Å©±â¸¦ Å©°Ô ¼³Á¤ÇÕ´Ï´Ù.

Çü ½Ä

¹®ÀÚ¿.big()

°´ Ã¼

string


scroll ¸Þ¼Òµå

4 [image] 3

Æ¯Á¤ ÁÂÇ¥·Î À©µµ¿ì¸¦ ½ºÅ©·ÑÇØ ÁÝ´Ï´Ù.

Çü ½Ä

windowReference.scroll(x ÁÂÇ¥, yÁÂÇ¥)

°´ Ã¼

Window


scrollBy ¸Þ¼Òµå

4

À©µµ¿ì¿¡ Æ÷ÇÔµÈ ³»¿ëÀ» »ó´ëÀûÀÎ ±æÀÌ¸¸Å ½ºÅ©·Ñ½ÃÅµ´Ï´Ù.

Çü ½Ä

windowObject.scrollBy(¼öÆò±æÀÌ, ¼öÁ÷±æÀÌ)

°´ Ã¼

window


scrollTo ¸Þ¼Òµå

4

À©µµ¿ì¿¡ Æ÷ÇÔµÈ ³»¿ëÀ» Àý´ëÀûÀÎ À§Ä¡·Î ½ºÅ©·Ñ½ÃÅµ´Ï´Ù.

Çü ½Ä

windowObject.scrollTo(°¡·Î ÁÂÇ¥°ª,¼¼·Î ÁÂÇ¥°ª)

°´ Ã¼

window


search ¸Þ¼Òµå

4 [image] 4

¹®ÀÚ¿¿¡¼ ¹®ÀÚ¸¦ °Ë»öÇÏ¿© ¹®ÀÚÀ§Ä¡¸¦ ¼ýÀÚ·Î ³Ñ±â°í ¾øÀ»°æ¿ì -1À» ³Ñ±é´Ï´Ù.

Çü ½Ä

¹®ÀÚ¿°´Ã¼.search(¹®ÀÚ)

°´ Ã¼

String


select ¸Þ¼Òµå

3 [image] 2

ÀÔ·Â ¾ç½Ä¿¡ ÀÔ·ÂµÈ ³»¿ëÀ» ¼±ÅÃÇØ ÁÝ´Ï´Ù.

Çü ½Ä

ÀÔ·Â¾ç½Äname.select()

°´ Ã¼

fileupload, password, text, textarea


setDate ¸Þ¼Òµå

3 [image] 2

³¯À» ¼³Á¤ÇØ ÁÝ´Ï´Ù.

Çü ½Ä

date°´Ã¼ÀÌ¸§.setDate(1¿¡¼ 31±îÁöÀÇ Á¤¼ö)

°´ Ã¼

Date


setFullYear ¸Þ¼Òµå

3 [image] 2

³âµµ¸¦ ¼³Á¤ÇØ ÁÝ´Ï´Ù.

Çü ½Ä

date°´Ã¼ÀÌ¸§.setFullYear (³âµµ,[¿ù,ÀÏ])

°´ Ã¼

Date


setHours ¸Þ¼Òµå

3 [image] 2

½Ã¸¦ ¼³Á¤ÇØ ÁÝ´Ï´Ù.

Çü ½Ä

date°´Ã¼ÀÌ¸§ÀÌ³ª ¼Ó¼º.setHours(0¿¡¼ 23±îÁöÀÇ Á¤¼ö)

°´ Ã¼

Date


setInterval ¸Þ¼Òµå

4 [image] 4

ÁÖ±âÀûÀ¸·Î ¸í·ÉÀ» ½ÇÇà½ÃÅµ´Ï´Ù.

Çü ½Ä

setInterval(ÁÖ±âÀûÀ¸·Î ½ÇÇàÇÒ ÇÔ¼ö, ÁÖ±â)

°´ Ã¼

frame, window


setMiliseconds ¸Þ¼Òµå

4 [image] 4

1/100ÃÊ¸¦ ¼³Á¤ÇÕ´Ï´Ù.

Çü ½Ä

date°´Ã¼ÀÌ¸§.setMiliseconds (1/100ÃÊ)

°´ Ã¼

Date


blink ¸Þ¼Òµå

3 [image] 2

¹®ÀÚ¿À» ±ôºýÀÌ°Ô ÇÕ´Ï´Ù.

Çü ½Ä

¹®ÀÚ¿.blink()

°´ Ã¼

string


setMinutes ¸Þ¼Òµå

3 [image] 2

ºÐÀ» ¼³Á¤ÇÕ´Ï´Ù.

Çü ½Ä

date°´Ã¼ÀÌ¸§.setMinutes(0¿¡¼ 59±îÁöÀÇ Á¤¼ö)

°´ Ã¼

Date


setMonth ¸Þ¼Òµå

3 [image] 2

´ÞÀ» ¼³Á¤ÇÕ´Ï´Ù.

Çü ½Ä

date°´Ã¼ÀÌ¸§.setMonth(0¿¡¼ 11±îÁöÀÇ Á¤¼ö)

°´ Ã¼

Date


setSeconds ¸Þ¼Òµå

3 [image] 2

ÃÊ¸¦ ¼³Á¤ÇØ ÁÝ´Ï´Ù.

Çü ½Ä

date°´Ã¼ÀÌ¸§.setSeconds(0¿¡¼ 59±îÁöÀÇ Á¤¼ö)

°´ Ã¼

Date


setTime ¸Þ¼Òµå

3 [image] 2

date °´Ã¼ÀÇ ½Ã°£À» ¼³Á¤ÇÕ´Ï´Ù.

Çü ½Ä

date°´Ã¼ÀÌ¸§.setTime(½Ã°£)

½Ã°£Àº 1970³â 1¿ù 1ÀÏ ÀÌÈÄºÎÅÍ 1/1000´ÜÀ§·Î ÀÔ·ÂÇÕ´Ï´Ù

°´ Ã¼

Date


setTimeout 메소드

3 [image] 2

지정된 시간이 지난 후에 지정된 명령을 실행시킵니다.
한번만 실행됩니다.

형 식

setTimeout(함수, 시간)

시간은 밀리초 단위로 입력합니다.

객 체

frame, window


setUTCDate ¸Þ¼Òµå

4 [image] 4

ÀÏÀ» ¼³Á¤ÇÕ´Ï´Ù.

Çü ½Ä

date°´Ã¼ÀÌ¸§.setUTCDate(ÀÏ)

°´ Ã¼

Date


setUTCFullYear ¸Þ¼Òµå

4 [image] 4

³âÀ» ¼³Á¤ÇÕ´Ï´Ù.

Çü ½Ä

date°´Ã¼ÀÌ¸§.setUTCFullYear(³âµµ,[¿ù,ÀÏ])

°´ Ã¼

Date


setUTCHours ¸Þ¼Òµå

4 [image] 4

½Ã¸¦ ¼³Á¤ÇÕ´Ï´Ù.

Çü ½Ä

date°´Ã¼ÀÌ¸§.setUTCHours(½Ã,[ºÐ,ÃÊ,1/100ÃÊ])

°´ Ã¼

Date


setUTCMiliseconds ¸Þ¼Òµå

4 [image] 4

1/100ÃÊ¸¦ ¼³Á¤ÇÕ´Ï´Ù.

Çü ½Ä

date°´Ã¼ÀÌ¸§.setUTCMiliseconds(1/100ÃÊ)

°´ Ã¼

Date


setUTCMinutes ¸Þ¼Òµå

4 [image] 4

ºÐÀ» ¼³Á¤ÇÕ´Ï´Ù.

Çü ½Ä

date°´Ã¼ÀÌ¸§.setUTCMinutes(ºÐ,[ÃÊ,1/100ÃÊ])

°´ Ã¼

Date


blur ¸Þ¼Òµå

3 [image] 2

ÇöÀç ÁöÁ¤µÈ °´Ã¼·ÎºÎÅÍÀÇ Æ÷Ä¿½º(focus)¸¦ ¾ø¾Ö ÁÝ´Ï´Ù.

Çü ½Ä

ÀÔ·Â¾ç½ÄName.blur()

°´ Ã¼

button, checkbox, password, radio, reset, select, submit, text, textarea


setUTCMonth ¸Þ¼Òµå

4 [image] 4

¿ùÀ» ¼³Á¤ÇÕ´Ï´Ù.

Çü ½Ä

date°´Ã¼ÀÌ¸§.setUTCMonth(¿ù,[ÀÏ])

°´ Ã¼

Date


setUTCSeconds ¸Þ¼Òµå

4 [image] 4

ÃÊ¸¦ ¼³Á¤ÇÕ´Ï´Ù.

Çü ½Ä

date°´Ã¼ÀÌ¸§.setUTCSeconds(ÃÊ,[1/100ÃÊ])

°´ Ã¼

Date


setYear ¸Þ¼Òµå

3 [image] 2

³âÀ» ¼³Á¤ÇÕ´Ï´Ù.

Çü ½Ä

date°´Ã¼ÀÌ¸§.setYear(1900ÀÌ»óÀÇ Á¤¼ö)

°´ Ã¼

Date


setInterval ¸Þ¼Òµå

5 [image] 4

ÀÏÁ¤ÇÑ °£°ÝÀ» µÎ°í ¸í·ÉÀ» ÁÖ±âÀûÀ¸·Î ½ÇÇà½ÃÅ°°íÀÚ ÇÒ ¶§ »ç¿ëÇÕ´Ï´Ù.

Çü ½Ä

À©µµ¿ì°´Ã¼Name.setInterval(ÇÔ¼ö,ÁÖ±â)

°´ Ã¼

window


shift ¸Þ¼Òµå (JavaScript 1.2)

4

¹è¿ÀÇ Ã¹ ¹øÂ° ¿ä¼Ò¸¦ »èÁ¦ÇÑ ÈÄ ¸®ÅÏÇÏ±â.

Çü ½Ä

arrayObject.shift()

°´ Ã¼

Array

Æ¯ Â¡

¾øÀ½


sin ¸Þ¼Òµå

3 [image] 2

Sine °ªÀ» °è»êÇÕ´Ï´Ù.
(-1¿¡¼ 1±îÁöÀÇ °ªÀ» ¹ÝÈ¯ÇÕ´Ï´Ù)

Çü ½Ä

Math.sin(¼ýÀÚ)

°´ Ã¼

Math


slice 메소드

4

문자열이나 배열의 일부를 추출합니다.

형 식

문자열.slice(추출할 문자열의 처음위치,추출할 문자열의 끝위치)

객 체

String/Array


small ¸Þ¼Òµå

3 [image] 2

¹®ÀÚ¿À» ÀÛÀº Å©±â·Î ³ªÅ¸³ª°Ô ÇÕ´Ï´Ù.
(-1¿¡¼ 1±îÁöÀÇ °ªÀ» ¹ÝÈ¯ÇÕ´Ï´Ù)

Çü ½Ä

¹®ÀÚ¿Name.small()

°´ Ã¼

string


splice ¸Þ¼Òµå

4

¹è¿ÀÇ ÀÏºÎ¸¦ ¼öÁ¤ÇÕ´Ï´Ù.

Çü ½Ä

splice(»èÁ¦ÇÒ ¿ä¼ÒÀÇ ½ÃÀÛÀÎµ¦½º, »èÁ¦ÇÒ ¿ä¼ÒÀÇ ¼ö,»õ·Î »ðÀÔµÈ ¿ä¼Ò , ...)

°´ Ã¼

Array


split ¸Þ¼Òµå

4

¹®ÀÚ¿À» ºÐ¸®½ÃÅµ´Ï´Ù.

Çü ½Ä

¹®ÀÚ¿.spilt([¹®ÀÚ¿À» ºÐ¸®ÇÏ´Âµ¥ »ç¿ëÇÏ´Â ¹®ÀÚ³ª ±âÈ£], [ºÐ¸®ÇÒ¼ö])

°´ Ã¼

String


bold ¸Þ¼Òµå

3 [image] 2

¹®ÀÚ¿À» º¼µåÃ¼·Î º¸¿©ÁÝ´Ï´Ù.

Çü ½Ä

¹®ÀÚ¿Name.bold()

°´ Ã¼

string


sqrt ¸Þ¼Òµå

3 [image] 2

Á¦°ö±Ù °ªÀ» °è»êÇÕ´Ï´Ù.

¿ø Çü

Math.sqrt(0ÀÌ³ª ¾çÀÇ Á¤¼ö)

°´ Ã¼

Math


sort ¸Þ¼Òµå

4 [image] 3

¹è¿ÀÇ ¿ä¼ÒµéÀ» Á¤·ÄÇØ ÁÝ´Ï´Ù..

Çü ½Ä

¹è¿Name.sort(ºñ±³ÇÔ¼ö)

°´ Ã¼

Array


split 메소드

4 [image] 3

문자열을 구분하여 배열로 만들어 줍니다.
(이 메소드는 새로운 문자열을 반환합니다)

형 식

문자열Name.split([구분자])

객 체

String


strike ¸Þ¼Òµå

3 [image] 2

¹®ÀÚ¿ Áß°£¿¡ ÁÙÀ» ±×·ÁÁÝ´Ï´Ù.

Çü ½Ä

¹®ÀÚ¿Name.strike()

°´ Ã¼

string


stop ¸Þ¼Òµå

4

¹®¼ Àü¼ÛÀ» Áß´Ü½ÃÅµ´Ï´Ù.
(ºê¶ó¿ìÀúÀÇ Back ¹öÆ°À» ´©¸£´Â °Í°ú µ¿ÀÏÇÑ È¿°ú.)

Çü ½Ä

À©µµ¿ì°´Ã¼.stop()

°´ Ã¼

window


sub ¸Þ¼Òµå

3 [image] 2

¹®ÀÚ¿À» ¾Æ·¡Ã·ÀÚ·Î ¸¸µé¾î ÁÝ´Ï´Ù.

Çü ½Ä

¹®ÀÚ¿Name.sub()

°´ Ã¼

string


submit ¸Þ¼Òµå

3 [image] 2

ÀÔ·Â ¾ç½Ä¿¡ ÀÔ·ÂµÈ °ªÀ» ¼¹ö·Î º¸³»´Â ¸Þ¼Òµå.
(Submit ¹öÆ°À» ´©¸¥ °Í°ú µ¿ÀÏÇÑ È¿°ú)

Çü ½Ä

ÆûName.submit()

°´ Ã¼

form


substr ¸Þ¼Òµå

4

¹®ÀÚ¿ ÀÏºÎ¸¦ ÃßÃâÇÏ´Â ¸Þ¼Òµå.

Çü ½Ä

¹®ÀÚ¿.substr(ÃßÃâÇÒ ¹®ÀÚ¿ÀÇ Ã³À½À§Ä¡, ÃßÃâÇÒ ¹®ÀÚ¿ÀÇ ±æÀÌ)

°´ Ã¼

String


substring 메소드

3 [image] 2

문자열 객체의 일부를 반환합니다.
(1. 문자열의 첫 번째 문자는 인덱스가 0이다.
2. A와 B 사이의 문자열을 추출하여 리턴한다.
3. A와 B가 같은 값이면 빈 문자열을 리턴한다.)

형 식

문자열Name.substring(A,B)

A,B :숫자
 반환할 문자열의 시작 배열번호,반환할 문자열의 끝 배열번호

객 체

string


sup ¸Þ¼Òµå

3 [image] 2

¹®ÀÚ¿ÀÌ À§Ã·ÀÚ·Î ³ªÅ¸³ªµµ·Ï ¸¸µé¾î ÁÝ´Ï´Ù.

Çü ½Ä

¹®ÀÚ¿Name.sup()

°´ Ã¼

string


call ¸Þ¼Òµå

4

¸Þ¼Òµå¸¦ È£ÃâÇÏ´Â °³Ã¼ ³»¿¡¼ ´Ù¸¥ °´Ã¼ÀÇ ¸Þ¼Òµå ½ÇÇàÇÕ´Ï´Ù.

Çü ½Ä

ÇÔ¼ö°´Ã¼.call()

°´ Ã¼

Function


taint ¸Þ¼Òµå

3 [image] 3

¼Ó¼º¿¡ taintingÀ» ´õÇÕ´Ï´Ù.

Çü ½Ä

taint(¼Ó¼ºÀÌ¸§)

°´ Ã¼

¾øÀ½


tan ¸Þ¼Òµå

3 [image] 2

Tangent °ªÀ» ¹ÝÈ¯ÇÕ´Ï´Ù.

Çü ½Ä

Math.tan(¼ýÀÚ)

°´ Ã¼

Math


toGMTString 메소드

3 [image] 2

인터넷 GMT 방법으로 날짜를 문자열로 바꾸어 줍니다.
(이 메소드의 리턴 값은 플랫폼마다 다르다.)

형 식

date객체이름.toGMTString()

dateObjectName
date 객체나 기존 객체의 속성

객 체

Date


toLocaleString ¸Þ¼Òµå

3 [image] 2

ÇöÀç Áö¿ª Ç¥±â¹ýÀ¸·Î ³¯Â¥¸¦ ¹®ÀÚ¿·Î º¯È¯ÇÏ¿© ÁÝ´Ï´Ù.

Çü ½Ä

date°´Ã¼ÀÌ¸§.toLocaleString()

°´ Ã¼

Date


toLowerCase ¸Þ¼Òµå

2

¹®ÀÚ¿À» ¼Ò¹®ÀÚ·Î º¯È¯ÇÕ´Ï´Ù.

Çü ½Ä

¹®ÀÚ¿.toLowerCase()

°´ Ã¼

String


toSource ¸Þ¼Òµå

4.06

°´Ã¼ÀÇ ¼Ò½ºÄÚµå¸¦ ¹ÝÈ¯ÇÕ´Ï´Ù.

Çü ½Ä

°´Ã¼ÀÌ¸§.toSource()

°´ Ã¼

¸ðµç °´Ã¼


toString ¸Þ¼Òµå

3 [image] 2

°´Ã¼¸¦ ¹®ÀÚ¿·Î ¹Ù²Ù¾î ÁÝ´Ï´Ù.

Çü ½Ä

°´Ã¼ÀÌ¸§.toString([radix])

°´ Ã¼

¸ðµç °´Ã¼


toUTCString ¸Þ¼Òµå

4 [image] 4

À¯´Ï¹ö¼³ Å¸ÀÓ¿¡ ÀÇÇÑ ½Ã°£À» ¹ÝÈ¯ÇÕ´Ï´Ù.

Çü ½Ä

date°´Ã¼ÀÌ¸§.toUTCString()

°´ Ã¼

Date


unescape ÇÔ¼ö

3 [image] 2

ASCII ¹®ÀÚ¿À» ISO ¹®ÀÚ¿·Î º¯È¯ÇÏ¿© ÁÝ´Ï´Ù.

Çü ½Ä

unescape("ASCII")

°´ Ã¼

¾øÀ½


captureEvents ¸Þ¼Òµå

4

Æ¯Á¤ ÀÌº¥Æ® Å¸ÀÔÀ» Àâ¾Æ³»¾î ÁÝ´Ï´Ù.

Çü ½Ä

°´Ã¼ÀÌ¸§.captureEvents(Event.ÀÌº¥Æ®Å¸ÀÔ)

°´ Ã¼

window,document


unshift ¸Þ¼Òµå

4

¹è¿¿¡ ¿ä¼Ò¸¦ Ãß°¡ÇÏ°í »õ ¹è¿Å©±â¸¦ ¹ÝÈ¯ÇÕ´Ï´Ù.

Çü ½Ä

¹è¿.unshift(e1, e2, ..., en)

e1, e2, ..., en
Ãß°¡ÇÒ ¿ä¼Ò

°´ Ã¼

Array


untaint ¸Þ¼Òµå

3

¼Ó¼º¿¡ taintingÀ» ¾ø¾ÖÁÝ´Ï´Ù.

Çü ½Ä

untaint(¼Ó¼ºÀÌ¸§)

°´ Ã¼

¾øÀ½


UTC ¸Þ¼Òµå

3 [image] 2

1970³â 1¿ù 1ÀÏ 00:00:00 ÀÌÈÄ ½Ã°£À» ¹Ð¸®ÃÊ·Î ¹ÝÈ¯ÇÏ¿© ÁÝ´Ï´Ù.

Çü ½Ä

Date.UTC(³â, ´Þ, ÀÏ, [,½Ã] [,ºÐ] [,ÃÊ])

³â ( 1900³â ÀÌÈÄ ¿¬µµ)

¿ù(0~11)

ÀÏ(1~31)

½Ã(0~23)

ºÐ(0~59)

ÃÊ(0~59)

°´ Ã¼

Date


write ¸Þ¼Òµå

3 [image] 2

ÁöÁ¤µÈ À©µµ¿ìÀÇ ¹®¼¿¡ HTML Çü½ÄÀ¸·Î ¾¹´Ï´Ù.

Çü ½Ä

document.write(expression1[,expression2],...[,expressionN])

expression1 ... expressionN
HTML Çü½Ä

°´ Ã¼

document


writeIn ¸Þ¼Òµå

3 [image] 2

ÁöÁ¤µÈ À©µµ¿ìÀÇ ¹®¼¿¡ HTML Çü½ÄÀ¸·Î ¾²¸é¼ ÁÙÀ» ¹Ù²Ù¾î ÁÝ´Ï´Ù.

Çü ½Ä

document.writeIn(expression1[,expression2], ...[,expressionN])

expression1 ... expressionN
(HTML Çü½Ä)

°´ Ã¼

document


ceil ¸Þ¼Òµå

3 [image] 2

ÁöÁ¤µÈ ¼ýÀÚº¸´Ù °°°Å³ª ÀÛÁö ¾ÊÀº Á¤¼ö¸¦ ¹ÝÈ¯ÇÏ¿© ÁÝ´Ï´Ù.

Çü ½Ä

Math.ceil(¼ýÀÚ)

°´ Ã¼

Math


charAt 메소드

3 [image] 2

지정된 인덱스에 있는 문자를 반환하여 줍니다.
(1. 정수는 문자열의 왼쪽에서 오른쪽으로 번호가 매겨진다.
2. 정수는 0부터 시작한다.
3. 정수가 범위를 벗어나게 되면 빈 문자열을 리턴하게 된다 )

형 식

문자열.charAt(정수)

정수
(0에서 stringName.length-1까지)

객 체

string


charCodeAt ¸Þ¼Òµå

4 [image] 4

¹®ÀÚ¿ÀÇ Æ¯Á¤ À§Ä¡¿¡ ÀÖ´Â ¹®ÀÚÀÇ À¯´ÏÄÚµå °ªÀ» ¾Ë¾Æ³»¾î ÁÝ´Ï´Ù.

Çü ½Ä

string°´Ã¼.charCodeAt(Á¤¼ö)

Á¤¼ö
(¹®ÀÚÀÇ À§Ä¡)

°´ Ã¼

string


clearInterval ¸Þ¼Òµå

4 [image] 4

setInterval ¸Þ¼Òµå·Î ¼³Á¤µÈ ¸Þ¼Òµå¸¦ Ãë¼ÒÇÏ¿© ÁÝ´Ï´Ù.

Çü ½Ä

clearInterval (intervallD)

intervallD
setInterval ¸Þ¼Òµå¿¡¼ ¸®ÅÏµÈ °ª

°´ Ã¼

frame, window


acos 메소드

3 [image] 2

Arc cosine 값을 반환합니다.
(1. 0부터 l 사이의 값을 리턴한다.
2. 만약 입력 값이 범위를 벗어나는 경우에는 0을 리턴한다.)

형 식

Math.acos(숫자)

숫자
숫자(-1과 1 사이)나 기존 객체의 특성

객 체

Math


clearTimeout ¸Þ¼Òµå

3 [image] 2

setTimeout ¸Þ¼Òµå·Î ¼³Á¤µÈ Å¸ÀÓ¾Æ¿ôÀ» Ãë¼ÒÇÕ´Ï´Ù..

Çü ½Ä

clearTimeout(timeoutlD)

timeoutlD
setTimeout ¸Þ¼Òµå¿¡¼ ¹ÝÈ¯µÈ °ª

°´ Ã¼

frame, window


click 메소드

3 [image] 2

입력 양식에서 마우스로 클릭하는 것을 흉내내주는 메소드.
( 1. button, reset, submit 객체의 경우에는 버튼을 누르는 것과 동일한 결과
2. radio 객체의 경우에는 라디오 버튼을 선택하는 것과 동일한 결과
3. checkbox 객체의 경우에는 체크하는 것과 동일한 결과 )

형 식

입력양식Name.click()

객 체

button, checkbox, radio, reset, submit


close(document 객체)메소드

3 [image] 2

출력 스트림을 닫고 문자가 강제로 출력되도록 합니다.
( open() 메소드로 열려진 문서를 닫는 역할)

형 식

document.close()

객 체

document


close(window °´Ã¼)¸Þ¼Òµå

3 [image] 2

À©µµ¿ì ÇÏ³ª¸¦ ´Ý½À´Ï´Ù.
( open() ¸Þ¼Òµå·Î ¿¬ À©µµ¿ì¸¦ ´Ý´Â °´Ã¼ )

Çü ½Ä

windowReference.close()

°´ Ã¼

window


concat ¸Þ¼Òµå

4 [image] 4

¹®ÀÚ¿°ú ¸Å°³º¯¼öÀÇ ¹®ÀÚ¸¦ ÇÏ³ªÀÇ ¹®ÀÚ¿·Î ¸¸µé¾î ÁÝ´Ï´Ù

Çü ½Ä

¹®ÀÚ¿.concat(¹®ÀÚ)

°´ Ã¼

String/Array


confirm 메소드

3 [image] 2

메시지와 OK/Cancel 버튼을 포함한 다이얼로그 박스를 만듭니다.
( 1. 사용자로부터 응답을 듣고 싶을 때 사용하는 메소드
2. 사용자가 OK 버튼을 누르면 true가 리턴되고, Cancel 버튼을 누르면 false가 반환된다.)

형 식

confirm("문자열")

객 체

window


cos ¸Þ¼Òµå

3 [image] 2

Cosine °ªÀ» ¹ÝÈ¯ÇÕ´Ï´Ù.
( -1¿¡¼ 1 »çÀÌÀÇ °ªÀÌ ¹ÝÈ¯µË´Ï´Ù.)

Çü ½Ä

Math.cos(¼ýÀÚ)

°´ Ã¼

Math


escape 함수

3 [image] 2

ISO 문자열을 ASCII으로 바꾸어 반환하는 함수입니다.

형 식

escape("문자열")

문자열
IOS Latin1 문자열

객 체

1. escape는 특정 객체에 속한 메소드가 아닌 독립 함수이다.

2. 리턴되는 값은 "%xx"의 형태로 나오게 된다.


eval 함수

3 [image] 2

문자열로 된 수식을 계산하여 결과를 반환합니다.
( eval() 함수는 자바스크립트 내장 함수로서 특정 객체에 속한 메소드가 아니다 )

형 식

eval(문자열)

문자열
자바스크립트 수식이 문자열로 되어 있는 것

객 체

없음


exp ¸Þ¼Òµå

3 [image] 2

¿ÀÀÏ·¯ »ó¼ö e°¡ ¹ØÀÎ Áö¼ö °ªÀ» ¹ÝÈ¯ÇÕ´Ï´Ù.

Çü ½Ä

Math.exp(¼ýÀÚ)

°´ Ã¼

Math


alert 메소드

3 [image] 2

메시지와 OK 버튼만을 가진 다이얼로그 박스를 보여줍니다.
( 1. 사용자의 요구를 받을 필요가 없는 메시지의 경우에 사용할 수 있습니다.
2. alert()가 window의 메소드이지만 window 객체를 지정할 필요는 없습니다. )

형 식

alert("문자열")

객 체

window


find 메소드

4 [image] 4

윈도우에 포함되어 있는 텍스트 중에서 원하는 문자열을 찾아줍니다.
( 브라우저의 Find 버튼을 누르는 것과 동일한 결과 )

형 식

windowObject.find("문자열" [,case_sensitive] [,search_dir])

문자열
( 검색할 문자열 )

case_sensitive
대소문자 구분

search_dir
전후 검색

객 체

window


fixed ¸Þ¼Òµå

3 [image] 2

¹®ÀÚ¿À» °íÁ¤µÈ Å©±âÀÇ ÆùÆ®·Î º¸¿©ÁÝ´Ï´Ù.

Çü ½Ä

¹®ÀÚ¿.fixed()

°´ Ã¼

string


floor °´Ã¼

3 [image] 2

ÁöÁ¤µÈ ¼ýÀÚº¸´Ù °°°Å³ª Å©Áö ¾ÊÀº Á¤¼ö¸¦ ¹ÝÇÑÇÕ´Ï´Ù.

Çü ½Ä

Math.floor(¼ýÀÚ)

°´ Ã¼

Math


focus ¸Þ¼Òµå

3 [image] 2

ÁöÁ¤µÈ °´Ã¼¿¡ Æ÷Ä¿½º(focus)¸¦ ÁÝ´Ï´Ù.

Çü ½Ä

ÀÔ·Â¾ç½ÄName.focus()

°´ Ã¼

button, checkbox, password, radio, reset, select, submit, text, textarea


fontcolor 메소드

3 [image] 2

문자열이 지정된 색으로 보이도록 만드어 줍니다.

형 식

문자열.fontcolor(색상)

stringName : 문자열이나 기존 객체의 속성

색상
( 색상이름이나 기존 객체의 속성 혹은 RGB를 나타내는 16진수 모음 )

객 체

string


forward 메소드

4 [image] 4

히스토리 리스트의 현재 위치에서 뒤에 있는 URL 문서로 이동합니다.
(브라우저의 앞으로 버튼을 누르는 것과 동일한 효과.)

형 식

windowObject.forward()

객 체

history, window


fontsize 메소드

3 [image] 2

문자열이 지정된 크기로 보이도록 만들어 줍니다.
( 1. 폰트의 크기를 지정하는 메소드.
2. "-2"로 지정할 때에는 <BASEFONT> 태그로 지정된 크기 보다 2 만큼 적은 크기로 폰트를 만든다. )

형 식

문자열.fontsize(숫자)

숫자
( 1에서 7까지의 정수 )

객 체

string


fromCahrCode ¸Þ¼Òµå

4 [image] 4

À¯´ÏÄÚµå °ªÀ» ÅëÇØ ISO ¹®ÀÚ¸¦ ¹ÝÈ¯ÇØ ÁÝ´Ï´Ù..

Çü ½Ä

¹®ÀÚ¿.fromCahrCode(num1,num2,...,numN)

num1, num2, ..., numn
¹®ÀÚ·Î ¸¸µé ISO Latin1 °ªµé

°´ Ã¼

string


getDate ¸Þ¼Òµå

3 [image] 2

ÁöÁ¤µÈ ³¯Â¥ÀÇ ³¯À» ¹ÝÈ¯ÇÏ¿© ÁÝ´Ï´Ù.
( 1ºÎÅÍ 31±îÁöÀÇ Á¤¼ö°ªÀ» ¹ÝÈ¯ÇÕ´Ï´Ù. )

Çü ½Ä

date°´Ã¼ÀÌ¸§.getDate()

°´ Ã¼

Date


getDay 메소드

3 [image] 2

지정된 날짜의 요일을 반환하여 줍니다.
( 1. 각 요일을 숫자로 리턴하게 된다.
2. 0이면 일요일, 1이면 월요일, ... )

형 식

date객체이름.getDay()

객 체

Date


anchor 메소드

3 [image] 2

하이퍼텍스트 링크로 사용되는 표식을 지정합니다.
( <A> 태그의 NAME 속성으로 만들 수 있는 표식을 만드는 메소드 )

형 식

문자열.anchor(문자열 속성)

문자열 속성
( 문자열이나 기존 객체의 특성 )

객 체

string


getHours 메소드

3 [image] 2

지정된 날짜의 시간을 리턴하는 메소드.

형 식

dateObjectName.getHours()

dateObjectName : date 객체 이름이나 기존 객체의 속성

객 체

Date

특 징

0에서 23까지의 정수를 리턴한다.


getMiliseconds ¸Þ¼Òµå

getMiliseconds ¸Þ¼Òµå (JavaScript 1.3) (JScript 3.0)

4 [image] 4

ÁöÁ¤µÈ ³¯Â¥ÀÇ 1/100ÃÊ¸¦ ¸®ÅÏÇÏ´Â ¸Þ¼Òµå.

Çü ½Ä

dateObjectName.getMiliseconds()

dateObjectName
date °´Ã¼ ÀÌ¸§ÀÌ³ª ±âÁ¸ °´Ã¼ÀÇ ¼Ó¼º

°´ Ã¼

Date

Æ¯ Â¡

¾øÀ½


getMinutes ¸Þ¼Òµå

3 [image] 2

ÁöÁ¤µÈ ³¯Â¥ÀÇ ºÐÀ» ¹ÝÈ¯ÇÏ¿© ÁÝ´Ï´Ù.
( 0¿¡¼ 59±îÁöÀÇ Á¤¼ö¸¦ ¹ÝÈ¯ÇÕ´Ï´Ù. )

Çü ½Ä

date°´Ã¼ÀÌ¸§.getMinute()

°´ Ã¼

Date


getMonth ¸Þ¼Òµå

3 [image] 2

ÁöÁ¤µÈ ³¯Â¥ÀÇ ´ÞÀ» ¹ÝÈ¯ÇÕ´Ï´Ù.
( 1. 0¿¡¼ 11±îÁöÀÇ °ªÀ» ¹ÝÈ¯ÇÕ´Ï´Ù.
2. 0ÀÌ¸é 1¿ù, 1ÀÌ¸é 2¿ù, ... )

Çü ½Ä

date°´Ã¼ÀÌ¸§.getMinute()

°´ Ã¼

Date


getSeconds ¸Þ¼Òµå

3 [image] 2

ÁöÁ¤µÈ ³¯Â¥ÀÇ ÃÊ¸¦ ¹ÝÈ¯ÇÏ¿© ÁÝ´Ï´Ù.
( 0¿¡¼ 59±îÁöÀÇ °ªÀ» ¹ÝÈ¯ÇÕ´Ï´Ù. )

Çü ½Ä

date°´Ã¼ÀÌ¸§.getSeconds()

°´ Ã¼

Date


getSelection ¸Þ¼Òµå

3 [image] 2

¸¶¿ì½º·Î µå·¡±×ÇÏ¿© ¼±ÅÃµÈ ¹®ÀÚ¿À» ¹ÝÈ¯ÇÕ´Ï´Ù.

Çü ½Ä

document°´Ã¼.getSelection()

°´ Ã¼

document


getTime ¸Þ¼Òµå

3 [image] 2

ÁöÁ¤µÈ ³¯Â¥ÀÇ ½Ã°£À» ¹ÝÈ¯ÇÏ¿© ÁÝ´Ï´Ù.
( 1970³â 1¿ù 1ÀÏ 00:00:00 ÀÌÈÄÀÇ ½Ã°£À» ¸®ÅÏÇÑ´Ù. )

Çü ½Ä

date°´Ã¼ÀÌ¸§.getTime()

°´ Ã¼

document


getTimezoneOffset 메소드

3 [image] 2

현재 로컬 시간에 대한 time zone offset을 반환하여 줍니다.
( time zone offset이라는 것은 로컬 시간과 GMT간의 차이를 의미 한다. )

형 식

date객체이름.getTimezoneOffset()

객 체

Date


getUTCDate ¸Þ¼Òµå

4 [image] 4

À¯´Ï¹ö¼³ Å¸ÀÓ¿¡ ÀÇÇÑ ÀÏ(1~31)À» ¹ÝÈ¯ÇÏ¿© ÁÝ´Ï´Ù.

Çü ½Ä

date°´Ã¼ÀÌ¸§.getUTCDate()

°´ Ã¼

Date


getUTCDay ¸Þ¼Òµå (JavaScript 1.3)

getUTCDay ¸Þ¼Òµå (JavaScript 1.3) (JScript 3.0)

4 [image] 4

À¯´Ï¹ö¼³ Å¸ÀÓ¿¡ ÀÇÇÑ ¿äÀÏ(0=ÀÏ¿äÀÏ, 1=¿ù¿äÀÏ, ...)À» ¹ÝÈ¯ÇÏ¿© ÁÝ´Ï´Ù.

Çü ½Ä

date°´Ã¼ÀÌ¸§.getUTCDay()

°´ Ã¼

Date


apply ¸Þ¼Òµå

4

¸Þ¼Òµå¸¦ È£ÃâÇÏ´Â °´Ã¼ ³»¿¡¼ ´Ù¸¥ °´Ã¼ÀÇ ¸Þ¼Òµå¸¦ Àû¿ëÇÕ´Ï´Ù.

Çü ½Ä

function°´Ã¼.apply()

°´ Ã¼

Function


getUTCFullTear ¸Þ¼Òµå

4 [image] 4

À¯´Ï¹ö¼³ Å¸ÀÓ¿¡ ÀÇÇÑ ³âµµ¸¦ ¹ÝÈ¯ÇÏ¿© ÁÝ´Ï´Ù.

Çü ½Ä

date°´Ã¼ÀÌ¸§.getUTCFullYear()

°´ Ã¼

Date


getUTCHours ¸Þ¼Òµå

4 [image] 4

À¯´Ï¹ö¼³ Å¸ÀÓ¿¡ ÀÇÇÑ ½Ã¸¦ ¹ÝÈ¯ÇÏ¿© ÁÝ´Ï´Ù.

Çü ½Ä

date°´Ã¼ÀÌ¸§.getUTCHours()

°´ Ã¼

Date


getUTCMiliseconds ¸Þ¼Òµå

4 [image] 4

À¯´Ï¹ö¼³ Å¸ÀÓ¿¡ ÀÇÇÑ 1/100ÃÊ°ªÀ» ¹ÝÈ¯ÇÏ¿© ÁÝ´Ï´Ù.

Çü ½Ä

date°´Ã¼ÀÌ¸§ObjectName.getUTCMiliseconds()

°´ Ã¼

Date


getUTCMinutes ¸Þ¼Òµå

4 [image] 4

À¯´Ï¹ö¼³ Å¸ÀÓ¿¡ ÀÇÇÑ ºÐÀ» ¹ÝÈ¯ÇÏ¿© ÁÝ´Ï´Ù.

Çü ½Ä

date°´Ã¼ÀÌ¸§.getUTCMinutes()

°´ Ã¼

Date


getUTCMonth ¸Þ¼Òµå

4 [image] 4

À¯´Ï¹ö¼³ Å¸ÀÓ¿¡ ÀÇÇÑ ¿ùÀ» ¹ÝÈ¯ÇÏ¿© ÁÝ´Ï´Ù.

Çü ½Ä

date°´Ã¼ÀÌ¸§.getUTCMonth()

°´ Ã¼

Date


getUTCSeconds ¸Þ¼Òµå

4 [image] 4

À¯´Ï¹ö¼³ Å¸ÀÓ¿¡ ÀÇÇÑ ÃÊ¸¦ ¹ÝÈ¯ÇÏ¿© ÁÝ´Ï´Ù.

Çü ½Ä

date°´Ã¼ÀÌ¸§ObjectName.getUTCSeconds()

°´ Ã¼

Date


getYear ¸Þ¼Òµå

3 [image] 2

ÁöÁ¤µÈ ³¯Â¥ÀÇ ³âÀ» ¹ÝÈ¯ÇÏ¿© ÁÝ´Ï´Ù.
( 1996³âÀÌ¸é 96À» ¸®ÅÏÇÑ´Ù.)

Çü ½Ä

date°´Ã¼ÀÌ¸§.getYear()

°´ Ã¼

Date


getFullYear ¸Þ¼Òµå

4 [image] 4

ÁöÁ¤µÈ ³¯Â¥ÀÇ ³âÀ» ¹ÝÈ¯ÇÏ¿© ÁÝ´Ï´Ù.
( 2001³âÀÌ¸é 2001À» ¸®ÅÏÇÑ´Ù. )

Çü ½Ä

date°´Ã¼ÀÌ¸§.getFullYear()

°´ Ã¼

Date


go 메소드

3 [image] 2

히스토리 리스트에 있는 URL 주소로 이동하게 합니다.

형 식

history.go(번호 | "URL")

번호
정수나 기존 객체의 속성, 히스토리 리스트에서 상대 위치 지정

URL
 히스토리 리스트에서 URL 이름

객 체

history


handleEvent ¸Þ¼Òµå

4

Æ¯Á¤ ÀÌº¥Æ® ÇÚµé·¯¸¦ È£ÃâÇÕ´Ï´Ù.

Çü ½Ä

°´Ã¼.handleEvent()

°´ Ã¼

button, checkbox, document, form, link


asin 메소드

3 [image] 2

Arc sine 값을 반환하여 줍니다.
( 1. -Pl/2부터 Pl/2 사이의 값을 리턴한다.
2. 만약 입력 값이 범위를 벗어나는 경우에는 0을 반환합니다.)

형 식

Math.asin(숫자)

숫자
(-1과 1 사이의 수나 기존 객체의 속성 )

객 체

Math


home ¸Þ¼Òµå

4 [image] 4

È¨ÆäÀÌÁö·Î ÁöÁ¤µÈ °÷À¸·Î ÀÌµ¿ÇÕ´Ï´Ù.
( ºê¶ó¿ìÀúÀÇ Home ¹öÆ°À» ´©¸£´Â °Í°ú µ¿ÀÏÇÑ È¿°ú. )

Çü ½Ä

windowObject.home()

°´ Ã¼

window


indexOf 메소드

3 [image] 2

검색한 문자열이 처음으로 나타나는 위치를 반환하여 줍니다.
( 1. 검색은 문자열의 왼쪽에서 오른쪽으로 합니다.
2. 문자열의 첫 번째 문자는 인덱스가 0입니다.
3. 검색 문자열을 찾지 못하면 -1을 반환합니다. )

형 식

문자열.indexOf(검색할 문자열, [숫자])

숫자
( 0에서 stringName.length-1까지). 검색을 시작할 위치

객 체

string


isFinite ÇÔ¼ö

4 [image] 4

À¯ÇÑ¼öÀÎÁö ¿©ºÎ¸¦ Á¶»çÇÕ´Ï´Ù.

Çü ½Ä

isFinite(¼ýÀÚ)

°´ Ã¼

¾øÀ½


isNaN 함수

3 [image] 2

유닉스 시스템에서 매개변수가 "NaN"인지를 검사(Not A Number)하여 줍니다.
( 1. 이 함수는 자바스크립트 내장 함수로 객체에 속한 메소드가 아니다.
2. 이 함수는 유닉스 시스템에서만 사용합니다.
3. 이 함수는 true나 false를 반환합니다. )

형 식

isNaN(testValue)

testValue
검색할 값

객 체

없음


italics 메소드

3 [image] 2

문자열을 이탤릭체로 보여주게 합니다.
( 1. 이 함수는 자바스크립트 내장 함수로 객체에 속한 메소드가 아닙니다.
2. 이 함수는 유닉스 시스템에서만 사용됩니다.
3. 이 함수는 true나 false를 반환합니다.

형 식

문자열.italics()

객 체

string


javaEnabled 메소드

4 [image] 3

자바를 사용할 수 있는 상태인지를 체크하여 줍니다.
( 자바를 사용할 수 있으면 true를 리턴하고 그렇지 않으면 false를 반환합니다.)

형 식

navigator.javaEnabled()

객 체

navigator


join ¸Þ¼Òµå

4 [image] 3

¹è¿¿¡ ÀÖ´Â ¸ðµç ¿ä¼ÒµéÀ» ÇÏ³ª·Î ÇÕÇÏ¿© ¹®ÀÚ¿·Î ¸¸µé¾î ÁÝ´Ï´Ù.

Çü ½Ä

arrayName.join(separator)

°´ Ã¼

Array


lastIndexOf 메소드

4 [image] 2

검색한 문자열이 처음으로 나타나는 위치를 반환하여 줍니다.
( 1. indexOf 메소드와 반대로 뒤에서부터 검색을 시작합니다.
2. 문자열의 첫 번째 문자는 인덱스가 0입니다.
3. 검색 문자열을 찾지 못하면 -1을 반환합니다.

형 식

문자열.lastIndexOf(검색할 문자열, [숫자])

stringName
문자열이나 기존 객체의 속성

searchValue
문자열이나 기존 객체의 속성. 검색할 문자열

숫자
( 0에서 stringName.length-1 까지, 검색을 시작할 위치 )

객 체

string


link ¸Þ¼Òµå

3 [image] 2

ÇÏÀÌÆÛÅØ½ºÆ® ¸µÅ©¸¦ ¸¸µé¾î ÁÝ´Ï´Ù.
( <A HERF=" ">À¸·Î ÁöÁ¤ÇÏ´Â ¸µÅ©¿Í µ¿ÀÏÇÕ´Ï´Ù. )

Çü ½Ä

linkText.link(URL)

°´ Ã¼

¾øÀ½


load ¸Þ¼Òµå

4 [image] 4

ÇöÀç ·¹ÀÌ¾î¿¡¼ HTML ¹®¼¸¦ ÀÐ¾îµéÀÔ´Ï´Ù.

Çü ½Ä

document.layers[index].load(URL,¼ýÀÚ)

URL
HTML ¹®¼ÀÇ URL ÁÖ¼Ò

¼ýÀÚ
·¹ÀÌ¾îÀÇ ³Êºñ

°´ Ã¼

layer


atan ¸Þ¼Òµå

3 [image] 2

Arc tangent °ªÀ» ¹ÝÈ¯ÇÏ¿© ÁÝ´Ï´Ù.
( -Pl/2ºÎÅÍ Pl/2 »çÀÌÀÇ °ªÀ» ¹ÝÈ¯ÇÕ´Ï´Ù. )

Çü ½Ä

Math.atan(¼ýÀÚ)

°´ Ã¼

Math


log 메소드

3 [image] 2

로그 값(e가 밑)을 반환하여 줍니다.
( 매개변수가 지정된 범위를 넘어서면
언제나 -1.797693134862316e+308 값을 반환합니다. )

형 식

Math.log(숫자)

객 체

Math


match ¸Þ¼Òµå

4 [image] 4

¹®ÀÚ¿¿¡¼ Á¤±Ô½Ä °Ë»öÇÏ¿© ¼º°ø ¿©ºÎ¸¦ ¹ÝÈ¯ÇÏ¿© ÁÝ´Ï´Ù.

Çü ½Ä

¹®ÀÚ¿.match(Á¤±Ô½Ä)

°´ Ã¼

String


max ¸Þ¼Òµå

3 [image] 2

ÀÔ·ÂµÈ µÎ ¼ýÀÚ Áß Å« °ªÀ» ¹ÝÈ¯ÇÏ¿© ÁÝ´Ï´Ù.

Çü ½Ä

Math.max(¼ýÀÚ, ¼ýÀÚ)

°´ Ã¼

Math


min ¸Þ¼Òµå

3 [image] 2

ÀÔ·ÂµÈ µÎ ¼ýÀÚ Áß ÀÛÀº °ªÀ» ¹ÝÈ¯ÇÏ¿© ÁÝ´Ï´Ù.

Çü ½Ä

Math.min(¼ýÀÚ, ¼ýÀÚ)

°´ Ã¼

Math


moveAbove ¸Þ¼Òµå

4

ÇöÀç ·¹ÀÌ¾î¸¦ ¸Å°³º¯¼ö·Î ÁöÁ¤ÇÑ ·¹ÀÌ¾î À§·Î ¿Ã·ÁÁÝ´Ï´Ù.

Çü ½Ä

document.layers[index].moveAbove(layer)

layer
·¹ÀÌ¾î

°´ Ã¼

layer


moveBelow ¸Þ¼Òµå

4

ÇöÀç ·¹ÀÌ¾î¸¦ ¸Å°³º¯¼ö·Î ÁöÁ¤ÇÑ ·¹ÀÌ·¯ ¹ØÀ¸·Î ³»·ÁÁÝ´Ï´Ù.

Çü ½Ä

document.layers[index].moveBelow(layer)

layer
·¹ÀÌ¾î

°´ Ã¼

layer


moveBy ¸Þ¼Òµå

4

À©µµ¿ì/·¹ÀÌ¾î¸¦ »ó´ëÀûÀÎ °Å¸®¸¸Å ÀÌµ¿½ÃÄÑÁÝ´Ï´Ù.

Çü ½Ä

°´Ã¼ÀÌ¸§.moveBy(¼öÆòÀÌµ¿°Å¸®,¼öÁ÷ÀÌµ¿°Å¸®)

°´ Ã¼

window, layer


moveTo 메소드

4

윈도우/레이어를 절대적인 위치로 이동시켜줍니다.

형 식

객체이름.moveTo(x, y)

x
이동할 위치의 x 좌표

y
이동할 위치의 y 좌표

객 체

window, layer


moveToAbsolute ¸Þ¼Òµå

4

·¹ÀÌ¾î¸¦ Àý´ëÀûÀÎ À§Ä¡·Î ÀÌµ¿½ÃÄÑ ÁÝ´Ï´Ù.

Çü ½Ä

windowObject.moveToAbsolute(x, y)

x
ÀÌµ¿ÇÒ À§Ä¡ÀÇ x ÁÂÇ¥

y
ÀÌµ¿ÇÒ À§Ä¡ÀÇ y ÁÂÇ¥

°´ Ã¼

layer


open 메소드(document 객체)

3 [image] 2

브라우저에 출력하기 위해 문서를 열어줍니다.
( 1. mimeType에 의해 문서에 출력할 형식이 지정됩니다.
2. open() 메소드에 열려진 문서는 close()로 닫을 수 있습니다.
3. mimeType을 지정하지 않으면 text/html이 기본 값으로 사용됩니다.

형 식

document.open(["mimeType"])

mimeType
다음과 같은 값들이 들어갈 수 있습니다.

text/html

text/plain

image/gif

image/jpeg

image/x-bitmap

plugin

객 체

document


atan2 ¸Þ¼Òµå

3 [image] 2

Arc Tangent °ªÀ» ¹ÝÈ¯ÇÏ¿© ÁÝ´Ï´Ù.

Çü ½Ä

Math.atan2(x, y)

x
(¼ýÀÚ,xÃà °ª)

y
(¼ýÀÚ,yÃà °ª)

°´ Ã¼

Math


open 메소드(window 객체)

3 [image] 2

새로운 브라우저 윈도우를 열어 줍니다.
( 1. 윈도우 속성을 지정하지 않으면 [File]-[New Web Browser]로 만들어지는 모양으로 나타납니다.
2. URL을 지정하지 않은 빈 화면이 나타납니다. )

형 식

[windowVar = ][window].open("URL", "windowName", ["windowFeatures"])

windowVar
새 윈도우의 이름

URL
새 윈도우에 보여줄 문서의 URL 주소

windowName
TARGET 속성에서 지정하는데 사용되는 윈도우 이름

windowFeatures
윈도우 속성

toolbar[=yes|no]|[=1|0]

location[=yes|no]|[=1|0]

directories[=yes|no]|[=1|0]

status[=yes|no]|[=1|0]

menubar[=yes|no]|[=1|0]

scrollbars[=yes|no]|[=1|0]

resizable[=yes|no]|[=1|0]

width=pixels

height=pixels

객 체

window


parse 메소드

3 [image] 2

1970년 1월 1일 이후의 시간을 밀리초로 만들어 반환하여 줍니다.
( 이 메소드는 "Dec 25, 1995"와 같은 문자열을 1970년 1월 1일 이후의 시간을 밀리초로 리턴합니다. )

형 식

Date.parse(dateString)

dateString
날짜를 나타내는 문자열

객 체

Date


parseFloat 함수

3 [image] 2

문자열을 부동소수점으로 변환하는 함수입니다.
( 1. 이 함수는 자바스크립트 내장 함수로서 객체에 속한 메소드가 아닙니다.
2. 숫자가 아닌 문자를 만난 경우에는 거기까지의 수만을 변환합니다.
3. 첫 문자가 숫자가 아닌 경우에는 0(윈도우즈)이나 NaN(유닉스)을 반환합니다. )

형 식

parseFloat(string)

string
부동소수점으로 바꾸고 싶은 문자열

객 체

없음


parseInt 함수

3 [image] 2

문자열을 정수로 변환하는 함수입니다.
( 1. 이 함수는 자바스크립트 내장 함수로서 객체에 속한 메소드가 아닙니다.
2. radix에 의해 몇 진수의 수로 변환할 것인가가 결정됩니다.
3. radix가 8이면 8진수, 10이면 10진수, 16이면 16진수가 됩니다. )

형 식

parseInt(문자열 [,radix])

radix
진수

객 체

없음


pop ¸Þ¼Òµå

4

¹è¿ÀÇ ¸¶Áö¸· ¿ä¼Ò¸¦ »èÁ¦ÇÑ ÈÄ ¿ä¼Ò¸¦ ¹ÝÈ¯ÇÕ´Ï´Ù..

Çü ½Ä

Array.pop()

°´ Ã¼

Array


pow ¸Þ¼Òµå

3 [image] 2

Áö¼ö °ªÀ» ¹ÝÈ¯ÇÕ´Ï´Ù.
( baseÀÇ exponent½Â °ª )

Çü ½Ä

Math.pow(base, exponent)

base
( ¼ýÀÚ, ¹Ø )

exponent
( ¼ýÀÚ, Áö¼ö)

°´ Ã¼

Math


print ¸Þ¼Òµå

5 [image] 4

ÇöÀç ÆäÀÌÁö¸¦ Ãâ·ÂÇÏ¿© ÁÝ´Ï´Ù.
( ºê¶ó¿ìÀúÀÇ Print ¹öÆ°À» ´©¸£´Â °Í°ú µ¿ÀÏÇÑ °á°úÀÔ´Ï´Ù.)

Çü ½Ä

windowObject.print()

°´ Ã¼

window


push ¸Þ¼Òµå

4

¹è¿¿¡ »õ·Î¿î ¿ä¼Ò¸¦ Ãß°¡ÇÏ°í »õ Å©±â¸¦ ¹ÝÈ¯ÇÕ´Ï´Ù.

Çü ½Ä

¹è¿.push(Ãß°¡ÇÒ ¿ä¼Ò, ...)

°´ Ã¼

Array


prompt 메소드

3 [image] 2

메시지와 입력 필드를 가진 다이얼로그 박스를 보여줍니다.
( 1. 사용자로부터 숫자나 문자열을 입력받고자 할 때 사용합니다.
2. 만약 inputDefault를 지정하지 않으면 <undefined>가 나타납니다. )

형 식

prompt(문자열, [inputDefault])

문자열
( 다이얼로그 박스에 나타나는 문자열)

inputDefault
( 문자, 숫자, 기존 객체의 속성. 입력 필드에 나타나는 값 )

객 체

window


random ¸Þ¼Òµå

3 [image] 2

³¼ö°ªÀ» ¹ÝÈ¯ÇÕ´Ï´Ù.
( À¯´Ð½º ½Ã½ºÅÛ¿¡¼¸¸ »ç¿ë °¡´ÉÇÕ´Ï´Ù.)

Çü ½Ä

Math.random()

°´ Ã¼

Math


back 메소드

3 [image] 2

히스토리 리스트의 현재 위치에서 뒤에 있는 URL 문서를 읽습니다.
( 1. 브라우저의 Back 버튼을 누르는 것과 동일한 결과입니다.
2. history.go(-1)과 동일한 결과입니다. )

형 식

histroy.back()

객 체

history, window


releaseEvents ¸Þ¼Òµå

4

Æ¯Á¤ ÀÌº¥Æ® Å¸ÀÔÀ» Àâ¾Æ³»´Â °ÍÀ» Ç®¾îÁÝ´Ï´Ù.

Çü ½Ä

°´Ã¼.releaseEvents()

°´ Ã¼

document


reload ¸Þ¼Òµå

4 [image] 3

ºê¶ó¿ìÀúÀÇ ÇöÀç ¹®¼¸¦ ´Ù½Ã ÀÐ¾îµéÀÌµµ·Ï ÇÏ¿© ÁÝ´Ï´Ù.

Çü ½Ä

location.reload([true])

°´ Ã¼

Location


replace ¸Þ¼Òµå

4 [image] 3

ÇöÀç È÷½ºÅä¸® ¿£Æ®¸®¸¦ Æ¯Á¤ URL·Î ¹Ù²Ù¾î ÀÐ¾îµéÀÌ°Ô ÇÕ´Ï´Ù.

¿ø Çü

location.replace("URL")

°´ Ã¼

Location


replace 메소드

4 [image] 4

정규식에 의한 문자열 치환. 정규식에 의한 문자열 치환 후 함수를 실행합니다.

형 식

문자열.replace(정규식, 숫자)

문자열객체.replace(정규식, 함수)

숫자
(치환할 문자열 수 )

함수
( 치환 후 실행할 함수)

객 체

String


reset ¸Þ¼Òµå

4 [image] 3

ÀÔ·Â ¾ç½Ä¿¡¼ Reset ¹öÆ°À» ´©¸£´Â °Í°ú µ¿ÀÏÇÑ È¿°ú¸¦ ¸¸µé¾î ÁÝ´Ï´Ù.

Çü ½Ä

ormName.reset()

°´ Ã¼

Form


resizeBy ¸Þ¼Òµå

4

À©µµ¿ì/·¹ÀÌ¾îÀÇ Å©±â¸¦ »ó´ëÀûÀÎ ±æÀÌ¸¸Å ¹Ù²Ù¾î ÁÝ´Ï´Ù.

Çü ½Ä

°´Ã¼ÀÌ¸§, resizeBy(°¡·Î±æÀÌ, ¼¼·Î±æÀÌ)

°´ Ã¼

window, layer


resizeTo ¸Þ¼Òµå

4

À©µµ¿ì/·¹ÀÌ¾îÀÇ Å©±â¸¦ Àý´ëÀûÀ¸·Î ¹Ù²Ù¾î ÁÝ´Ï´Ù.

Çü ½Ä

°´Ã¼ÀÌ¸§.resizeTo(°¡·Î±æÀÌ, ¼¼·Î±æÀÌ)

°´ Ã¼

window, layer


reverse ¸Þ¼Òµå

4 [image] 3

¹è¿¿¡ ÀÖ´Â ¿ä¼ÒµéÀÌ ¼ø¼¸¦ ¿ªÀ¸·Î ¹Ù²Ù¾î ÁÝ´Ï´Ù.

Çü ½Ä

¹è¿ÀÌ¸§.reverse()

°´ Ã¼

Array


round ¸Þ¼Òµå

3 [image] 2

¼ýÀÚ¸¦ ¹Ý¿Ã¸²ÇÏ¿© ¹ÝÈ¯ÇÏ¿© ÁÝ´Ï´Ù..

Çü ½Ä

Math.round(¼ýÀÚ)

°´ Ã¼

Math


routeEvent ¸Þ¼Òµå

4

ÀâÀº ÀÌº¥Æ® Å¸ÀÔÀ» ´Ù¸¥ °´Ã¼¿¡ Àü´ÞÇØ ÁÝ´Ï´Ù.

Çü ½Ä

°´Ã¼.routeEvent()

°´ Ã¼

document


Above ¼Ó¼º

4

ÇöÀç Á¤ÀÇµÇ´Â ·¹ÀÌ¾î À§¿¡ µé¾î°¥ ·¹ÀÌ¾î ÁöÁ¤ÇÕ´Ï´Ù.

Çü ½Ä

document.layers[index].Above

°´ Ã¼

layer


availHeight ¼Ó¼º

3 [image] 3

À©µµ¿ìÀÇ ÅÂ½ºÅ© ¹Ù¿Í °°Àº ÀÎÅÍÆäÀÌ½º¸¦ Á¦¿ÜÇÑ È¸éÀÇ ³ôÀÌÀÔ´Ï´Ù..

Çü ½Ä

screen.availHeight

°´ Ã¼

screen


selected 속성

3 [image] 2

리스트 박스의 옵션 메뉴가 선택되어 있는지를 알려주는 상태 변수입니다.
( 1. 옵션 메뉴가 선택되어 있으면 selected 속성의 값은 true가 되고 그렇지 않으면 falserk 됩니다.
2. 이 속성은 언제든지 설정될 수 있습니다..)

형 식

selectName.options[index].selected

selectName
select 객체의 NAME 속성

index
옵션 메뉴의 인덱스

객 체

options array


selectedIndex 속성

3 [image] 2

리스트 박스에서 현재 선택되어 있는 옵션 메뉴의 인덱스 값입니다.
( 1. 이 속성은 언제든지 설정할 수 있습니다.
2. selectedIndex 속성을 수정하자마자 해당되는 옵션 메뉴가 선택되어 집니다. )

형 식

selectName.selectedIndex

selectName.options.selectedIndex

selectName
select 객체의 NAME 속성

객 체

select, option array


self 속성

3 [image] 2

자기 윈도우나 자기 프레임을 가리키는 것입니다.
(1. 이 속성은 자바스크립트 코드를 좀더 읽기 쉽게 만들기 위해 사용됩니다.
2. 이 속성은 읽기 전용입니다.)

형 식

self.propertyName

self.methodName

propertyName
속성 이름

methodName
메소드 이름

객 체

frame, window


siblingAbove ¼Ó¼º

4

ÇöÀç Á¤ÀÇµÇ´Â ·¹ÀÌ¾î À§¿¡ µé¾î°¥ ·¹ÀÌ¾î ÁöÁ¤µË´Ï´Ù.
(µ¿ÀÏÇÑ »óÀ§ ·¹ÀÌ¾î ¹Ø¿¡ ÀÖ´Â ·¹ÀÌ¾î¸¸).

Çü ½Ä

document.layers[index].siblingAbove

°´ Ã¼

layer


siblingBelow ¼Ó¼º

4

ÇöÀç Á¤ÀÇµÇ´Â ·¹ÀÌ¾î ¹Ø¿¡ µé¾î°¥ ·¹ÀÌ¾î ÁöÁ¤ÇÕ´Ï´Ù.
(µ¿ÀÏÇÑ »óÀ§ ·¹ÀÌ¾î ¹Ø¿¡ ÀÖ´Â ·¹ÀÌ¾î¸¸)

Çü ½Ä

document.layers[index].siblingBelow

°´ Ã¼

layer


SQRT1_2 ¼Ó¼º

3 [image] 2

1/2ÀÇ Á¦°ö±Ù(¾à 0.707) ÀÔ´Ï´Ù..
( ÀÌ ¼Ó¼ºÀº ÀÐ±â Àü¿ëÀÔ´Ï´Ù. )

Çü ½Ä

Math.SQRT1_2

°´ Ã¼

Math


SQRT2 ¼Ó¼º

3 [image] 2

2ÀÇ Á¦°ö±Ù(¾à 1.414) ÀÔ´Ï´Ù.
( ÀÌ ¼Ó¼ºÀº ÀÐ±â Àü¿ëÀÔ´Ï´Ù.)

Çü ½Ä

Math.SQRT2

°´ Ã¼

Math


src ¼Ó¼º

4 [image] 3

ÀÌ¹ÌÁöÀÇ URL ÁÖ¼ÒÀÔ´Ï´Ù.
(1. <IMG> ÅÂ±×ÀÇ LOWSRC ¼Ó¼º¿¡ ¼³Á¤µÈ °ªÀ» °¡Áö°í ÀÖ´Ù.
2. ÀÌ ¼Ó¼º °ªÀ» ¾ðÁ¦µçÁö ¼³Á¤ÇÒ ¼ö ÀÖ´Ù. )

Çü ½Ä

imageName.src

°´ Ã¼

image


src ¼Ó¼º

4

·¹ÀÌ¾îÀÇ ³»¿ëÀ¸·Î µé¾î°¥ HTML ¹®¼ÀÇ URL ÁÖ¼ÒÀÔ´Ï´Ù.

Çü ½Ä

document.layers[index].src

°´ Ã¼

layer


status 속성

4 [image] 3

브라우저의 상태선에 보여줄 메시지를 설정하는 속성입니다.
( 이 속성은 언제든지 설정할 수 있다. )

형 식

windowReference.status

windowReference
윈도우 이름

객 체

window


availWidth ¼Ó¼º

3 [image] 3

À©µµ¿ìÀÇ ÅÂ½ºÅ© ¹Ù¿Í °°Àº ÀÎÅÍÆäÀÌ½º¸¦ Á¦¿ÜÇÑ È¸éÀÇ ³ÊºñÀÔ´Ï´Ù.

Çü ½Ä

screen.avilWidth

°´ Ã¼

screen


statusbar ¼Ó¼º

4

»óÅÂ¼±À» º¸¿©ÁÙÁöÀÇ ¿©ºÎ¸¦ ÁöÁ¤ÇÕ´Ï´Ù.

Çü ½Ä

windowName.statusbar = true/false

°´ Ã¼

window


suffixes ¼Ó¼º

3

MIME Å¸ÀÔÀ» Áö¿øÇÏ´Â ÆÄÀÏÀÇ È®ÀåÀÚÀÔ´Ï´Ù.

Çü ½Ä

navigator.mimeTypes[index].suffixes

navigator.mimeTypes[mimeTypeName].suffixes

°´ Ã¼

mimeTypes


target 속성

3 [image] 2

입력 양식에서는 Submit 결과를 보여주는 윈도우를 지정하는 속성이 되고, 링크의 경우에는 연결되어 있는 문서를 보여줄 윈도우를 지정하는 속성이 됩니다.
( 1. <A> 태그나 <FORM> 태그의 TARGET 속성 입니다.
2. 이 속성은 언제든지 설정될 수 있습니다. )

형 식

폼이름.target

links[index].target

index
링크의 인덱스

객 체

form, link


text 속성

3 [image] 2

옵션 메뉴의 제목으로 나타나게 되는 문자열입니다.1.
( 1 이 속성은 <OPTION> 태그 뒤에 따라오는 제목에 영향을 주는 문자열입니다.
2. 이 속성은 언제든지 설정할 수 있습니다. )

형 식

selectName.options[index].text

selectName
select 객체의 NAME 속성

index
옵션 메뉴의 인덱스

객 체

options array


title 속성

3 [image] 2

문서의 제목을 나타내는 문자열입니다.
(1. 이 속성은 <TITLE>과 </TITLE> 태그 사이에 들어간 문자열을 가리킵니다.
2. 만약 <TITLE> 태그를 사용하지 않았다면 이 속성은 null 값을 가집니다.
3. 이 속성은 읽기 전용입니다. )

형 식

document.title

객 체

document


toolbar ¼Ó¼º

4

Åø¹Ù¸¦ º¸¿©ÁÙÁöÀÇ ¿©ºÎ¸¦ ÁöÁ¤ÇÕ´Ï´Ù.

Çü ½Ä

windowName.toolbar = true/false

°´ Ã¼

window


top 속성

3 [image] 2

브라우저 계층구조에서 가장 최상위에 있는 윈도우를 가리킵니다.
( 이 속성은 읽기 전용이다. )

형 식

top.속성이름

top.메소드이름

top.프레임이름

객 체

window

특 징

이 속성은 읽기 전용이다.


top ¼Ó¼º

4

·¹ÀÌ¾îÀÇ »ó´Ü À§Ä¡ÀÔ´Ï´Ù.

Çü ½Ä

document.layers[index].top

°´ Ã¼

layer


type ¼Ó¼º

4 [image] 3

1. ÀÔ·Â ¾ç½ÄÀÇ Á¾·ù¸¦ ¾Ë·ÁÁÖ´Â ¼Ó¼ºÀÔ´Ï´Ù.

2. MIME Å¸ÀÔÀ» ¾Ë·ÁÁÖ´Â ¼Ó¼ºÀÔ´Ï´Ù.

Çü ½Ä

objectName.type

mimeTypes[index].type

°´ Ã¼

Button, Checkbox, FileUpload, Hidden, mimeType, Password, Radio, Reset, Select, Submit, Text, Textarea


undefined ¼Ó¼º

4

Á¤ÀÇµÇÁö ¾ÊÀº °ªÀÔ´Ï´Ù.

Çü ½Ä

undifined

°´ Ã¼

¾øÀ½


Below ¼Ó¼º

4

ÇöÀç Á¤ÀÇµÇ´Â ·¹ÀÌ¾î ¹Ø¿¡ µé¾î°¥ ·¹ÀÌ¾î¸¦ ÁöÁ¤ÇÕ´Ï´Ù.

Çü ½Ä

document.layers[index].Below

°´ Ã¼

layer


URL ¼Ó¼º

3 [image] 2

¹®¼ÀÇ URL ÁÖ¼ÒÀÔ´Ï´Ù.

Çü ½Ä

°´Ã¼ÀÌ¸§.type

°´ Ã¼

document


userAgent 속성

3 [image] 2

HTTP 프로토콜에서 클라이언트가 서버에게 보내는 데이터의 헤더에 들어가는 값입니다.
( 이 속성은 읽기 전용입니다. )

형 식

navigator.userAgent

객 체

navigator


value ¼Ó¼º

3 [image] 2

°´Ã¼ÀÇ VALUE ¼Ó¼º¿¡ ÇÒ´çµÇ¾î ÀÖ´Â ¹®ÀÚ¿ÀÔ´Ï´Ù.

Çü ½Ä

ÀÔ·Â¾ç½Ä.value

radioName[ÀÎµ¦½º].value

selectName.options.[ÀÎµ¦½º].value

°´ Ã¼

Button, checkbox, hidden, password, radio, reset, submit, text, textarea, options array


visibility ¼Ó¼º

4

·¹ÀÌ¾î¸¦ º¸¿©ÁÙÁöÀÇ ¿©ºÎ¸¦ ÁöÁ¤ÇÕ´Ï´Ù.

Çü ½Ä

document.layers[index].visility

°´ Ã¼

layer


vlinkColor 속성

3 [image] 2

한번 방문한 링크의 색깔을 나타내는 문자열입니다.

형 식

document.vlinkColor
( 1. <BODY> 태그의 VLINK 속성에 설정되어 있는 값입니다.
2. 16진수로 RGB를 표현하거나, 색깔 문자열을 사용하여 설정 합니다.)

객 체

document

특 징


vspace 속성

3 [image] 2

이미지의 위쪽/아래쪽 테두리와 텍스트 사이의 여백 길이입니다.
( 1. <IMG> 태그의 VSPACE 속성에 설정된 값을 나타냅니다.
2. 이미지를 Image() 생성자 함수로 만드는 경우에는 vspace는 0의 값을 가집니다. )

형 식

imageName.vspace

객 체

image


width 속성

4 [image] 3

이미지의 가로 길이.

형 식

imageName.width

객 체

Image

특 징

1. <IMG> 태그의 WIDTH 속성에 설정된 값을 나타낸다.

2. 길이는 픽셀 값이 될 수도 있고 백분율이 될 수도 있다.


width ¼Ó¼º

4

·¹ÀÌ¾îÀÇ °¡·Î ±æÀÌ.

Çü ½Ä

document.layers[index].width

°´ Ã¼

layer

Æ¯ Â¡

¾øÀ½


width ¼Ó¼º

4 [image] 3

È¸éÀÇ ³Êºñ(ÇÈ¼¿ ´ÜÀ§).

Çü ½Ä

screen.width

°´ Ã¼

screen

Æ¯ Â¡

¾øÀ½


window 속성

3 [image] 2

현재 윈도우나 프레임을 가리키는 속성.

형 식

window.propertyName

window.methodName

propertyName
속성 이름

methodName
메소드 이름

객 체

frame, window

특 징

이 속서은 자바스크립트 코드를 좀더 읽기 쉽게 만들기 위해 사용된다.


bgColor 속성

3 [image] 2

문서 배경색을 지정하는 문자열.

형 식

document.bgColor

객 체

document

특 징

1. <IMG> 태그의 BORDER 속성에 설정되어 있는 값.

2. 16진수로 RGB를 표현하거나, 색깔 문자열을 사용하여 설정한다.


zIndex ¼Ó¼º

4

·¹ÀÌ¾î »çÀÌÀÇ ¼ø¼.

Çü ½Ä

document.layers[index].zIndex

°´ Ã¼

layer

Æ¯ Â¡

¾øÀ½


border 속성

4 [image] 3

이미지 테두리 굵기.

형 식

imageName.border

객 체

image

특 징

1. <IMG> 태그의 BORDER 속성에 설정되어 있는 값.

2. image() 생성자 함수로 만드는 이미지의 경우에 border 속성 값은 0이 된다.


caller ¼Ó¼º

4

ÀÌ ÇÔ¼ö¸¦ È£ÃâÇÏ´Â ÇÔ¼öÀÇ ¸Å°³º¯¼ö Á¤º¸.

Çü ½Ä

argumentsObject.caller

argumentsObject
Arguments °´Ã¼

°´ Ã¼

Arguments

Æ¯ Â¡

¾øÀ½


callee ¼Ó¼º

4

ÀÌ ÇÔ¼ö°¡ È£ÃâÇÏ´Â ÇÔ¼öÀÇ ¸Å°³º¯¼ö Á¤º¸.

Çü ½Ä

argumentsObject.callee

argumentsObject
Atguments °´Ã¼

°´ Ã¼

Arguments

Æ¯ Â¡

¾øÀ½


checked 속성

3 [image] 2

현재 체크 박스나 라디오 버튼의 선택 여부를 가리키는 변수.

형 식

checkboxName.checked

radioName[index].checked

checkboxName
체크 박스 객체의 NAME 속성

radioName
라디오 버튼 객체의 NAME 속성

index
라디오 버튼 객체의 몇 번째 버튼인가를 나타내는 인덱스

객 체

checkbox, radio

특 징

1. 체크 박스나 라디오 버튼이 선택되어 있으면 이 값이 true가 되고 그렇지 않으면 false가 된다.

2. 이 속성 값은 언제든지 설정할 수 있다.


clip.top ¼Ó¼º

4

·¹ÀÌ¾î Å¬¸®ÇÎ ¿µ¿ªÀÇ »ó´Ü À§Ä¡.

Çü ½Ä

document.layers[index].clip.top

°´ Ã¼

layer

Æ¯ Â¡

¾øÀ½


clip.left ¼Ó¼º

4

·¹ÀÌ¾î Å¬¸®ÇÎ ¿µ¿ªÀÇ ÁÂÃø À§Ä¡.

Çü ½Ä

document.layers[index].clip.left

°´ Ã¼

layer

Æ¯ Â¡

¾øÀ½


action 속성

3 [image] 2

입력 양식에 들어간 값을 보낼 곳의 URL 주소 문자열.

원 형

formName.action

formName
입력 양식 이름이나 forms 배열의 요소

객 체

form

특 징

1. <FORM> 태그의 ACTION 속성에 설정되어 있는 값.

2. action 속성의 값은 언제든지 설정할 수 있다.


clip.right ¼Ó¼º

4

·¹ÀÌ¾î Å¬¸®ÇÎ ¿µ¿ªÀÇ ¿ìÃø À§Ä¡.

¿ø Çü

document.layers[index].clip.right

°´ Ã¼

layer

Æ¯ Â¡

¾øÀ½


clip.bottom ¼Ó¼º

4

·¹ÀÌ¾î Å¬¸®ÇÎ ¿µ¿ªÀÇ ÇÏ´Ü À§Ä¡.

Çü ½Ä

document.layers[index].clip.bottom

°´ Ã¼

layer

Æ¯ Â¡

¾øÀ½


colorDepth 속성

3 [image] 3

사용 가능한 색상 수.

형 식

screen, colorDepth

객 체

screen

특 징

1. 체크 박스나 라디오 버튼이 선택되어 있으면 이 값이 true가 되고 그렇지 않으면 false가 된다.

2. 이 속성 값은 언제든지 설정할 수 있다.


complete 속성

3

브라우저가 이미지를 완전하게 읽어들였는지를 가리키는 변수.

형 식

imageName.complete

객 체

image

특 징

1. 이미지를 완벽하게 읽어들였으면 true가 되고 그렇지 않으면 false가 된다.

2. 이 속성 값은 읽기 전용이다.


constructor ¼Ó¼º

4 [image] 3

»ý¼ºÀÚ ÇÔ¼ö¸¦ °¡¸®Å°´Â ¼Ó¼º.

Çü ½Ä

object.construct

°´ Ã¼

¸ðµç °´Ã¼

Æ¯ Â¡

¾øÀ½


cookie ¼Ó¼º

3 [image] 2

³×ºñ°ÔÀÌÅÍ¿¡ ÀÇÇØ cookies.txt ÆÄÀÏ¿¡ ÀúÀåÇØ³õÀº ÀÛÀº Å©±âÀÇ Á¤º¸ÀÎ cookie¸¦ ÀúÀåÇÏ´Â ¹®ÀÚ¿

¿ø Çü

document.cookie

°´ Ã¼

document

Æ¯ Â¡

º»¹® ÂüÁ¶


cookie ¼Ó¼º

3 [image] 2

³×ºñ°ÔÀÌÅÍ¿¡ ÀÇÇØ cookies.txt ÆÄÀÏ¿¡ ÀúÀåÇØ³õÀº ÀÛÀº Å©±âÀÇ Á¤º¸ÀÎ cookie¸¦ ÀúÀåÇÏ´Â ¹®ÀÚ¿ÀÔ´Ï´Ù.

Çü ½Ä

document.cookie

°´ Ã¼

document


current 속성

4

히스토리 리스트 중 현재 보고 있는 곳의 URL 주소입니다.
( 1. 이미지를 완벽하게 읽어들였으면 true가 되고 그렇지 않으면 false가 됩니다.
2. 이 속성 값은 읽기 전용입니다. )

형 식

history.current

객 체

history


defaultChecked 속성

3 [image] 2

체크 박스나 라디오 버튼이 처음부터 선택되어 있던 상태였는지를 알려줍니다.
( 1. <INPUT> 태그와 CHECKED 속성 값을 가집니다.
2. 체크 박스나 라디오 버튼이 원래 선택되어 있었다면 이 속성 값은 true가 되고 그렇지 않다면 false가 됩니다.
3. 이 값은 언제든지 설정할 수 있습니다. )

형 식

checkboxName.defaultChecked

radioName[index].defaultChecked

index
라디오 버튼 객체의 몇 번째 버튼인가를 나타내는 인덱스

객 체

checkbox, radio


defaultSelected 속성

3 [image] 2

리스트 박스의 옵션이 처음부터 선택된 상태였는지를 가리킵니다.
( 1. <OPTION> 태그의 SELECTED 속성 값을 가지고 있습니다.
2. 옵션 메뉴가 처음부터 선택되어 있었으면 이 속성 값은 true가 되고 그렇지 않으면 flase가 됩니다.
3. 이 속성 값은 언제든지 설정할 수 있습니다. )

형 식

selectName.options[index].defaultSelected

selectName
select 객체의 NAME 속성

index
select 객체의 옵션 순서를 알려주는 인덱스

객 체

options array


alinkColor 속성

3 [image] 2

마우스로 링크를 클릭하는 순간 색깔을 나타냅니다.
( 1. <BODY> 태그의 ALINK 속성에 설정되어 있는 값입니다.
2. 16진수로 RGB를 표현하거나, 색깔 문자열을 사용하여 설정합니다. )

형 식

document.alinkColor

객 체

document


defaultStatus 속성

3 [image] 2

브라우저 하단의 상태창에 기본적으로 보여주게 될 메시지입니다.
( 이 속성 값은 언제든지 설정할 수 있습니다. )

형 식

windowReference.defaultStatus

windowReference
윈도우 객체 이름

객 체

window


defaultValue 속성

3 [image] 2

password, text, textarea 객체의 초기에 나타나게 될 문자열입니다.
(1. 이 속성 값은 각 객체별로 다릅니다.
text : VALUE 속성 값
textarea : <TEXTAREA>와 </TEXTAREA> 태그 사이의 값
password : VALUE 속성 값에 관계없이 무조건 null
2. defaultValue에 세팅하면 기존에 정해놓은 초기 값이 바뀌게 됩니다.
3. 이 속성 값은 언제든지 바꿀 수 있습니다. )

형 식

passwordName
password 객체의 NAME 속성 값

textName
text 객체의 NAME 속성 값

textareaName
textarea 객체의 NAME 속성 값

객 체

password, text, textarea


description 속성

4 [image] 3

mimeTypes 객체나 plugins 객체에 대한 설명을 가지고 있는 속성입니다.
( MIME 타입이나 플러그인에 관한 일반 정보를 제공합니다. )

형 식

navigator.mimeTypes[index].description

navigator.mimeTypes[mimeTypeName].description

navigator.plugins[index].description

navigator.plugins[pluginName].description

객 체

mimeTypes, plugins


E ¼Ó¼º

3 [image] 2

¿ÀÀÏ·¯ »ó¼ö(¾à 2.718).
( E´Â »ó¼öÀÌ±â ¶§¹®¿¡ ÀÐ±â Àü¿ëÀÔ´Ï´Ù. )

Çü ½Ä

Math.E

°´ Ã¼

Math


elements ¼Ó¼º

3 [image] 2

ÀÔ·Â ¾ç½Ä¿¡ ÀÖ´Â °¢ ¿ä¼ÒµéÀ» ¹è¿·Î½á Æ÷ÇÔÇÑ º¯¼öÀÔ´Ï´Ù.

Çü ½Ä

form.elements[index]

°´ Ã¼

form


enabledPlugin 속성

3

지정된 MIME 타입을 처리할 플러그인 객체를 가리키는 속성입니다.
( 1. 이미지를 완벽하게 읽어들였으면 true가 되고 그렇지 않으면 false가 됩니다.
2. 이 속성 값은 읽기 전용입니다. )

형 식

navigator.mimeType[index].enabledPlugin

navigator.mimeType[mimeTypeName].enabledPlugin

객 체

mimeTypes


encoding 속성

3 [image] 2

입력 양식의 MIME 인코딩 방식을 지정한 문자열입니다.
( 1. <FORM> 태그의 ENCTYOE 속성 값입니다.
2. 이 속성 값은 언제든지 설정할 수 있습니다. )

형 식

formName.encoding

formName
입력 양식의 이름

객 체

form


fgColor 속성

3 [image] 2

문서에 나타나는 글자색을 지정하는 문자열입니다.
( 1. <BODY> 태그의 FGCOLOR 속성에 설정되어 있는 값입니다.
2. 16진수로 RGB를 표현하거나, 색깔 문자열을 사용하여 설정합니다. )

형 식

document.fgColor

객 체

document


filename ¼Ó¼º

3

ÇÃ·¯±×ÀÎÀÇ ÆÄÀÏ ÀÌ¸§ÀÔ´Ï´Ù.
( ÇÃ·¯±×ÀÎÀÇ ÆÄÀÏ Á¤º¸¸¦ Á¦°øÇÑ´Ù. )

Çü ½Ä

navigator.plugins[index].filename

navigator.plugins[pluginName].filename

°´ Ã¼

plugins


form ¼Ó¼º

3 [image] 2

°¢ °´Ã¼¸¦ Æ÷ÇÔÇÏ°í ÀÖ´Â Æû °´Ã¼ÀÔ´Ï´Ù.

Çü ½Ä

form

°´ Ã¼

Æû ³»ºÎ¿¡ µé¾î°¡´Â ¸ðµç °´Ã¼


anchors 속성

3 [image] 2

anchor 객체들을 배열로 모아놓은 것입니다.
( 1. <BODY> 태그의 ALINK 속성에 설정되어 있는 값입니다.
2. 16진수로 RGB를 표현하거나, 색깔 문자열을 사용하여 설정합니다. )

형 식

document.anchors[index]

객 체

document


forms ¼Ó¼º

3 [image] 2

¹®¼¿¡ Æ÷ÇÔµÇ¾î ÀÖ´Â ¸ðµç FormµéÀ» ¹è¿·Î °¡¸®Åµ´Ï´Ù.

Çü ½Ä

forms[index]

°´ Ã¼

document


frames ¼Ó¼º

3 [image] 2

ºê¶ó¿ìÀú¿¡ Æ÷ÇÔµÇ¾î ÀÖ´Â ¸ðµç ÇÁ·¹ÀÓµéÀ» ¹è¿·Î °¡Áö°í ÀÖ´Â º¯¼ö ÀÔ´Ï´Ù.

Çü ½Ä

frames[index]

°´ Ã¼

window


hash 속성

3 [image] 2

URL 주소에서 # 표시 뒤에 나오는 표식 이름입니다.
( 이 속성은 언제든지 설정할 수 있습니다. )

형 식

links[index].haxh

location.hash

index
링크 객체의 인덱스

객 체

link, location


height 속성

4 [image] 3

이미지의 세로 길이입니다.
( 1. <IMG> 태그의 HEIGHT 속성에 설정된 값을 나타냅니다.
2. 길이는 픽셀 값이 될 수도 있고 백분율이 될 수도 있습니다. )

형 식

imageName.height

객 체

image


height ¼Ó¼º

4

·¹ÀÌ¾îÀÇ ¼¼·Î ±æÀÌÀÔ´Ï´Ù.

Çü ½Ä

document.layers[index].height

°´ Ã¼

layer


height 속성

3 [image] 3

화면의 높이(픽셀 단위)입니다.
( 1. <IMG> 태그의 HEIGHT 속성에 설정된 값을 나타낸다.
2. 길이는 픽셀 값이 될 수도 있고 백분율이 될 수도 있다. )

형 식

screen.height

객 체

screen


host 속성

3 [image] 2

URL 주소의 "호스트 이름:포트" 부분입니다.
( 1. 이 속성에는 호스트 이름과 포트 번호가 들어 있다.
2. 만약 port 속성 값이 없는 경우에는 hostname 속성 값과 같게 됩니다.
3. 이 속성 값은 언제든지 설정할 수 있습니다. )

형 식

links[index].host

location.host

index
링크 객체의 인덱스

객 체

link, location


hostname 속성

3 [image] 2

URL 주소의 네트웍 호스트의 호스트와 도메인 이름입니다.(또는 IP 어드레스).
( 1. 이 속성에는 호스트 이름과 포트 번호가 들어 있습니다.
2. 이 속성은 port 속성 값이 없는 host 속성 값과 같습니다.
3. 이 속성은 언제든지 설정할 수 있습니다. )

형 식

links[index].hostname

location.hostname

index
링크 객체의 인덱스

객 체

link, location


herf 속성

3 [image] 2

URL 전체 주소입니다.
( 1. herf는 URL 전체 주소를 가리킵니다.
2. 이 속성은 언제든지 설정할 수 있습니다.
3. 다음의 두 예는 동일하게 취급됩니다.
 window.location.herf="http://www.netscape.com/"
window.location="http://www.netscape.com/" )

형 식

links[index].herf

location.herf

index
링크 객체의 인덱스

객 체

link, location


hspace 속성

4 [image] 3

이미지의 왼쪽/오른쪽 테두리와 텍스트 사이의 여백 길이입니다.
( 1. <IMG> 태그의 HSPACE 속성에 설정된 값을 나타냅니다.
2. 이미지를 image() 생성자 함수로 만드는 경우에는 hspace는 0의 값을 가집니다. )

형 식

imageName.hspace

객 체

image


appCodeName ¼Ó¼º

3 [image] 2

ºê¶ó¿ìÀúÀÇ ÄÚµå ÀÌ¸§À» ÀúÀåÇÑ ¹®ÀÚ¿ÀÔ´Ï´Ù.
( ÀÌ ¼Ó¼ºÀº ÀÐ±â Àü¿ëÀÌ´Ù. )

Çü ½Ä

navigator.appCodeName

°´ Ã¼

navigator


index 속성

3 [image] 2

selecr 객체에 있는 옵션 메뉴의 인덱스입니다.
( 이 속성은 옵션의 위치를 가리키는 값으로 0부터 시작합니다. )

형 식

selectName.options[indexValue].index

selectName
select 객체의 NAME 속성

indexValue
select 객체의 옵션을 가리키는 정수

객 체

options array


index ¼Ó¼º (JavaScript 1.2)

4

Á¤±Ô½Ä(Regular Expression)¿¡ ÀÏÄ¡ÇÏ´Â ¿ä¼Ò¸¦ °¡¸®Å°´Â ¹è¿ÀÔ´Ï´Ù.

Çü ½Ä

arrayObject.index

°´ Ã¼

Array


Infinity ¼Ó¼º

4

¹«ÇÑ´ëÀÇ ¼öÀÔ´Ï´Ù.

Çü ½Ä

Infinity

°´ Ã¼

¾øÀ½


innerHeight ¼Ó¼º

4

À©µµ¿ì¿¡¼ ³»¿ëÀÌ ³ªÅ¸³ª´Â ¿µ¿ªÀÇ ³ôÀÌÀÔ´Ï´Ù.

Çü ½Ä

windowName.innerHeight

°´ Ã¼

window


innerWidth ¼Ó¼º

4

À©µµ¿ì¿¡¼ ³»¿ëÀÌ ³ªÅ¸³ª´Â ¿µ¿ªÀÇ ³ÊºñÀÔ´Ï´Ù.

Çü ½Ä

windowName.innerWidth

°´ Ã¼

window


input ¼Ó¼º

4

Á¤±Ô½Ä(Regular Expression) °Ë»öÀ» ÇÑ ¹®ÀÚ¿ ÀÔ´Ï´Ù.

Çü ½Ä

arrayObject.input

°´ Ã¼

Array


language ¼Ó¼º

4 [image] 4

ÇöÀç ºê¶ó¿ìÀú°¡ »ç¿ëÇÏ°í ÀÖ´Â ¾ð¾î ÀÔ´Ï´Ù.
( ÀÌ ¼Ó¼ºÀº ¿É¼ÇÀÇ À§Ä¡¸¦ °¡¸®Å°´Â °ªÀ¸·Î 0ºÎÅÍ ½ÃÀÛÇÑ´Ù. )

Çü ½Ä

navigator.language

°´ Ã¼

navigator


lastModified ¼Ó¼º

3 [image] 2

ÇöÀç ¹®¼°¡ °¡Àå ÃÖ±Ù¿¡ º¯°æµÈ ³¯Â¥ ÀÔ´Ï´Ù.
( ÀÌ ¼Ó¼ºÀº ÀÐ±â Àü¿ëÀÔ´Ï´Ù. )

Çü ½Ä

document.lastModified

°´ Ã¼

document


left ¼Ó¼º

4

·¹ÀÌ¾îÀÇ ÁÂÃø À§Ä¡ ÀÔ´Ï´Ù..

Çü ½Ä

document.layers[index].left

°´ Ã¼

layer


length 속성

3 [image] 2

객체나 배열의 길이에 관한 정보를 제공합니다.
( 이 속성은 읽기 전용이다. )

형 식

[객체와 함께 사용될 때]

formName.length
Form에 포함되어 있는 요소의 개수

frameReference.length
프레임 안에 포함되어 있는 프레임의 개수

history.length
히스토리에 포함되어 있는 주소의 개수

radioName.length
라디오 객체에 포함되어 있는 라디오 버튼의 개수

selectName.length
리스트 박스에 포함되어 있는 옵션 메뉴의 개수

stringName.length
문자열의 길이

windowReference.length
최상위 윈도우 안에 포함되어 있는 프레임의 개수

[배열과 함께 사용될 때 : 각 배열의 길이]

anchors.length

elements.length

forms.length

frameReference.frames.length

windowReference.frames.length

links.length

selectName.options.length

객 체

frame, history, radio, select, string, window, objects, anchors, elements, forms, frames, links, options arrays


appName ¼Ó¼º

3 [image] 2

ºê¶ó¿ìÀúÀÇ ÀÌ¸§À» ÀúÀåÇÑ ¹®ÀÚ¿ ÀÔ´Ï´Ù.
( ÀÌ ¼Ó¼ºÀº ÀÐ±â Àü¿ëÀÌ´Ù. )

Çü ½Ä

navigator.appName

°´ Ã¼

navigator


linkColor 속성

3 [image] 2

하이퍼텍스트 링크의 글자색을 지정하는 문자열 입니다..
( 1. <BODY> 태그의 LINK 속서에 설정되어 있는 값입니다.
2. 16진수로 RGB를 표현하거나, 색깔 문자열을 사용하여 설정합니다. )

형 식

document.linkColor

객 체

document


links ¼Ó¼º

3 [image] 2

document °´Ã¼¿¡ Æ÷ÇÔµÇ¾î ÀÖ´Â link °´Ã¼ÀÇ ¹è¿ ¼Ó¼ºÀÔ´Ï´Ù.

Çü ½Ä

document.links[index]

°´ Ã¼

document


LN2 ¼Ó¼º

3 [image] 2

2ÀÇ ÀÚ¿¬·Î±×(¾à 0.693).
( ÀÌ ¼Ó¼º °ªÀº ÀÐ±â Àü¿ëÀÔ´Ï´Ù. )

Çü ½Ä

Math.LN2

°´ Ã¼

Math


LN10 ¼Ó¼º

4

10ÀÇ ÀÚ¿¬·Î±×(¾à 2.302).

Çü ½Ä

Math.LN10

°´ Ã¼

layer


locatiobar ¼Ó¼º

4

Location Bar¸¦ º¸¿©ÁÙÁöÀÇ ¿©ºÎ¸¦ ÁöÁ¤ÇÕ´Ï´Ù.

Çü ½Ä

windowName.locationbar = true/false

°´ Ã¼

window


LOG2E ¼Ó¼º

3 [image] 2

¹ØÀÌ 2ÀÎ eÀÇ ·Î±×(¾à 1.442).
( ÀÌ ¼Ó¼º °ªÀº ÀÐ±â Àü¿ëÀÌ´Ù. )

Çü ½Ä

Math.LOG2E

°´ Ã¼

Math


LOG10E ¼Ó¼º

3 [image] 2

¹ØÀÌ 10ÀÎ eÀÇ ·Î±×(¾à 0.434).
( ÀÌ ¼Ó¼º °ªÀº ÀÐ±â Àü¿ëÀÌ´Ù. )

Çü ½Ä

Math.LOG10E

°´ Ã¼

Math


lowscr 속성

3

문서에 보여주는 이미지의 저해상도 버전의 URL 주소입니다.
( 1. <IMG> 태그의 LOWSRC 속성에 설정된 값을 가지고 있다.
2. 이 속성 값을 언제든지 설정할 수 있다.
3. 브라우저는 먼저 LOWSRC로 지정한 저해상도 이미지를 보여준 후에 나중에 SRC로 지정한 고해상도 이미지를 보여주게 된다. )

형 식

imageName.lowsrc

객 체

image


MAX_VALUE ¼Ó¼º

4 [image] 3

ÀÚ¹Ù½ºÅ©¸³Æ®¿¡¼ Ç¥ÇöÇÒ ¼ö ÀÖ´Â °¡Àå Å« ¼öÀÔ´Ï´Ù.

Çü ½Ä

Math.MAX_VALUE

°´ Ã¼

Math


method 속성

3 [image] 2

입력 양식에 들어간 값을 서버에 보내는 방법을 설정해놓은 문자열입니다.
( 1. <FORM> 객체의 METHOD 속성 값(get이나 post).
2. 이 속성 값을 언제든지 설정할 수 있습니다. )

형 식

formName.method

formName
form의 이름

객 체

form


appVersion 속성

3 [image] 2

브라우저의 버전 정보를 저장한 문자열입니다.
(1. 브라우저 버전 정보는 다음과 같은 형식으로 나타나게 됩니다.
releaseNumber (platform; country)
releaseNumber : 네비게이터 버전 번호(예: 2.0b4)
platform : 네비게이터가 실행되는 운영체계(예: Win32)
country : "I" 인터내셔날 릴리즈, "U" 미국 국내용 릴리즈
2. 이 속성은 읽기 전용입니다. )

형 식

navigator.appVersion

객 체

navigator


menubar ¼Ó¼º

4

¸Þ´º¸¦ º¸¿©ÁÙÁöÀÇ ¿©ºÎ¸¦ ÁöÁ¤ÇÕ´Ï´Ù..

Çü ½Ä

windowName.menubar = true/false

°´ Ã¼

window


MIN_VALUE ¼Ó¼º

4 [image] 3

ÀÚ¹Ù½ºÅ©¸³Æ®¿¡¼ Ç¥ÇöÇÒ ¼ö ÀÖ´Â °¡Àå ÀÛÀº ¼öÀÔ´Ï´Ù.

Çü ½Ä

Math.MIN_VALUE

°´ Ã¼

Math


name 속성

3 [image] 2

객체의 일름을 포함하고 있는 문자열 입니다.
( 이 속성 값은 읽기 전용입니다. )

형 식

objectName.name

frameReference.naem

frameReference.frames.name

radioName[index].name

selectName.options.name

windowReference.name

windowReference.frames.name

objectName
객체의 NAME 속성

frameReference
라디오 객체의 NAME 속성

radioName
라디오 객체의 NAME 속성

selectName
select 객체의 NAME 속성

windowReference
윈도우 객체의 이름

객 체

anchor, button, checkbox, frame, hidden, password, radio, reset, select, submit, text, textarea, window, options array


NaN ¼Ó¼º

4 [image] 3

"Not a Number" ¼ýÀÚ°¡ ¾Æ´Õ´Ï´Ù

Çü ½Ä

Math.NaN

°´ Ã¼

Math


NEGATIVE_INFINITY ¼Ó¼º

4 [image] 3

À½ÀÇ ¹«ÇÑ´ë ÀÔ´Ï´Ù.

Çü ½Ä

Math.NRGATIVE_INFINITY

°´ Ã¼

Math


next ¼Ó¼º

4

È÷½ºÅä¸® ¸®½ºÆ® Áß µÚ¿¡ ÀÖ´Â °÷ÀÇ URL ÁÖ¼ÒÀÔ´Ï´Ù.

Çü ½Ä

history.next

°´ Ã¼

history


opener 속성

4 [image] 3

open() 메소드를 연 문서가 들어 있는 윈도우 입니다.
( 1. 이 속성은 open() 메소드를 포함하고 있는 문서가 있는 윈도우를 가리키는 것이 됩니다.
2. 이 속성은 언제든지 수정할 수 있습니다. )

형 식

window.opener

객 체

window


options ¼Ó¼º

3 [image] 2

select °´Ã¼ ¾È¿¡ Æ÷ÇÔµÈ ¿É¼ÇµéÀÇ ¹è¿ÀÔ´Ï´Ù..

Çü ½Ä

selectName.options[index]

°´ Ã¼

select


outerHeight ¼Ó¼º

4

À©µµ¿ì ¹Ù±ù Å×µÎ¸®ÀÇ ³ôÀÌÀÔ´Ï´Ù.

Çü ½Ä

windowName.outerHeight

°´ Ã¼

window


outerWidth ¼Ó¼º

4

À©µµ¿ìÀÇ ¹Ù±ù Å×µÎ¸®ÀÇ ³ÊºñÀÔ´Ï´Ù.

Çü ½Ä

windowName.outerWidth

°´ Ã¼

window


arguments ¼Ó¼º

4 [image] 4

ÇÔ¼öÀÇ ¸Å°³º¯¼ö Á¤º¸¸¦ ¹è¿·Î Á¦°øÇÕ´Ï´Ù.

Çü ½Ä

functionName.arguments

functionName
Function °´Ã¼ÀÇ ÀÌ¸§

°´ Ã¼

Function


pageX ¼Ó¼º

4

·¹ÀÌ¾îÀÇ ÁÂÃø À§Ä¡(ÀüÃ¼ ÆäÀÌÁö ±âÁØ)ÀÔ´Ï´Ù.

Çü ½Ä

document.layers[index].pageX

°´ Ã¼

layer


pageXOffset ¼Ó¼º

4

ÇöÀç À©µµ¿ì¿¡ ³ªÅ¸³ª´Â ÆäÀÌÁöÀÇ x ÁÂÇ¥ °ªÀÔ´Ï´Ù.

Çü ½Ä

windowName.pageXOffset

°´ Ã¼

window


pageY ¼Ó¼º

4

·¹ÀÌ¾îÀÇ »ó´Ü À§Ä¡(ÀüÃ¼ ÆäÀÌÁö ±âÁØ)ÀÔ´Ï´Ù.

Çü ½Ä

document.layers[index].pageY

°´ Ã¼

layer


pageYOffset ¼Ó¼º

4

ÇöÀç À©µµ¿ì¿¡ ³ªÅ¸³ª´Â ÆäÀÌÁöÀÇ y ÁÂÇ¥ °ªÀÔ´Ï´Ù.

Çü ½Ä

windowName.pageYOffset

°´ Ã¼

window


parent 속성

3 [image] 2

현재 윈도우나 프레임의 상위에 있는 윈도우나 프레임을 가리키는 것 입니다.
( 1. 이 속성 값은 파생된 프레임에서 상위 프레임을 가리킬 때 사용합니다.
2. 이 속성 값은 읽기 전용입니다. )

형 식

parent.propertyName

parent.methodName

parent.frameName

parent.frames[index]

propertyName
속성 이름

methodName
메소드 이름

frameName / frames[index]
프레임 이름

객 체

frame, window


parentLayer ¼Ó¼º

4

ÇöÀç ·¹ÀÌ¾î¸¦ Æ÷ÇÔÇÏ°í ÀÖ´Â ·¹ÀÌ¾îÀÇ ÀÌ¸§ÀÔ´Ï´Ù.

Çü ½Ä

document.layers[index].parentLayer

°´ Ã¼

layer


pathname 속성

3 [image] 2

URL 조소에서 디렉토리 이름 부분을 가리키고 있는 문자열입니다.
( 이 속성은 언제든지 설정할 수 있습니다. )

형 식

links[index].pathname

location.pathname

index
링크 객체를 가리키는 인덱스

객 체

link, location


personalbar ¼Ó¼º

4

Personal Bar¸¦ º¸¿©ÁÙÁöÀÇ ¿©ºÎ¸¦ ÁöÁ¤ÇÕ´Ï´Ù.

Çü ½Ä

windowName.personalbar = true/false

°´ Ã¼

window


Pl ¼Ó¼º

3 [image] 2

¿øÁÖÀ²(¾à 3.14159).
( ÀÌ ¼Ó¼ºÀº ¾ðÁ¦µçÁö ¼³Á¤ÇÒ ¼ö ÀÖ½À´Ï´Ù. )

Çü ½Ä

Math.Pl

°´ Ã¼

Math


pixelDepth ¼Ó¼º

3

ÇÑ ÇÈ¼¿´ç ºñÆ® ¼öÀÔ´Ï´Ù.

Çü ½Ä

screen.pixelDepth

°´ Ã¼

screen


arity ¼Ó¼º

3 [image] 3

Function °´Ã¼¿¡ »ç¿ëµÈ ¸Å°³º¯¼öÀÇ °³¼ö(ÇÔ¼ö ¿ÜºÎ¿¡¼ »ç¿ë)ÀÔ´Ï´Ù.

Çü ½Ä

functionName.arity

functionname
Function °´Ã¼ÀÇ ÀÌ¸§

°´ Ã¼

Function


platform ¼Ó¼º

4 [image] 4

ºê¶ó¿ìÀú°¡ »ç¿ëÇÏ°í ÀÖ´Â ½Ã½ºÅÛÀÇ Á¾·ùÀÔ´Ï´Ù.

Çü ½Ä

navigator.platform

°´ Ã¼

navigator


POSITIVE_INFINITY ¼Ó¼º

4 [image] 3

¾çÀÇ ¹«ÇÑ´ë.

Çü ½Ä

Math.POSITIVE_INFINITY

°´ Ã¼

Math


port 속성

3 [image] 2

서버가 통신을 위해 사용하는 특정 통신 포드를 가리키는 문자열입니다.
( 이 속성 값은 언제든지 설정할 수 있습니다. )

형 식

links[index].port

location.port

index
링크 객체의 인덱스

객 체

link, location


preference ¼Ó¼º

4

ÀÎÁõ¹ÞÀº ½ºÅ©¸³Æ®°¡ Preference °ª ¼³Á¤ÇÏ°Å³ª °¡Á®¿À´Âµ¥ »ç¿ëÇÕ´Ï´Ù .

Çü ½Ä

navigator.preference

°´ Ã¼

navigator


previous ¼Ó¼º

4

È÷½ºÅä¸® ¸®½ºÆ® Áß ¾Õ¿¡ ÀÖ´Â °÷ÀÇ URL ÁÖ¼ÒÀÔ´Ï´Ù.

Çü ½Ä

histoty.previous

°´ Ã¼

history


protocol 속성

3 [image] 2

URL 주소의 처음 부분에 나오는 문자열(":" 기호 앞).
(1. 프로토콜은 URL 주소에 접근하는 방법을 지정하는 것입니다.
2. 하이퍼텍스트 연결인 경우에는 "http:"를 사용하고, 자바스크립트 코드인 경우에는 "javascript:"를 사용합니다.
3. 이 속성 값은 언제든지 설정할 수 있습니다. )

형 식

links[index].protocol

location.protocol

index
링크 객체의 인덱스

객 체

link, location


prototype 속성

4 [image] 3

객체에 새로운 속성을 추가시켜주기 위한 것입니다.
( prototype으로 추가된 속성은 해당 객체로 만든 모든 변수에 영향을 미칩니다. )

형 식

objectType.prototype.protertyName = value

객 체

Array, Date, Function, Image, Select option, String, User-defined objects


referrer ¼Ó¼º

3 [image] 2

»ç¿ëÀÚ°¡ ¸µÅ©¸¦ Å¬¸¯ÇßÀ» ¶§ ¸µÅ©°¡ Æ÷ÇÔµÇ¾î ÀÖ¾ú´ø ¹®¼ÀÇ URL ÁÖ¼ÒÀÔ´Ï´Ù.
( ÀÌ ¼Ó¼®Àº ÀÐ±â Àü¿ëÀÔ´Ï´Ù. )

Çü ½Ä

document.referrer

°´ Ã¼

document


scrollbars ¼Ó¼º

4

½ºÅ©·Ñ ¹Ù¸¦ º¸¿©ÁÙÁöÀÇ ¿©ºÎ¸¦ ÁöÁ¤ÇÕ´Ï´Ù.

Çü ½Ä

windowName.scrollbars = true/false

°´ Ã¼

window


search 속성

3 [image] 2

URL 주소 중 검색을 위해 사용되는 문자열(? 문자 뒤에 나오는 것)입니다.
( 이 속성은 언제든지 설정할 수 있습니다. )

형 식

links[index].search

location.search

index
링크 객체의 인덱스

객 체

link, location


onabort ÀÌº¥Æ® ÇÚµé·¯

4 [image] 3

»ç¿ëÀÚ°¡ ÀÌ¹ÌÁö Àü¼ÛÀ» °Á¦·Î Áß´ÜÇßÀ» ¶§ ¹ß»ýÇÏ´Â ÀÌº¥Æ® ÇÚµé·¯ ÀÔ´Ï´Ù.

°´ Ã¼

Image


onkeypress ÀÌº¥Æ® ÇÚµé·¯

4 [image] 4

Å°º¸µåÀÇ Å°¸¦ ´·¶À» ¶§ ¹ß»ýÇÏ´Â ÀÌº¥Æ® ÇÚµé·¯ ÀÔ´Ï´Ù.

°´ Ã¼

document, Image, link, textarea


onkeyup ÀÌº¥Æ® ÇÚµé·¯

4 [image] 4

Å°º¸µåÀÇ Å°¸¦ ´·¶´Ù ³õ¾ÒÀ» ¶§ ¹ß»ýÇÏ´Â ÀÌº¥Æ® ÇÚµé·¯ ÀÔ´Ï´Ù.

°´ Ã¼

document, Image, link, textarea


onload 이벤트 핸들러

2

윈도우에 문서를 읽었을 때나 이미지가 브라우저에 나타났을 때 발생하는 이벤트 핸들러 입니다.

객 체

window, Image


onmousedown ÀÌº¥Æ® ÇÚµé·¯

4 [image] 4

¸¶¿ì½º ¹öÆ°À» ´·¶À» ¶§ ¹ß»ýÇÏ´Â ÀÌº¥Æ® ÇÚµé·¯ ÀÔ´Ï´Ù.

°´ Ã¼

button, document, link


onmouseout ÀÌº¥Æ® ÇÚµé·¯

4 [image] 3

¸¶¿ì½º°¡ ÁöÁ¤µÈ ¿µ¿ªÀÌ³ª ¸µÅ© À§¿¡¼ ¹þ¾î³µÀ» ¶§ ¹ß»ýÇÏ´Â ÀÌº¥Æ® ÇÚµé·¯ ÀÔ´Ï´Ù..

°´ Ã¼

link, Area, link


onmouseover ÀÌº¥Æ® ÇÚµé·¯

3 [image] 2

¸¶¿ì½º°¡ ÁöÁ¤µÈ ¿µ¿ªÀÌ³ª ¸µÅ© À§¸¦ Áö³ª°¥ ¶§ ¹ß»ýÇÏ´Â ÀÌº¥Æ® ÇÚµé·¯ ÀÔ´Ï´Ù.

°´ Ã¼

link, Area, link


onmouseup ÀÌº¥Æ® ÇÚµé·¯

4 [image] 4

¸¶¿ì½º ¹öÆ°À» ´·¶´Ù ³õ¾ÒÀ» ¶§ ¹ß»ýÇÏ´Â ÀÌº¥Æ® ÇÚµé·¯ ÀÔ´Ï´Ù.

°´ Ã¼

button, document, link


onmove ÀÌº¥Æ® ÇÚµé·¯

4

À©µµ¿ì¸¦ ÀÌµ¿ÇßÀ» ¶§ ¹ß»ýÇÏ´Â ÀÌº¥Æ® ÇÚµé·¯ ÀÔ´Ï´Ù.

°´ Ã¼

window


onreset ÀÌº¥Æ® ÇÚµé·¯

3 [image] 3

¸¶¿ì½º·Î Reset ¹öÆ°À» ¶§ ¹ß»ýÇÏ´Â ÀÌº¥Æ® ÇÚµé·¯ ÀÔ´Ï´Ù.

°´ Ã¼

Form


onresize ÀÌº¥Æ® ÇÚµé·¯

4

À©µµ¿ì Å©±â¸¦ ¹Ù²Ù¾úÀ» ¶§ ¹ß»ýÇÏ´Â ÀÌº¥Æ® ÇÚµé·¯ ÀÔ´Ï´Ù.

°´ Ã¼

window


onblur ÀÌº¥Æ® ÇÚµé·¯

3 [image] 2

°´Ã¼¿¡¼ focus¸¦ ÀÐ¾úÀ» ¶§ ¹ß»ýÇÏ´Â ÀÌº¥Æ® ÇÚµé·¯ ÀÔ´Ï´Ù.

°´ Ã¼

button, checkbox, fileupload, radio, reset, select, submit, text, textarea, window, frame


onselect ÀÌº¥Æ® ÇÚµé·¯

3 [image] 2

¸¶¿ì½º·Î ÀÔ·ÂµÈ ÅØ½ºÆ®¸¦ ¼±ÅÃÇÏ¿´À» ¶§ ¹ß»ýÇÏ´Â ÀÌº¥Æ® ÇÚµé·¯ ÀÔ´Ï´Ù.

°´ Ã¼

text, textarea


onsubmit ÀÌº¥Æ® ÇÚµé·¯

3 [image] 2

¸¶¿ì½º·Î Submit ¹öÆ°À» ´·¶À» ¶§ ¹ß»ýÇÏ´Â ÀÌº¥Æ® ÇÚµé·¯ ÀÔ´Ï´Ù.

°´ Ã¼

Form


onunload ÀÌº¥Æ® ÇÚµé·¯

3 [image] 2

À©µµ¿ìÀÇ ¹®¼°¡ ¾ø¾îÁú ¶§ ¹ß»ýÇÏ´Â ÀÌº¥Æ® ÇÚµé·¯ ÀÔ´Ï´Ù.

°´ Ã¼

window


onchange ÀÌº¥Æ® ÇÚµé·¯

3 [image] 2

°´Ã¼¿¡¼ ÀÔ·ÂµÇ°Å³ª ¼±ÅÃµÈ °ªÀ» ¹Ù²Ü ¶§ ¹ß»ýÇÏ´Â ÀÌº¥Æ® ÇÚµé·¯ ÀÔ´Ï´Ù.

°´ Ã¼

select, text, textarea


onclick ÀÌº¥Æ® ÇÚµé·¯

4 [image] 2

¸¶¿ì½º·Î °´Ã¼¸¦ Å¬¸¯ÇßÀ» ¶§ ¹ß»ýÇÏ´Â ÀÌº¥Æ® ÇÚµé·¯ ÀÔ´Ï´Ù.

°´ Ã¼

button, checkbox, document, radio, link, reset, submit


ondbclick ÀÌº¥Æ® ÇÚµé·¯

4 [image] 4

¸¶¿ì½º·Î °´Ã¼¸¦ ´õºíÅ¬¸¯ÇßÀ» ¶§ ¹ß»ýÇÏ´Â ÀÌº¥Æ® ÇÚµé·¯ ÀÔ´Ï´Ù.

°´ Ã¼

button, checkbox, document, radio, link, reset, submit


ondragdrop ÀÌº¥Æ® ÇÚµé·¯

4

¸¶¿ì½º·Î µå·¡±×-¾Ø-µå·Ó ÇßÀ» ¶§ ¹ß»ýÇÏ´Â ÀÌº¥Æ® ÇÚµé·¯ ÀÔ´Ï´Ù

°´ Ã¼

window


onerror ÀÌº¥Æ® ÇÚµé·¯

4 [image] 3

ÀÌ¹ÌÁö¸¦ Àü¼Û ¹Þ´Â Áß¿¡ ¿¡·¯°¡ »ý°åÀ» ¶§ ¹ß»ýÇÏ´Â ÀÌº¥Æ® ÇÚµé·¯ ÀÔ´Ï´Ù.

°´ Ã¼

Image, window


onfocus ÀÌº¥Æ® ÇÚµé·¯

3 [image] 2

°´Ã¼¿¡¼ focus¸¦ ¾ò¾úÀ» ¶§ ¹ß»ýÇÏ´Â ÀÌº¥Æ® ÇÚµé·¯ ÀÔ´Ï´Ù.

°´ Ã¼

button, checkbox, fileupload, radio, reset, select, submit, text, textarea, window, frame


onkeydown ÀÌº¥Æ® ÇÚµé·¯

4 [image] 4

Å°º¸µåÀÇ Å°¸¦ ´·¶À» ¶§ ¹ß»ýÇÏ´Â ÀÌº¥Æ® ÇÚµé·¯ ÀÔ´Ï´Ù.

°´ Ã¼

document, Image, link, textarea


B¸ñÂ÷

 Anchor °´Ã¼

Applet °´Ã¼

Area °´Ã¼

Argument °´Ã¼

Array °´Ã¼

Boolean °´Ã¼

Button °´Ã¼

Checkbox °´Ã¼

Date °´Ã¼

Document °´Ã¼

Event °´Ã¼

FileUpload °´Ã¼

Form °´Ã¼

Frame °´Ã¼

Function °´Ã¼

Hidden °´Ã¼

History °´Ã¼

Image °´Ã¼

Layer °´Ã¼

Link °´Ã¼

Location °´Ã¼

Math °´Ã¼

mimeType °´Ã¼

Navigator °´Ã¼

Number °´Ã¼

Option °´Ã¼

Password °´Ã¼

Plugin °´Ã¼

Radio °´Ã¼

Reset °´Ã¼

Screen °´Ã¼

Select °´Ã¼

String °´Ã¼

Submit °´Ã¼

Text °´Ã¼

Textarea °´Ã¼

Wondow °´Ã¼


¸ñÂ÷

 abs ¸Þ¼Òµå

acos ¸Þ¼Òµå

alert ¸Þ¼Òµå

anchor ¸Þ¼Òµå

apply ¸Þ¼Òµå

asin ¸Þ¼Òµå

atan ¸Þ¼Òµå

atan2 ¸Þ¼Òµå

back ¸Þ¼Òµå

big ¸Þ¼Òµå

blink ¸Þ¼Òµå

blur ¸Þ¼Òµå

bold ¸Þ¼Òµå

call ¸Þ¼Òµå

captureEvents ¸Þ¼Òµå

ceil ¸Þ¼Òµå

charAt ¸Þ¼Òµå

charCodeAt ¸Þ¼Òµå

clearInterval ¸Þ¼Òµå

clearTimeout ¸Þ¼Òµå

click ¸Þ¼Òµå

close(document °´Ã¼)¸Þ¼Òµå

close(window °´Ã¼)¸Þ¼Òµå

concat ¸Þ¼Òµå

confirm ¸Þ¼Òµå

cos ¸Þ¼Òµå

escape ÇÔ¼ö

eval ÇÔ¼ö

exp ¸Þ¼Òµå

find ¸Þ¼Òµå

fixed ¸Þ¼Òµå

floor °´Ã¼

focus ¸Þ¼Òµå

fontcolor ¸Þ¼Òµå

forward ¸Þ¼Òµå

fontsize ¸Þ¼Òµå

fromCahrCode ¸Þ¼Òµå

getDate ¸Þ¼Òµå

getDay ¸Þ¼Òµå

getHours ¸Þ¼Òµå

getMiliseconds ¸Þ¼Òµå (JavaScript 1.3) (JScript 3.0)

getMinutes ¸Þ¼Òµå

getMonth ¸Þ¼Òµå

getSeconds ¸Þ¼Òµå

getSelection ¸Þ¼Òµå

getTime ¸Þ¼Òµå

getTimezoneOffset ¸Þ¼Òµå

getUTCDate ¸Þ¼Òµå

getUTCDay ¸Þ¼Òµå (JavaScript 1.3) (JScript 3.0)

getUTCFullTear ¸Þ¼Òµå

getUTCHours ¸Þ¼Òµå

getUTCMiliseconds ¸Þ¼Òµå

getUTCMinutes ¸Þ¼Òµå

getUTCMonth ¸Þ¼Òµå

getUTCSeconds ¸Þ¼Òµå

getYear ¸Þ¼Òµå

getFullYear ¸Þ¼Òµå

go ¸Þ¼Òµå

handleEvent ¸Þ¼Òµå

home ¸Þ¼Òµå

indexOf ¸Þ¼Òµå

isFinite ÇÔ¼ö

isNaN ÇÔ¼ö

talics ¸Þ¼Òµå

javaEnabled ¸Þ¼Òµå

join ¸Þ¼Òµå

lastIndexOf ¸Þ¼Òµå

link ¸Þ¼Òµå

load ¸Þ¼Òµå

log ¸Þ¼Òµå

match ¸Þ¼Òµå

max ¸Þ¼Òµå

min ¸Þ¼Òµå

moveAbove ¸Þ¼Òµå

moveBelow ¸Þ¼Òµå

moveBy ¸Þ¼Òµå

moveTo ¸Þ¼Òµå

moveToAbsolute ¸Þ¼Òµå

open ¸Þ¼Òµå(document °´Ã¼)

open ¸Þ¼Òµå(window °´Ã¼)

parse ¸Þ¼Òµå

parseFloat ÇÔ¼ö

parseInt ÇÔ¼ö

pop ¸Þ¼Òµå

pow ¸Þ¼Òµå

print ¸Þ¼Òµå

push ¸Þ¼Òµå

prompt ¸Þ¼Òµå

random ¸Þ¼Òµå

releaseEvents ¸Þ¼Òµå

reload ¸Þ¼Òµå

replace ¸Þ¼Òµå

replace ¸Þ¼Òµå

reset ¸Þ¼Òµå

resizeBy ¸Þ¼Òµå

resizeTo ¸Þ¼Òµå

reverse ¸Þ¼Òµå

round ¸Þ¼Òµå

routeEvent ¸Þ¼Òµå

scroll ¸Þ¼Òµå

scrollBy ¸Þ¼Òµå

scrollTo ¸Þ¼Òµå

search ¸Þ¼Òµå

select ¸Þ¼Òµå

setDate ¸Þ¼Òµå

setFullYear ¸Þ¼Òµå

setHours ¸Þ¼Òµå

setInterval ¸Þ¼Òµå

setMiliseconds ¸Þ¼Òµå

setMinutes ¸Þ¼Òµå

setMonth ¸Þ¼Òµå

setSeconds ¸Þ¼Òµå

setTime ¸Þ¼Òµå

setTimeout ¸Þ¼Òµå

setUTCDate ¸Þ¼Òµå

setUTCFullYear ¸Þ¼Òµå

setUTCHours ¸Þ¼Òµå

setUTCMiliseconds ¸Þ¼Òµå

setUTCMinutes ¸Þ¼Òµå

setUTCMonth ¸Þ¼Òµå

setUTCSeconds ¸Þ¼Òµå

setYear ¸Þ¼Òµå

setInterval ¸Þ¼Òµå

shift ¸Þ¼Òµå (JavaScript 1.2)

sin ¸Þ¼Òµå

slice ¸Þ¼Òµå

small ¸Þ¼Òµå

splice ¸Þ¼Òµå

split ¸Þ¼Òµå

sqrt ¸Þ¼Òµå

sort ¸Þ¼Òµå

split ¸Þ¼Òµå

strike ¸Þ¼Òµå

stop ¸Þ¼Òµå

sub ¸Þ¼Òµå

submit ¸Þ¼Òµå

substr ¸Þ¼Òµå

substring ¸Þ¼Òµå

sup ¸Þ¼Òµå

taint ¸Þ¼Òµå

tan ¸Þ¼Òµå

toGMTString ¸Þ¼Òµå

toLocaleString ¸Þ¼Òµå

toLowerCase ¸Þ¼Òµå

toSource ¸Þ¼Òµå

toString ¸Þ¼Òµå

toUTCString ¸Þ¼Òµå

unescape ÇÔ¼ö

unshift ¸Þ¼Òµå

untaint ¸Þ¼Òµå

UTC ¸Þ¼Òµå

write ¸Þ¼Òµå

writeIn ¸Þ¼Òµå


D¸ñÂ÷

 Above ¼Ó¼º

action ¼Ó¼º

alinkColor ¼Ó¼º

anchors ¼Ó¼º

appCodeName ¼Ó¼º

appName ¼Ó¼º

appVersion ¼Ó¼º

arguments ¼Ó¼º

arity ¼Ó¼º

availHeight ¼Ó¼º

availWidth ¼Ó¼º

Below ¼Ó¼º

bgColor ¼Ó¼º

border ¼Ó¼º

caller ¼Ó¼º

callee ¼Ó¼º

checked ¼Ó¼º

clip.top ¼Ó¼º

clip.left ¼Ó¼º

clip.right ¼Ó¼º

clip.bottom ¼Ó¼º

colorDepth ¼Ó¼º

complete ¼Ó¼º

constructor ¼Ó¼º

cookie ¼Ó¼º

cookie ¼Ó¼º

current ¼Ó¼º

defaultChecked ¼Ó¼º

defaultSelected ¼Ó¼º

defaultStatus ¼Ó¼º

defaultValue ¼Ó¼º

description ¼Ó¼º

E ¼Ó¼º

elements ¼Ó¼º

enabledPlugin ¼Ó¼º

encoding ¼Ó¼º

fgColor ¼Ó¼º

filename ¼Ó¼º

form ¼Ó¼º

forms ¼Ó¼º

frames ¼Ó¼º

hash ¼Ó¼º

height ¼Ó¼º

height ¼Ó¼º

height ¼Ó¼º

host ¼Ó¼º

hostname ¼Ó¼º

herf ¼Ó¼º

hspace ¼Ó¼º

index ¼Ó¼º

index ¼Ó¼º (JavaScript 1.2)

Infinity ¼Ó¼º

innerHeight ¼Ó¼º

innerWidth ¼Ó¼º

input ¼Ó¼º

language ¼Ó¼º

lastModified ¼Ó¼º

left ¼Ó¼º

length ¼Ó¼º

linkColor ¼Ó¼º

links ¼Ó¼º

LN2 ¼Ó¼º

LN10 ¼Ó¼º

locatiobar ¼Ó¼º

LOG2E ¼Ó¼º

LOG10E ¼Ó¼º

lowscr ¼Ó¼º

MAX_VALUE ¼Ó¼º

method ¼Ó¼º

menubar ¼Ó¼º

MIN_VALUE ¼Ó¼º

name ¼Ó¼º

NaN ¼Ó¼º

NEGATIVE_INFINITY ¼Ó¼º

next ¼Ó¼º

opener ¼Ó¼º

options ¼Ó¼º

outerHeight ¼Ó¼º

outerWidth ¼Ó¼º

pageX ¼Ó¼º

pageXOffset ¼Ó¼º

pageY ¼Ó¼º

pageYOffset ¼Ó¼º

parent ¼Ó¼º

parentLayer ¼Ó¼º

pathname ¼Ó¼º

personalbar ¼Ó¼º

Pl ¼Ó¼º

pixelDepth ¼Ó¼º

platform ¼Ó¼º

POSITIVE_INFINITY ¼Ó¼º

port ¼Ó¼º

preference ¼Ó¼º

previous ¼Ó¼º

protocol ¼Ó¼º

prototype ¼Ó¼º

referrer ¼Ó¼º

scrollbars ¼Ó¼º

search ¼Ó¼º

selected ¼Ó¼º

selectedIndex ¼Ó¼º

self ¼Ó¼º

siblingAbove ¼Ó¼º

siblingBelow ¼Ó¼º

SQRT1_2 ¼Ó¼º

SQRT2 ¼Ó¼º

src ¼Ó¼º

src ¼Ó¼º

status ¼Ó¼º

statusbar ¼Ó¼º

suffixes ¼Ó¼º

target ¼Ó¼º

text ¼Ó¼º

title ¼Ó¼º

toolbar ¼Ó¼º

top ¼Ó¼º

top ¼Ó¼º

type ¼Ó¼º

undefined ¼Ó¼º

URL ¼Ó¼º

userAgent ¼Ó¼º

value ¼Ó¼º

visibility ¼Ó¼º

vlinkColor ¼Ó¼º

vspace ¼Ó¼º

width ¼Ó¼º

width ¼Ó¼º

width ¼Ó¼º

window ¼Ó¼º

zIndex ¼Ó¼º


E¸ñÂ÷

 onabort ÀÌº¥Æ® ÇÚµé·¯

onblur ÀÌº¥Æ® ÇÚµé·¯

onchange ÀÌº¥Æ® ÇÚµé·¯

onclick ÀÌº¥Æ® ÇÚµé·¯

ondbclick ÀÌº¥Æ® ÇÚµé·¯

ondragdrop ÀÌº¥Æ® ÇÚµé·¯

onerror ÀÌº¥Æ® ÇÚµé·¯

onfocus ÀÌº¥Æ® ÇÚµé·¯

onkeydown ÀÌº¥Æ® ÇÚµé·¯

onkeypress ÀÌº¥Æ® ÇÚµé·¯

onkeyup ÀÌº¥Æ® ÇÚµé·¯

onload ÀÌº¥Æ® ÇÚµé·¯

onmousedown ÀÌº¥Æ® ÇÚµé·¯

onmouseout ÀÌº¥Æ® ÇÚµé·¯

onmouseover ÀÌº¥Æ® ÇÚµé·¯

onmouseup ÀÌº¥Æ® ÇÚµé·¯

onmove ÀÌº¥Æ® ÇÚµé·¯

onreset ÀÌº¥Æ® ÇÚµé·¯

onresize ÀÌº¥Æ® ÇÚµé·¯

onselect ÀÌº¥Æ® ÇÚµé·¯

onsubmit ÀÌº¥Æ® ÇÚµé·¯

onunload ÀÌº¥Æ® ÇÚµé·¯